summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-04-17 04:08:03 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-04-17 04:08:03 +0000
commitc239339e1ad65920490f81e559cbf01efc7e1aff (patch)
treea2c4279e9c28422fb39e7d3e32ab887131c67221 /xfce-base
parentVersion bump, thanks to Stefan Salewski (bug #315673). (diff)
downloadgentoo-2-c239339e1ad65920490f81e559cbf01efc7e1aff.tar.gz
gentoo-2-c239339e1ad65920490f81e559cbf01efc7e1aff.tar.bz2
gentoo-2-c239339e1ad65920490f81e559cbf01efc7e1aff.zip
Version bump, bug 312519. Patch by Gef Lebster
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-settings/ChangeLog8
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.6.4.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/xfce-base/xfce4-settings/ChangeLog b/xfce-base/xfce4-settings/ChangeLog
index 1316204a88d6..878112a8ca53 100644
--- a/xfce-base/xfce4-settings/ChangeLog
+++ b/xfce-base/xfce4-settings/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/xfce4-settings
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/ChangeLog,v 1.37 2010/04/16 21:59:09 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/ChangeLog,v 1.38 2010/04/17 04:08:03 darkside Exp $
+
+*xfce4-settings-4.6.4 (17 Apr 2010)
+
+ 17 Apr 2010; Jeremy Olexa <darkside@gentoo.org>
+ +xfce4-settings-4.6.4.ebuild:
+ Version bump, bug 312519. Patch by Gef Lebster
16 Apr 2010; Pacho Ramos <pacho@gentoo.org>
xfce4-settings-4.6.3-r1.ebuild:
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.6.4.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.6.4.ebuild
new file mode 100644
index 000000000000..8ef84a8ef7c2
--- /dev/null
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.6.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/xfce4-settings-4.6.4.ebuild,v 1.1 2010/04/17 04:08:03 darkside Exp $
+
+EAPI=2
+EAUTORECONF=yes
+inherit xfconf
+
+DESCRIPTION="Settings daemon for Xfce4"
+HOMEPAGE="http://www.xfce.org"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.6/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug +keyboard libnotify sound"
+
+RDEPEND=">=dev-libs/glib-2.12:2
+ >=dev-libs/dbus-glib-0.34
+ >=gnome-base/libglade-2
+ >=x11-libs/gtk+-2.10:2
+ >=x11-libs/libX11-1
+ >=x11-libs/libXcursor-1.1
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXrandr-1.1
+ >=x11-libs/libwnck-2.12
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfcegui4-4.6
+ >=xfce-base/xfconf-4.6
+ >=xfce-base/exo-0.3.100
+ libnotify? ( >=x11-libs/libnotify-0.1.3 )
+ keyboard? ( >=x11-libs/libxklavier-0.3 )
+ sound? ( media-libs/libcanberra )
+ !<x11-base/xorg-server-1.5.3"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ dev-util/pkgconfig
+ x11-proto/inputproto
+ x11-proto/xf86vidmodeproto"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ $(use_enable libnotify)
+ $(use_enable keyboard libxklavier)
+ $(use_enable sound sound-settings)
+ $(use_enable debug)"
+ DOCS="AUTHORS ChangeLog NEWS TODO"
+ PATCHES=( "${FILESDIR}/${PN}-4.6.3-exo.patch"
+ "${FILESDIR}/${PN}-4.7.1-libxklavier.patch" )
+}