summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-29 14:35:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-29 14:35:36 +0000
commit331f149247693a48148849f641863a534010fb94 (patch)
tree3c2d2d0a6d6ec1cf8b0f5f93b6d08f11035c07c2 /xfce-extra
parentpunt old, broken (diff)
downloadgentoo-2-331f149247693a48148849f641863a534010fb94.tar.gz
gentoo-2-331f149247693a48148849f641863a534010fb94.tar.bz2
gentoo-2-331f149247693a48148849f641863a534010fb94.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-power-manager/ChangeLog7
-rw-r--r--xfce-extra/xfce4-power-manager/files/xfce4-power-manager-1.0.3-libnotify-0.7.patch27
-rw-r--r--xfce-extra/xfce4-power-manager/xfce4-power-manager-1.0.3.ebuild7
3 files changed, 38 insertions, 3 deletions
diff --git a/xfce-extra/xfce4-power-manager/ChangeLog b/xfce-extra/xfce4-power-manager/ChangeLog
index 10d18fd5d014..b97cb43840dc 100644
--- a/xfce-extra/xfce4-power-manager/ChangeLog
+++ b/xfce-extra/xfce4-power-manager/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-extra/xfce4-power-manager
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-power-manager/ChangeLog,v 1.33 2011/01/17 15:11:27 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-power-manager/ChangeLog,v 1.34 2011/01/29 14:35:36 ssuominen Exp $
+
+ 29 Jan 2011; Samuli Suominen <ssuominen@gentoo.org>
+ xfce4-power-manager-1.0.3.ebuild,
+ +files/xfce4-power-manager-1.0.3-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
17 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org>
xfce4-power-manager-1.0.3.ebuild:
diff --git a/xfce-extra/xfce4-power-manager/files/xfce4-power-manager-1.0.3-libnotify-0.7.patch b/xfce-extra/xfce4-power-manager/files/xfce4-power-manager-1.0.3-libnotify-0.7.patch
new file mode 100644
index 000000000000..206524a507be
--- /dev/null
+++ b/xfce-extra/xfce4-power-manager/files/xfce4-power-manager-1.0.3-libnotify-0.7.patch
@@ -0,0 +1,27 @@
+http://bugzilla.xfce.org/show_bug.cgi?id=7205
+
+--- src/xfpm-notify.c
++++ src/xfpm-notify.c
+@@ -209,13 +209,20 @@
+ {
+ NotifyNotification *n;
+
+- n = notify_notification_new (title, message, NULL, NULL);
++ n = notify_notification_new (title, message, NULL
++#ifdef HAVE_LIBNOTIFY_07
++ );
++#else
++ , NULL);
++#endif
+
+ if ( icon_name )
+ xfpm_notify_set_notification_icon (n, icon_name);
+-
++
++#ifndef HAVE_LIBNOTIFY_07
+ if ( icon )
+ notify_notification_attach_to_status_icon (n, icon);
++#endif
+
+ notify_notification_set_urgency (n, (NotifyUrgency)urgency);
+
diff --git a/xfce-extra/xfce4-power-manager/xfce4-power-manager-1.0.3.ebuild b/xfce-extra/xfce4-power-manager/xfce4-power-manager-1.0.3.ebuild
index fbe21b9717cf..663fafd096ef 100644
--- a/xfce-extra/xfce4-power-manager/xfce4-power-manager-1.0.3.ebuild
+++ b/xfce-extra/xfce4-power-manager/xfce4-power-manager-1.0.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-power-manager/xfce4-power-manager-1.0.3.ebuild,v 1.3 2011/01/17 15:11:27 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-power-manager/xfce4-power-manager-1.0.3.ebuild,v 1.4 2011/01/29 14:35:36 ssuominen Exp $
EAPI=3
-inherit xfconf
+inherit flag-o-matic xfconf
DESCRIPTION="Power manager for the Xfce desktop environment"
HOMEPAGE="http://goodies.xfce.org/projects/applications/xfce4-power-manager"
@@ -37,6 +37,9 @@ DEPEND="${COMMON_DEPEND}
x11-proto/xproto"
pkg_setup() {
+ has_version ">=x11-libs/libnotify-0.7" && append-cppflags -DHAVE_LIBNOTIFY_07
+ PATCHES=( "${FILESDIR}"/${P}-libnotify-0.7.patch )
+
XFCONF=(
--disable-dependency-tracking
$(use_enable policykit polkit)