summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-10-30 22:08:28 +0000
committerChristoph Mende <angelos@gentoo.org>2008-10-30 22:08:28 +0000
commit36ae64491be18b50c62c4cbe51367aa2eb8621f2 (patch)
tree528a744dc8d4e0abb8f61ea766bb224843a03cf2 /xfce-extra
parentXfce-4.4.3 bump (diff)
downloadgentoo-2-36ae64491be18b50c62c4cbe51367aa2eb8621f2.tar.gz
gentoo-2-36ae64491be18b50c62c4cbe51367aa2eb8621f2.tar.bz2
gentoo-2-36ae64491be18b50c62c4cbe51367aa2eb8621f2.zip
Xfce-4.4.3 bump
(Portage version: 2.2_rc12/cvs/Linux 2.6.28-rc2 x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-mixer/ChangeLog10
-rw-r--r--xfce-extra/xfce4-mixer/xfce4-mixer-4.4.3.ebuild50
2 files changed, 58 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-mixer/ChangeLog b/xfce-extra/xfce4-mixer/ChangeLog
index b0c4ef837380..e001448280c7 100644
--- a/xfce-extra/xfce4-mixer/ChangeLog
+++ b/xfce-extra/xfce4-mixer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-mixer
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-mixer/ChangeLog,v 1.102 2007/12/17 18:51:07 jer Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-mixer/ChangeLog,v 1.103 2008/10/30 22:08:28 angelos Exp $
+
+*xfce4-mixer-4.4.3 (30 Oct 2008)
+
+ 30 Oct 2008; Christoph Mende <angelos@gentoo.org>
+ +xfce4-mixer-4.4.3.ebuild:
+ Xfce-4.4.3 bump
17 Dec 2007; Jeroen Roovers <jer@gentoo.org> xfce4-mixer-4.4.2.ebuild:
Stable for HPPA (bug #201747).
diff --git a/xfce-extra/xfce4-mixer/xfce4-mixer-4.4.3.ebuild b/xfce-extra/xfce4-mixer/xfce4-mixer-4.4.3.ebuild
new file mode 100644
index 000000000000..d98fac6af3b3
--- /dev/null
+++ b/xfce-extra/xfce4-mixer/xfce4-mixer-4.4.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-mixer/xfce4-mixer-4.4.3.ebuild,v 1.1 2008/10/30 22:08:28 angelos Exp $
+
+EAPI=1
+
+inherit eutils xfce44
+
+XFCE_VERSION=4.4.3
+
+xfce44
+xfce44_core_package
+
+# Bugs 166167 and 174296. Parallel make is dead in xfce4-mixer.
+xfce44_single_make
+
+DESCRIPTION="Volume control application (ALSA or OSS)"
+HOMEPAGE="http://www.xfce.org/projects/xfce4-mixer"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="alsa debug nls"
+
+RDEPEND=">=dev-libs/glib-2.6:2
+ dev-libs/libxml2
+ >=x11-libs/gtk+-2.6:2
+ >=xfce-base/xfce-mcs-manager-${XFCE_MASTER_VERSION}
+ >=xfce-base/xfce4-panel-${XFCE_MASTER_VERSION}
+ alsa? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}
+ dev-util/intltool"
+
+if use alsa; then
+ XFCE_CONFIG+=" --with-sound=alsa"
+fi
+
+XFCE_CONFIG+=" $(use_enable nls)"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ echo panel-plugin/mixer-prefbox.gob >> po/POTFILES.skip
+ echo src/main.c >> po/POTFILES.skip
+}
+
+src_install() {
+ xfce44_src_install
+ make_desktop_entry ${PN} "Volume Control" ${PN} AudioVideo
+}
+
+DOCS="AUTHORS ChangeLog NEWS NOTES README TODO"