summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-29 21:01:23 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-29 21:01:23 +0000
commit6b1819b56b0cab97caee771ce70fba94c7057473 (patch)
tree0e50250f974956852cc5b7891be3c6eb667d7601 /xfce-extra
parentbump to eapi3, use arrays etc (diff)
downloadgentoo-2-6b1819b56b0cab97caee771ce70fba94c7057473.tar.gz
gentoo-2-6b1819b56b0cab97caee771ce70fba94c7057473.tar.bz2
gentoo-2-6b1819b56b0cab97caee771ce70fba94c7057473.zip
bump to eapi3
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.4.0.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.4.0.ebuild b/xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.4.0.ebuild
index 29162fd378b9..a538ab82be35 100644
--- a/xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.4.0.ebuild
+++ b/xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.4.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.4.0.ebuild,v 1.3 2009/10/08 17:33:46 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.4.0.ebuild,v 1.4 2011/01/29 21:01:23 ssuominen Exp $
EAUTORECONF=yes
EINTLTOOLIZE=yes
-EAPI=2
+EAPI=3
inherit xfconf
DESCRIPTION="panel plugin that adds eyes which watch your every step"
@@ -25,14 +25,16 @@ DEPEND="${RDEPEND}
dev-util/intltool"
pkg_setup() {
- PATCHES=( "${FILESDIR}/${P}-libtool.patch" )
+ PATCHES=( "${FILESDIR}"/${P}-libtool.patch )
DOCS="AUTHORS ChangeLog README"
- XFCONF="--disable-dependency-tracking
- $(use_enable debug)"
+ XFCONF=(
+ --disable-dependency-tracking
+ $(use_enable debug)
+ )
}
src_prepare() {
sed -i -e "/^AC_INIT/s/eyes_version()/eyes_version/" \
- configure.in || die "sed failed"
+ configure.in || die
xfconf_src_prepare
}