summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-29 11:23:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-29 11:23:30 +0000
commitafa0a6ef3566c1102b309bd2b7b9b75d7ad59a46 (patch)
tree7a1e36a4277f6f4f76fe017962b4f248905b46d0 /xfce-extra
parentMove forward ~ppc keyword, not clear why this was dropped in the first place. (diff)
downloadgentoo-2-afa0a6ef3566c1102b309bd2b7b9b75d7ad59a46.tar.gz
gentoo-2-afa0a6ef3566c1102b309bd2b7b9b75d7ad59a46.tar.bz2
gentoo-2-afa0a6ef3566c1102b309bd2b7b9b75d7ad59a46.zip
Initial commit.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-weather-plugin/ChangeLog10
-rw-r--r--xfce-extra/xfce4-weather-plugin/metadata.xml5
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.7.3_p20110129.ebuild40
3 files changed, 55 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/ChangeLog b/xfce-extra/xfce4-weather-plugin/ChangeLog
new file mode 100644
index 000000000000..0f962dd3546a
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for xfce-extra/xfce4-weather-plugin
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-weather-plugin/ChangeLog,v 1.12 2011/01/29 11:23:30 ssuominen Exp $
+
+*xfce4-weather-plugin-0.7.3_p20110129 (29 Jan 2011)
+
+ 29 Jan 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-weather-plugin-0.7.3_p20110129.ebuild:
+ Initial commit.
+
diff --git a/xfce-extra/xfce4-weather-plugin/metadata.xml b/xfce-extra/xfce4-weather-plugin/metadata.xml
new file mode 100644
index 000000000000..d56729e92f8e
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>xfce</herd>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.7.3_p20110129.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.7.3_p20110129.ebuild
new file mode 100644
index 000000000000..717ba080f43a
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.7.3_p20110129.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.7.3_p20110129.ebuild,v 1.1 2011/01/29 11:23:30 ssuominen Exp $
+
+# http://bugzilla.xfce.org/show_bug.cgi?id=6965
+
+# git clone git://git.xfce.org/panel-plugins/xfce4-weather-plugin
+# wget "http://bugzilla.xfce.org/attachment.cgi?id=3428" -O xfce48.patch
+
+EAPI=3
+EAUTORECONF=yes
+inherit xfconf
+
+DESCRIPTION="A weather plug-in for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=x11-libs/gtk+-2.6:2
+ >=xfce-base/libxfce4util-4.3.90.2
+ >=xfce-base/libxfcegui4-4.3.90.2
+ >=xfce-base/xfce4-panel-4.3.99.1
+ >=dev-libs/libxml2-2.4"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-dependency-tracking
+ $(xfconf_use_debug)
+ )
+
+ DOCS="AUTHORS NEWS README TODO"
+}