summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/perl/perl-5.8.6-r4.ebuild4
-rw-r--r--sys-apps/groff/groff-1.19.1-r2.ebuild9
-rw-r--r--sys-apps/man/man-1.5p.ebuild9
-rw-r--r--sys-devel/libperl/libperl-5.8.6.ebuild17
-rw-r--r--sys-libs/gdbm/gdbm-1.8.3-r1.ebuild19
5 files changed, 26 insertions, 32 deletions
diff --git a/dev-lang/perl/perl-5.8.6-r4.ebuild b/dev-lang/perl/perl-5.8.6-r4.ebuild
index 4d3d60be8119..dc0a2f2cc6d6 100644
--- a/dev-lang/perl/perl-5.8.6-r4.ebuild
+++ b/dev-lang/perl/perl-5.8.6-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.6-r4.ebuild,v 1.2 2005/03/11 21:43:44 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.6-r4.ebuild,v 1.3 2005/03/14 23:46:06 vapier Exp $
inherit eutils flag-o-matic gcc multilib
@@ -17,7 +17,7 @@ LIBPERL="libperl.so.${PERLSLOT}.${SHORT_PV}"
LICENSE="Artistic GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390 ~sh"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="berkdb debug doc gdbm ithreads perlsuid uclibc"
PERL_OLDVERSEN="5.8.0 5.8.2 5.8.4 5.8.5"
diff --git a/sys-apps/groff/groff-1.19.1-r2.ebuild b/sys-apps/groff/groff-1.19.1-r2.ebuild
index 916bbee17542..2d90039c5835 100644
--- a/sys-apps/groff/groff-1.19.1-r2.ebuild
+++ b/sys-apps/groff/groff-1.19.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.19.1-r2.ebuild,v 1.11 2005/01/02 23:19:04 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.19.1-r2.ebuild,v 1.12 2005/03/14 23:45:52 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -11,16 +11,15 @@ SRC_URI="mirror://gnu/groff/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
IUSE="X"
-DEPEND="virtual/libc
- >=sys-apps/texinfo-4.7-r1"
+DEPEND=">=sys-apps/texinfo-4.7-r1"
PDEPEND=">=sys-apps/man-1.5k-r1"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# Fix the info pages to have .info extensions,
# else they do not get gzipped.
diff --git a/sys-apps/man/man-1.5p.ebuild b/sys-apps/man/man-1.5p.ebuild
index 04c23a19bb14..cf08b305b705 100644
--- a/sys-apps/man/man-1.5p.ebuild
+++ b/sys-apps/man/man-1.5p.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5p.ebuild,v 1.3 2005/03/04 23:31:53 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5p.ebuild,v 1.4 2005/03/14 23:46:26 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -11,11 +11,10 @@ SRC_URI="mirror://kernel/linux/utils/man/man-${NV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
IUSE="nls"
-DEPEND="virtual/libc
- >=sys-apps/sed-4"
+DEPEND=""
RDEPEND="sys-process/cronbase
>=sys-apps/groff-1.18
nls? ( sys-devel/gettext )"
@@ -24,7 +23,7 @@ S="${WORKDIR}/${PN}-${NV}"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# Make sure we can build with -j :)
epatch ${FILESDIR}/man-1.5p-parallel-make.patch
diff --git a/sys-devel/libperl/libperl-5.8.6.ebuild b/sys-devel/libperl/libperl-5.8.6.ebuild
index 3982324f3d0a..f8dfb9d1c00d 100644
--- a/sys-devel/libperl/libperl-5.8.6.ebuild
+++ b/sys-devel/libperl/libperl-5.8.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.6.ebuild,v 1.6 2005/03/08 23:53:13 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.6.ebuild,v 1.7 2005/03/14 23:46:11 vapier Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -52,15 +52,10 @@
#
# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
-IUSE="berkdb debug gdbm ithreads uclibc"
+IUSE="berkdb debug gdbm ithreads nocxx uclibc"
inherit eutils flag-o-matic toolchain-funcs
-# Perl has problems compiling with -Os in your flags
-use uclibc || replace-flags "-Os" "-O2"
-# This flag makes compiling crash in interesting ways
-filter-flags "-malign-double"
-
# The slot of this binary compat version of libperl.so
PERLSLOT="1"
@@ -73,7 +68,7 @@ HOMEPAGE="http://www.perl.org"
SLOT="${PERLSLOT}"
LIBPERL="libperl.so.${PERLSLOT}.${SHORT_PV}"
LICENSE="Artistic GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390 ~sh"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
# rac 2004.08.06
@@ -85,7 +80,7 @@ KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390 ~sh
RESTRICT="maketest"
-DEPEND="!uclibc? ( sys-apps/groff )
+DEPEND="!nocxx? ( sys-apps/groff )
berkdb? ( sys-libs/db )
gdbm? ( >=sys-libs/gdbm-1.8.0 )"
@@ -147,6 +142,10 @@ src_unpack() {
}
src_compile() {
+ # Perl has problems compiling with -Os in your flags
+ use uclibc || replace-flags "-Os" "-O2"
+ # This flag makes compiling crash in interesting ways
+ filter-flags "-malign-double"
export LC_ALL="C"
local myconf=""
diff --git a/sys-libs/gdbm/gdbm-1.8.3-r1.ebuild b/sys-libs/gdbm/gdbm-1.8.3-r1.ebuild
index e4862a93c00f..b3843d4ed9a1 100644
--- a/sys-libs/gdbm/gdbm-1.8.3-r1.ebuild
+++ b/sys-libs/gdbm/gdbm-1.8.3-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.8.3-r1.ebuild,v 1.11 2004/12/07 20:21:00 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.8.3-r1.ebuild,v 1.12 2005/03/14 23:45:23 vapier Exp $
-inherit gnuconfig flag-o-matic eutils libtool
+inherit flag-o-matic eutils libtool
DESCRIPTION="Standard GNU database libraries included for compatibility with Perl"
HOMEPAGE="http://www.gnu.org/software/gdbm/gdbm.html"
@@ -10,17 +10,14 @@ SRC_URI="mirror://gnu/gdbm/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
IUSE="berkdb"
-DEPEND="virtual/libc
- berkdb? ( =sys-libs/db-1* )"
-RDEPEND="virtual/libc"
+DEPEND="berkdb? ( =sys-libs/db-1* )"
src_unpack() {
unpack ${A}
- cd ${S}
- gnuconfig_update
+ cd "${S}"
append-flags -fomit-frame-pointer
uclibctoolize
}
@@ -32,7 +29,7 @@ src_compile() {
}
src_install() {
- make INSTALL_ROOT=${D} install || die
+ make INSTALL_ROOT="${D}" install || die
make \
includedir=/usr/include/gdbm \
@@ -42,7 +39,7 @@ src_install() {
dodoc ChangeLog NEWS README
# temp backwards support #32510
- if [ -e ${ROOT}/usr/$(get_libdir)/libgdbm.so.2 ] ; then
+ if [[ -e ${ROOT}/usr/$(get_libdir)/libgdbm.so.2 ]] ; then
cp ${ROOT}/usr/$(get_libdir)/libgdbm.so.2 ${D}/usr/$(get_libdir)/
touch ${D}/usr/$(get_libdir)/libgdbm.so.2
fi