summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-drivers/xf86-input-wacom/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-wacom/files/0.10.2-wheel-buttons.patch13
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.2-r1.ebuild58
3 files changed, 78 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-wacom/ChangeLog b/x11-drivers/xf86-input-wacom/ChangeLog
index e3ec80804317..d4cecfb1735e 100644
--- a/x11-drivers/xf86-input-wacom/ChangeLog
+++ b/x11-drivers/xf86-input-wacom/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-wacom
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.5 2009/12/01 09:40:44 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.6 2009/12/02 20:52:21 ikelos Exp $
+
+*xf86-input-wacom-0.10.2-r1 (02 Dec 2009)
+
+ 02 Dec 2009; Mike Auty <ikelos@gentoo.org>
+ +files/0.10.2-wheel-buttons.patch, +xf86-input-wacom-0.10.2-r1.ebuild:
+ Fix up wheel mouse bug with xf86-input-wacom-0.10.2.
*xf86-input-wacom-0.10.2 (01 Dec 2009)
diff --git a/x11-drivers/xf86-input-wacom/files/0.10.2-wheel-buttons.patch b/x11-drivers/xf86-input-wacom/files/0.10.2-wheel-buttons.patch
new file mode 100644
index 000000000000..2e9dba6a0b81
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/files/0.10.2-wheel-buttons.patch
@@ -0,0 +1,13 @@
+diff --git a/src/wcmCommon.c b/src/wcmCommon.c
+index e197973..ea3c937 100644
+--- a/src/wcmCommon.c
++++ b/src/wcmCommon.c
+@@ -616,6 +616,7 @@ static void sendWheelStripEvents(LocalDevicePtr local, const WacomDeviceState* d
+
+ switch (fakeButton & AC_TYPE)
+ {
++ case 0: /* no spec. action defined */
+ case AC_BUTTON:
+ /* send both button on/off in the same event for pad */
+ xf86PostButtonEvent(local->dev, is_absolute, fakeButton & AC_CODE,
+
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.2-r1.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.2-r1.ebuild
new file mode 100644
index 000000000000..4fce17382fb6
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.2-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.2-r1.ebuild,v 1.1 2009/12/02 20:52:21 ikelos Exp $
+
+EAPI="2"
+
+inherit linux-info x-modular eutils
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://anongit.freedesktop.org/~whot/xf86-input-wacom"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://people.freedesktop.org/~whot/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="hal debug"
+
+RDEPEND=">=x11-base/xorg-server-1.6
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ CONFIGURE_OPTIONS="$(use_enable debug)"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/0.10.2-wheel-buttons.patch"
+ x-modular_src_prepare
+}
+
+src_install() {
+ x-modular_src_install
+
+ if use hal; then
+ insinto /usr/share/hal/fdi/policy/10osvendor
+ newins "${S}"/fdi/wacom.fdi 11-x11-wacom.fdi
+ fi
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ if ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}