summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/atk/atk-1.0.3-r1.ebuild7
-rw-r--r--dev-libs/glib/glib-2.0.6-r1.ebuild5
2 files changed, 9 insertions, 3 deletions
diff --git a/dev-libs/atk/atk-1.0.3-r1.ebuild b/dev-libs/atk/atk-1.0.3-r1.ebuild
index 98a99aa536f4..6dcb3e43f6c4 100644
--- a/dev-libs/atk/atk-1.0.3-r1.ebuild
+++ b/dev-libs/atk/atk-1.0.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-1.0.3-r1.ebuild,v 1.1 2002/08/04 07:42:40 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-1.0.3-r1.ebuild,v 1.2 2002/08/04 08:43:37 spider Exp $
inherit libtool
@@ -25,7 +25,10 @@ src_compile() {
use doc \
&& myconf="${myconf} --enable-gtk-doc" \
|| myconf="${myconf} --disable-gtk-doc"
-
+ if [ -n "$DEBUG" ]; then
+ myconf="${myconf} --enable-debug"
+ fi
+
econf ${myconf} || die
emake || die
}
diff --git a/dev-libs/glib/glib-2.0.6-r1.ebuild b/dev-libs/glib/glib-2.0.6-r1.ebuild
index 326c281403d5..2be9b038cc17 100644
--- a/dev-libs/glib/glib-2.0.6-r1.ebuild
+++ b/dev-libs/glib/glib-2.0.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.0.6-r1.ebuild,v 1.1 2002/08/04 07:42:40 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.0.6-r1.ebuild,v 1.2 2002/08/04 08:43:37 spider Exp $
inherit libtool
@@ -29,6 +29,9 @@ src_compile() {
local myconf=""
use doc && myconf="${myconf} --enable-gtk-doc"
use doc || myconf="${myconf} --disable-gtk-doc"
+ if [ -n "$DEBUG" ]; then
+ myconf="${myconf} --enable-debug=yes"
+ fi
econf \
--with-threads=posix \