summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/devfsd/ChangeLog6
-rw-r--r--sys-fs/devfsd/Manifest12
-rw-r--r--sys-fs/devfsd/devfsd-1.3.25-r6.ebuild8
-rw-r--r--sys-fs/devfsd/devfsd-1.3.25-r7.ebuild8
-rw-r--r--sys-fs/dosfstools/ChangeLog6
-rw-r--r--sys-fs/dosfstools/Manifest12
-rw-r--r--sys-fs/dosfstools/dosfstools-2.10.ebuild11
-rw-r--r--sys-fs/dosfstools/dosfstools-2.9.ebuild11
8 files changed, 44 insertions, 30 deletions
diff --git a/sys-fs/devfsd/ChangeLog b/sys-fs/devfsd/ChangeLog
index caca68f40635..7f092651fdb5 100644
--- a/sys-fs/devfsd/ChangeLog
+++ b/sys-fs/devfsd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/devfsd
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/devfsd/ChangeLog,v 1.9 2004/03/18 22:26:06 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/devfsd/ChangeLog,v 1.10 2004/05/12 13:09:14 pappy Exp $
+
+ 12 May 2004; Alexander Gabert <pappy@gentoo.org> devfsd-1.3.25-r6.ebuild,
+ devfsd-1.3.25-r7.ebuild:
+ changed hardened-gcc logic to filter-flags
*devfsd-1.3.25-r6 (16 Mar 2004)
*devfsd-1.3.25-r7 (16 Mar 2004)
diff --git a/sys-fs/devfsd/Manifest b/sys-fs/devfsd/Manifest
index 0451746a2078..a4e72ca7f8ba 100644
--- a/sys-fs/devfsd/Manifest
+++ b/sys-fs/devfsd/Manifest
@@ -1,13 +1,13 @@
+MD5 54afa59a31935e89f5667bd8060493c8 ChangeLog 4562
+MD5 d0e5d2c4491863e44c4269d8f259db2b devfsd-1.3.25-r6.ebuild 1117
+MD5 10fda93c07caca6eded4a1dbc9cb0787 devfsd-1.3.25-r7.ebuild 1127
+MD5 16a55af09139afd5288f735dd8ae908f devfsd-1.3.25-r8.ebuild 1126
+MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 ebcf65c3f4a7675a7214fb8e28ba9f6d files/devfsd.conf 1555
MD5 d580e9efc3658a0e71a165b3b531d415 files/devfsd 245
MD5 41a6be534a78f5a0ad994b10e4134e6e files/devfsd-1.3.25-kernel-2.5.patch 3929
MD5 b64f47136c8298cec42e00df32c4276f files/devfsd-1.3.25-kernel-2.5.patch.bz2 1556
+MD5 9483221bc19786c3f7cb5df05a664477 files/devfsd-1.3.25-pic.patch 529
MD5 b8ec7858c1ac54c47302ca839a52188f files/digest-devfsd-1.3.25-r6 65
MD5 b8ec7858c1ac54c47302ca839a52188f files/digest-devfsd-1.3.25-r7 65
MD5 b8ec7858c1ac54c47302ca839a52188f files/digest-devfsd-1.3.25-r8 65
-MD5 9483221bc19786c3f7cb5df05a664477 files/devfsd-1.3.25-pic.patch 529
-MD5 d7f90083060c42ff4cd4a57375dc998d ChangeLog 4413
-MD5 5ffe8a57e635aae190cf3760472a4f44 devfsd-1.3.25-r6.ebuild 1251
-MD5 43cec295ff392b01b1773a01ee2dc721 devfsd-1.3.25-r7.ebuild 1261
-MD5 16a55af09139afd5288f735dd8ae908f devfsd-1.3.25-r8.ebuild 1126
-MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
diff --git a/sys-fs/devfsd/devfsd-1.3.25-r6.ebuild b/sys-fs/devfsd/devfsd-1.3.25-r6.ebuild
index 80158c46b539..a9c1501c2d65 100644
--- a/sys-fs/devfsd/devfsd-1.3.25-r6.ebuild
+++ b/sys-fs/devfsd/devfsd-1.3.25-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/devfsd/devfsd-1.3.25-r6.ebuild,v 1.2 2004/04/06 03:17:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/devfsd/devfsd-1.3.25-r6.ebuild,v 1.3 2004/05/12 13:09:14 pappy Exp $
IUSE=""
@@ -22,9 +22,6 @@ PROVIDE="virtual/dev-manager"
src_unpack() {
unpack ${A}
- # http://www.gentoo.org/proj/en/hardened/etdyn-ssp.xml or #gentoo-hardened/irc.freenode
- has_version "sys-devel/hardened-gcc" && append-flags "-yet_exec"
-
cd ${S}
cp GNUmakefile GNUmakefile.orig
sed -e "s:-O2:${CFLAGS}:g" \
@@ -35,6 +32,9 @@ src_unpack() {
}
src_compile() {
+
+ filter-flags -fPIC
+
make || die
}
diff --git a/sys-fs/devfsd/devfsd-1.3.25-r7.ebuild b/sys-fs/devfsd/devfsd-1.3.25-r7.ebuild
index a9a70fdd8093..3eeb7eaf7da9 100644
--- a/sys-fs/devfsd/devfsd-1.3.25-r7.ebuild
+++ b/sys-fs/devfsd/devfsd-1.3.25-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/devfsd/devfsd-1.3.25-r7.ebuild,v 1.2 2004/04/06 03:17:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/devfsd/devfsd-1.3.25-r7.ebuild,v 1.3 2004/05/12 13:09:14 pappy Exp $
IUSE=""
@@ -22,9 +22,6 @@ PROVIDE="virtual/dev-manager"
src_unpack() {
unpack ${A}
- # http://www.gentoo.org/proj/en/hardened/etdyn-ssp.xml or #gentoo-hardened/irc.freenode
- has_version "sys-devel/hardened-gcc" && append-flags "-yet_exec"
-
cd ${S}
epatch ${FILESDIR}/${P}-kernel-2.5.patch.bz2
@@ -36,6 +33,9 @@ src_unpack() {
}
src_compile() {
+
+ filter-flags -fPIC
+
make || die
}
diff --git a/sys-fs/dosfstools/ChangeLog b/sys-fs/dosfstools/ChangeLog
index b38319c98039..49a7a5b02875 100644
--- a/sys-fs/dosfstools/ChangeLog
+++ b/sys-fs/dosfstools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/dosfstools
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dosfstools/ChangeLog,v 1.10 2004/03/25 00:02:46 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dosfstools/ChangeLog,v 1.11 2004/05/12 13:12:34 pappy Exp $
+
+ 12 May 2004; Alexander Gabert <pappy@gentoo.org> dosfstools-2.10.ebuild,
+ dosfstools-2.9.ebuild:
+ changed hardened-gcc logic to filter-flags
25 Mar 2004; <plasmaroo@gentoo.org> dosfstools-2.10.ebuild,
files/dosfstools-2.10-2.6.headers.patch:
diff --git a/sys-fs/dosfstools/Manifest b/sys-fs/dosfstools/Manifest
index afef79a66b4e..5835abcf1404 100644
--- a/sys-fs/dosfstools/Manifest
+++ b/sys-fs/dosfstools/Manifest
@@ -1,10 +1,10 @@
-MD5 00becc2351a2f963d00f47fe1db34f2a ChangeLog 2502
-MD5 ee5a688d4e3874982dbef43956df4350 dosfstools-2.10.ebuild 1400
-MD5 96caf3a02fb0621de8dc2078717cfb21 dosfstools-2.9.ebuild 1355
-MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 d412ae45f619887f06153ce29d0e6fc8 ChangeLog 2648
+MD5 f19c50c0df353d0e5eebe0e15ab05770 dosfstools-2.10.ebuild 1438
MD5 3549613f8ab922686f96e974aecc7fd0 dosfstools-2.8-r3.ebuild 1141
-MD5 af6a07ad458852ef02d58a7a3658ca15 files/errno.patch 257
-MD5 6b58c7a85ca01fc79287563b903024ff files/dosfstools-2.10-2.6.headers.patch 357
+MD5 c9e22f34d51abba5bbce6e97a8f66c7a dosfstools-2.9.ebuild 1394
+MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 9eae6c4e222bcb616db95d21959a7688 files/digest-dosfstools-2.10 70
MD5 51b6aebebdca730b6a304548ec5c6da1 files/digest-dosfstools-2.8-r3 69
MD5 8102aee0611b0b9f797c88f7cc4fd503 files/digest-dosfstools-2.9 69
+MD5 6b58c7a85ca01fc79287563b903024ff files/dosfstools-2.10-2.6.headers.patch 357
+MD5 af6a07ad458852ef02d58a7a3658ca15 files/errno.patch 257
diff --git a/sys-fs/dosfstools/dosfstools-2.10.ebuild b/sys-fs/dosfstools/dosfstools-2.10.ebuild
index 655628e49e95..ac9f050b47bd 100644
--- a/sys-fs/dosfstools/dosfstools-2.10.ebuild
+++ b/sys-fs/dosfstools/dosfstools-2.10.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dosfstools/dosfstools-2.10.ebuild,v 1.8 2004/03/25 00:02:46 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dosfstools/dosfstools-2.10.ebuild,v 1.9 2004/05/12 13:12:34 pappy Exp $
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="dos filesystem tools"
SRC_URI="ftp://ftp.uni-erlangen.de/pub/Linux/LOCAL/dosfstools/${P}.src.tar.gz"
@@ -23,11 +23,14 @@ src_unpack() {
# Bug: 34785 hardened-gcc transparently adds -fPIC so we must filter
# that away because this package cant cope. (Nov 30 2003 -solar)
- has_version 'sys-devel/hardened-gcc' && \
- sed -i -e "s:^DEBUGFLAGS.*:DEBUGFLAGS=-yet_exec:g" Makefile
+ # has_version 'sys-devel/hardened-gcc' && \
+ # sed -i -e "s:^DEBUGFLAGS.*:DEBUGFLAGS=-yet_exec:g" Makefile
}
src_compile() {
+
+ filter-flags -fPIC
+
# this package does *not* play well with optimisations
# please dont change to: make OPTFLAGS="${CFLAGS}"
make || die
diff --git a/sys-fs/dosfstools/dosfstools-2.9.ebuild b/sys-fs/dosfstools/dosfstools-2.9.ebuild
index c379fc5fea62..bee53cd50f38 100644
--- a/sys-fs/dosfstools/dosfstools-2.9.ebuild
+++ b/sys-fs/dosfstools/dosfstools-2.9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dosfstools/dosfstools-2.9.ebuild,v 1.3 2004/02/15 17:31:05 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dosfstools/dosfstools-2.9.ebuild,v 1.4 2004/05/12 13:12:34 pappy Exp $
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="dos filesystem tools"
SRC_URI="ftp://ftp.uni-erlangen.de/pub/Linux/LOCAL/dosfstools/${P}.src.tar.gz"
@@ -22,11 +22,14 @@ src_unpack() {
# Bug: 34785 hardened-gcc transparently adds -fPIC so we must filter
# that away because this package cant cope. (Nov 30 2003 -solar)
- has_version 'sys-devel/hardened-gcc' && \
- sed -i -e "s:^DEBUGFLAGS.*:DEBUGFLAGS=-yet_exec:g" Makefile
+ # has_version 'sys-devel/hardened-gcc' && \
+ # sed -i -e "s:^DEBUGFLAGS.*:DEBUGFLAGS=-yet_exec:g" Makefile
}
src_compile() {
+
+ filter-flags -fPIC
+
# this package does *not* play well with optimisations
# please dont change to: make OPTFLAGS="${CFLAGS}"
make || die