summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/psmon/ChangeLog9
-rw-r--r--app-admin/psmon/psmon-1.39-r1.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/app-admin/psmon/ChangeLog b/app-admin/psmon/ChangeLog
index fcbbc571b7fa..f24b5af39133 100644
--- a/app-admin/psmon/ChangeLog
+++ b/app-admin/psmon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/psmon
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/psmon/ChangeLog,v 1.20 2012/06/27 16:04:44 kensington Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/psmon/ChangeLog,v 1.21 2013/07/31 04:37:18 qnikst Exp $
+
+*psmon-1.39-r1 (31 Jul 2013)
+
+ 31 Jul 2013; Alexander Vershilov <qnikst@gentoo.org> +psmon-1.39-r1.ebuild:
+ port psmon-1.39 to EAPI=5 due to #478714
27 Jun 2012; Michael Palimaka <kensington@gentoo.org> -psmon-1.0.4.ebuild,
-psmon-1.29.ebuild:
diff --git a/app-admin/psmon/psmon-1.39-r1.ebuild b/app-admin/psmon/psmon-1.39-r1.ebuild
new file mode 100644
index 000000000000..f0e68f42c30d
--- /dev/null
+++ b/app-admin/psmon/psmon-1.39-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/psmon/psmon-1.39-r1.ebuild,v 1.1 2013/07/31 04:37:18 qnikst Exp $
+
+EAPI="5"
+
+inherit perl-app
+
+DESCRIPTION="Monitors process table to slay aggressive, and spawn dead, processes"
+HOMEPAGE="http://www.psmon.com/"
+SRC_URI="http://www.psmon.com/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.6.0
+ dev-perl/config-general
+ dev-perl/Proc-ProcessTable
+ dev-perl/Unix-Syslog
+ virtual/perl-Getopt-Long"
+
+src_install() {
+ perl-module_src_install
+ insinto /etc
+ doins etc/psmon.conf
+}
+
+pkg_postinst() {
+ einfo "NOTICE: Please modify at least the NotifyEmail parameter found in"
+ einfo "the /etc/psmon.conf file"
+}