summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mail/checkpw/ChangeLog9
-rw-r--r--net-mail/checkpw/Manifest2
-rw-r--r--net-mail/checkpw/checkpw-1.01.ebuild64
-rw-r--r--net-mail/checkpw/files/digest-checkpw-1.011
-rw-r--r--net-mail/checkpw/metadata.xml12
5 files changed, 88 insertions, 0 deletions
diff --git a/net-mail/checkpw/ChangeLog b/net-mail/checkpw/ChangeLog
new file mode 100644
index 000000000000..2cc9da1025e6
--- /dev/null
+++ b/net-mail/checkpw/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-mail/checkpw
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpw/ChangeLog,v 1.1 2004/03/11 15:33:14 matsuu Exp $
+
+*checkpw-1.01 (12 Mar 2004)
+
+ 12 Mar 2004; <matsuu@gentoo.org> checkpw-1.01.ebuild:
+ Initial import.
+
diff --git a/net-mail/checkpw/Manifest b/net-mail/checkpw/Manifest
new file mode 100644
index 000000000000..2c76e9553335
--- /dev/null
+++ b/net-mail/checkpw/Manifest
@@ -0,0 +1,2 @@
+MD5 30582192608dce8c339e9648f5ec4923 checkpw-1.01.ebuild 1609
+MD5 60b13a4dcd71f0024bc66e32f783ee82 files/digest-checkpw-1.01 63
diff --git a/net-mail/checkpw/checkpw-1.01.ebuild b/net-mail/checkpw/checkpw-1.01.ebuild
new file mode 100644
index 000000000000..f2f26f4219e3
--- /dev/null
+++ b/net-mail/checkpw/checkpw-1.01.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpw/checkpw-1.01.ebuild,v 1.1 2004/03/11 15:33:14 matsuu Exp $
+
+inherit gcc
+
+DESCRIPTION="an implementation of the checkpassword interface that checks a password"
+HOMEPAGE="http://checkpw.sourceforge.net/checkpw/"
+SRC_URI="mirror://sourceforge/checkpw/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+IUSE="static"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64 ~ia64"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # the -s is from the original build
+ LDFLAGS="${LDFLAGS} -s"
+ use static && LDFLAGS="${LDFLAGS} -static"
+ echo "$(gcc-getCC) ${CFLAGS}" > conf-cc || die
+ echo "$(gcc-getCC) ${LDFLAGS}" > conf-ld || die
+ echo ".maildir" > conf-maildir || die
+
+ if [ -z "$QMAIL_HOME" ]; then
+ QMAIL_HOME="/var/qmail"
+ ewarn "QMAIL_HOME is null! Using default."
+ ewarn "Create the qmail user and set the homedir to your desired location."
+ fi
+ einfo "Using $QMAIL_HOME as qmail's default home directory."
+ echo ${QMAIL_HOME} > conf-qmail || die
+
+ sed -i -e 's/head -1/head -n 1/g' Makefile auto_*.do default.do || die
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ into /
+ dobin checkpw checkapoppw selectcheckpw loginlog
+ fperms 0700 /bin/checkpw /bin/checkapoppw /bin/selectcheckpw
+
+ dodoc CHANGES INSTALL README
+ docinto samples
+ dodoc run-{apop,both,multidir,multipw,pop,rules}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "How to set password:"
+ einfo
+ einfo " % echo 'YOURPASSWORD' > ~/.maildir/.password"
+ einfo " % chmod 600 ~/.maildir/.password"
+ einfo
+ einfo "Replace YOURPASSWORD with your plain password."
+ einfo
+}
diff --git a/net-mail/checkpw/files/digest-checkpw-1.01 b/net-mail/checkpw/files/digest-checkpw-1.01
new file mode 100644
index 000000000000..35e7f4b73a5a
--- /dev/null
+++ b/net-mail/checkpw/files/digest-checkpw-1.01
@@ -0,0 +1 @@
+MD5 209a7df3a649a9b2ae487131a6428260 checkpw-1.01.tar.gz 28498
diff --git a/net-mail/checkpw/metadata.xml b/net-mail/checkpw/metadata.xml
new file mode 100644
index 000000000000..982db8e5c58f
--- /dev/null
+++ b/net-mail/checkpw/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>matsuu@gentoo.org</email>
+</maintainer>
+<longdescription>checkpw checks password which is stored in a file in the Maildir directory.
+The file has read and write permissions to the user only.
+checkpw checks real user's password. For virtual users, vucheckpw is available
+http://checkpw.sourceforge.net/vucheckpw/</longdescription>
+</pkgmetadata>