summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/kpdf/ChangeLog6
-rw-r--r--kde-base/kpdf/kpdf-3.4.3-r4.ebuild6
-rw-r--r--kde-base/kpdf/kpdf-3.5.2.ebuild6
-rw-r--r--kde-base/kpdf/kpdf-3.5.3.ebuild6
4 files changed, 17 insertions, 7 deletions
diff --git a/kde-base/kpdf/ChangeLog b/kde-base/kpdf/ChangeLog
index 795debdfbddc..954f1d77f27f 100644
--- a/kde-base/kpdf/ChangeLog
+++ b/kde-base/kpdf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kpdf
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kpdf/ChangeLog,v 1.104 2006/06/02 00:47:15 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpdf/ChangeLog,v 1.105 2006/06/27 20:54:20 genstef Exp $
+
+ 27 Jun 2006; Stefan Schweizer <genstef@gentoo.org> kpdf-3.4.3-r4.ebuild,
+ kpdf-3.5.2.ebuild, kpdf-3.5.3.ebuild:
+ Change built_with_use poppler-bindings check to also allow qt3
02 Jun 2006; Diego Pettenò <flameeyes@gentoo.org> kpdf-3.5.3.ebuild:
Use the actually good patch.
diff --git a/kde-base/kpdf/kpdf-3.4.3-r4.ebuild b/kde-base/kpdf/kpdf-3.4.3-r4.ebuild
index 3718e08e0e74..23480b53c9e9 100644
--- a/kde-base/kpdf/kpdf-3.4.3-r4.ebuild
+++ b/kde-base/kpdf/kpdf-3.4.3-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kpdf/kpdf-3.4.3-r4.ebuild,v 1.9 2006/04/04 12:20:05 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpdf/kpdf-3.4.3-r4.ebuild,v 1.10 2006/06/27 20:54:20 genstef Exp $
KMNAME=kdegraphics
MAXKDEVER=$PV
@@ -21,7 +21,9 @@ PATCHES="${FILESDIR}/post-3.4.3-kdegraphics-CAN-2005-3193.diff
${FILESDIR}/post-3.4.3-kdegraphics-CVE-2006-0301.diff"
pkg_setup() {
- if ! built_with_use app-text/poppler-bindings qt; then
+ # check for qt still until it had a revision bump in both ~arch and stable.
+ if ! built_with_use app-text/poppler-bindings qt && \
+ ! built_with_use app-text/poppler-bindings qt3; then
eerror "This package requires app-text/poppler-bindings compiled with Qt support."
eerror "Please reemerge app-text/poppler-bindings with USE=\"qt\"."
die "Please reemerge app-text/poppler-bindings with USE=\"qt\"."
diff --git a/kde-base/kpdf/kpdf-3.5.2.ebuild b/kde-base/kpdf/kpdf-3.5.2.ebuild
index 512345aa8408..a856598bbcb9 100644
--- a/kde-base/kpdf/kpdf-3.5.2.ebuild
+++ b/kde-base/kpdf/kpdf-3.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kpdf/kpdf-3.5.2.ebuild,v 1.14 2006/06/01 09:24:45 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpdf/kpdf-3.5.2.ebuild,v 1.15 2006/06/27 20:54:20 genstef Exp $
KMNAME=kdegraphics
MAXKDEVER=$PV
@@ -26,7 +26,9 @@ PATCHES="${DISTDIR}/${P}-poppler.patch.bz2"
pkg_setup() {
kde_pkg_setup
- if ! built_with_use app-text/poppler-bindings qt; then
+ # check for qt still until it had a revision bump in both ~arch and stable.
+ if ! built_with_use app-text/poppler-bindings qt && \
+ ! built_with_use app-text/poppler-bindings qt3; then
eerror "This package requires app-text/poppler-bindings compiled with Qt support."
eerror "Please reemerge app-text/poppler-bindings with USE=\"qt\"."
die "Please reemerge app-text/poppler-bindings with USE=\"qt\"."
diff --git a/kde-base/kpdf/kpdf-3.5.3.ebuild b/kde-base/kpdf/kpdf-3.5.3.ebuild
index aef40605a6b4..7fc57f4f45bf 100644
--- a/kde-base/kpdf/kpdf-3.5.3.ebuild
+++ b/kde-base/kpdf/kpdf-3.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kpdf/kpdf-3.5.3.ebuild,v 1.3 2006/06/02 00:47:15 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpdf/kpdf-3.5.3.ebuild,v 1.4 2006/06/27 20:54:20 genstef Exp $
KMNAME=kdegraphics
MAXKDEVER=$PV
@@ -26,7 +26,9 @@ PATCHES="${DISTDIR}/${P}-poppler-bis.patch.bz2"
pkg_setup() {
kde_pkg_setup
- if ! built_with_use app-text/poppler-bindings qt; then
+ # check for qt still until it had a revision bump in both ~arch and stable.
+ if ! built_with_use app-text/poppler-bindings qt && \
+ ! built_with_use app-text/poppler-bindings qt3; then
eerror "This package requires app-text/poppler-bindings compiled with Qt support."
eerror "Please reemerge app-text/poppler-bindings with USE=\"qt\"."
die "Please reemerge app-text/poppler-bindings with USE=\"qt\"."