summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-nds/ypbind/ChangeLog5
-rw-r--r--net-nds/ypbind/files/ypbind.initd13
2 files changed, 12 insertions, 6 deletions
diff --git a/net-nds/ypbind/ChangeLog b/net-nds/ypbind/ChangeLog
index 4a2c223c11d7..50406a460d95 100644
--- a/net-nds/ypbind/ChangeLog
+++ b/net-nds/ypbind/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-nds/ypbind
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ChangeLog,v 1.38 2007/03/26 07:58:34 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ChangeLog,v 1.39 2007/05/23 07:20:55 eradicator Exp $
+
+ 23 May 2007; Jeremy Huddleston <eradicator@gentoo.org> files/ypbind.initd:
+ Fixed bug #176125 thanks to DominikBuerkle <dominik.buerkle@webde.de>.
26 Mar 2007; Alec Warner <antarus@gentoo.org> ypbind-1.19.1.ebuild,
ypbind-1.19.1-r1.ebuild:
diff --git a/net-nds/ypbind/files/ypbind.initd b/net-nds/ypbind/files/ypbind.initd
index 006050771d96..3d363cf2578e 100644
--- a/net-nds/ypbind/files/ypbind.initd
+++ b/net-nds/ypbind/files/ypbind.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/files/ypbind.initd,v 1.3 2006/04/10 19:57:11 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/files/ypbind.initd,v 1.4 2007/05/23 07:20:55 eradicator Exp $
depend() {
need net portmap
@@ -10,22 +10,25 @@ depend() {
start() {
ebegin "Starting ypbind"
- if [ -n "${YPBIND_OPTS}" ]; then YOPTS="-- ${YPBIND_OPTS}"; fi
+ if [[ -n "${YPBIND_OPTS}" ]]; then
+ YOPTS="-- ${YPBIND_OPTS}"
+ fi
start-stop-daemon --start --quiet --exec /usr/sbin/ypbind ${YOPTS}
- if [ -n "$?" ] ; then
+ local ret=$?
+ if [[ $ret -eq 0 ]] ; then
notfound=1
for i in 0 1 2 3 4 5 6 7 8 9
do
ypwhich &>/dev/null && { notfound=0; break; }
sleep 1
done
- if [ $notfound -eq 1 ] ; then
+ if [[ $notfound -eq 1 ]] ; then
eend 1 "No NIS server found"
else
eend 0
fi
else
- eend $?
+ eend $ret
fi
}