summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/gsl/files/digest-gsl-1.21
-rw-r--r--dev-libs/gsl/gsl-1.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/gsl/files/digest-gsl-1.2 b/dev-libs/gsl/files/digest-gsl-1.2
new file mode 100644
index 000000000000..a50887148787
--- /dev/null
+++ b/dev-libs/gsl/files/digest-gsl-1.2
@@ -0,0 +1 @@
+MD5 518ada58964a77203b380af5744aae0e gsl-1.2.tar.gz 2042073
diff --git a/dev-libs/gsl/gsl-1.2.ebuild b/dev-libs/gsl/gsl-1.2.ebuild
new file mode 100644
index 000000000000..0eadcefb3817
--- /dev/null
+++ b/dev-libs/gsl/gsl-1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gsl/gsl-1.2.ebuild,v 1.1 2002/08/07 07:35:30 george Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The GNU Scientific Library"
+SRC_URI="http://mirrors.rcn.net/pub/sourceware/gsl/${P}.tar.gz"
+HOMEPAGE="http://sources.redhat.com/gsl/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+#Avoid locking (can break parallel builds)
+ local myconf
+ myconf="--disable-libtool-lock"
+
+ econf ${myconf} || die
+ emake || die
+
+ #Uncomment the 'make check ...' line if you want to run the test suite.
+ #Note that the check.log file will be several megabytes in size.
+ # make check > check.log 2>&1 || die
+
+}
+
+src_install () {
+ einstall || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL KNOWN-PROBLEMS MACHINES NEWS
+
+}