summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/geany-plugins/ChangeLog8
-rw-r--r--dev-util/geany-plugins/geany-plugins-0.21.1.ebuild65
-rw-r--r--dev-util/geany-plugins/metadata.xml3
3 files changed, 75 insertions, 1 deletions
diff --git a/dev-util/geany-plugins/ChangeLog b/dev-util/geany-plugins/ChangeLog
index c1febcff42cb..88ff441cc667 100644
--- a/dev-util/geany-plugins/ChangeLog
+++ b/dev-util/geany-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/geany-plugins
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/geany-plugins/ChangeLog,v 1.10 2011/10/27 04:51:22 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/geany-plugins/ChangeLog,v 1.11 2011/11/20 05:15:39 binki Exp $
+
+*geany-plugins-0.21.1 (20 Nov 2011)
+
+ 20 Nov 2011; Nathan Phillip Brink <binki@gentoo.org>
+ +geany-plugins-0.21.1.ebuild, metadata.xml:
+ Bump to geany-plugins-0.21.1, closing bug #389087.
27 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
geany-plugins-0.19.ebuild, geany-plugins-0.20-r1.ebuild:
diff --git a/dev-util/geany-plugins/geany-plugins-0.21.1.ebuild b/dev-util/geany-plugins/geany-plugins-0.21.1.ebuild
new file mode 100644
index 000000000000..0ef92d8fe809
--- /dev/null
+++ b/dev-util/geany-plugins/geany-plugins-0.21.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/geany-plugins/geany-plugins-0.21.1.ebuild,v 1.1 2011/11/20 05:15:39 binki Exp $
+
+EAPI=4
+
+inherit autotools-utils versionator
+
+DESCRIPTION="A collection of different plugins for Geany"
+HOMEPAGE="http://plugins.geany.org/geany-plugins"
+SRC_URI="http://plugins.geany.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debugger devhelp enchant gpg gtkspell lua nls soup webkit"
+
+LINGUAS="be ca da de es fr gl ja pt pt_BR ru tr zh_CN"
+
+RDEPEND=">=dev-util/geany-$(get_version_component_range 1-2)
+ dev-libs/libxml2:2
+ dev-libs/glib:2
+ debugger? ( x11-libs/vte:0 )
+ devhelp? (
+ dev-util/devhelp
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ )
+ enchant? ( app-text/enchant )
+ gpg? ( app-crypt/gpgme )
+ gtkspell? ( app-text/gtkspell:2 )
+ lua? ( dev-lang/lua )
+ soup? ( net-libs/libsoup )
+ webkit? (
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/gdk-pixbuf:2
+ )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+
+src_configure() {
+ # GeanyGenDoc requires ctpl which isn't yet in portage
+ local myeconfargs=(
+ --docdir=/usr/share/doc/${PF}
+ --disable-cppcheck
+ --disable-extra-c-warnings
+ --disable-geanygendoc
+ --enable-geanymacro
+ --enable-geanynumberedbookmarks
+ --enable-gproject
+ --enable-tableconvert
+ --enable-xmlsnippets
+ $(use_enable enchant spellcheck)
+ $(use_enable gpg geanypg)
+ $(use_enable gtkspell)
+ $(use_enable lua geanylua)
+ $(use_enable nls)
+ $(use_enable soup updatechecker)
+ $(use_enable webkit webhelper)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/dev-util/geany-plugins/metadata.xml b/dev-util/geany-plugins/metadata.xml
index e940fd467c9c..a7a016185749 100644
--- a/dev-util/geany-plugins/metadata.xml
+++ b/dev-util/geany-plugins/metadata.xml
@@ -6,7 +6,10 @@
<name>Nathan Phillip Brink</name>
</maintainer>
<use>
+ <flag name='debugger'>Enable the debugger plugin which interfaces with <pkg>sys-devel/gdb</pkg></flag>
+ <flag name='devhelp'>Enable the devhelp plugin which integrates <pkg>dev-util/devhelp</pkg></flag>
<flag name='enchant'>Enable spell checking using enchant</flag>
+ <flag name='gpg'>Enable geanypg plugin which integrates GPG using <pkg>app-crypt/gpgme</pkg></flag>
<flag name='gtkspell'>Use gtkspell for dictionary support</flag>
<flag name='soup'>Enable updatechecker plugin which requires net-libs/libsoup</flag>
<flag name='webkit'>Enable webhelper plugin which requires net-libs/webkit-gtk</flag>