summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/qt-webkit/ChangeLog7
-rw-r--r--x11-libs/qt-webkit/files/qt-webkit-4.6.0-solaris-strnstr.patch27
-rw-r--r--x11-libs/qt-webkit/files/qt-webkit-4.6.3-flash-plugin-segfault.patch43
3 files changed, 6 insertions, 71 deletions
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index 34344cca7e30..6c0648e51645 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-webkit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.162 2012/07/09 11:42:52 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.163 2012/07/09 12:41:59 johu Exp $
+
+ 09 Jul 2012; Johannes Huber <johu@gentoo.org>
+ -files/qt-webkit-4.6.0-solaris-strnstr.patch,
+ -files/qt-webkit-4.6.3-flash-plugin-segfault.patch:
+ Remove old.
09 Jul 2012; Johannes Huber <johu@gentoo.org> -qt-webkit-4.6.3-r1.ebuild,
-qt-webkit-4.6.3-r2.ebuild:
diff --git a/x11-libs/qt-webkit/files/qt-webkit-4.6.0-solaris-strnstr.patch b/x11-libs/qt-webkit/files/qt-webkit-4.6.0-solaris-strnstr.patch
deleted file mode 100644
index e71f5c0aa115..000000000000
--- a/x11-libs/qt-webkit/files/qt-webkit-4.6.0-solaris-strnstr.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-(Open)Solaris doesn't have strnstr either:
-https://bugs.webkit.org/show_bug.cgi?id=30647
-http://trac.webkit.org/changeset/50533
-
-
---- src/3rdparty/webkit/JavaScriptCore/wtf/StringExtras.h
-+++ src/3rdparty/webkit/JavaScriptCore/wtf/StringExtras.h
-@@ -85,7 +85,7 @@
-
- #endif
-
--#if PLATFORM(WIN_OS) || PLATFORM(LINUX)
-+#if PLATFORM(WIN_OS) || PLATFORM(LINUX) || PLATFORM(SOLARIS)
-
- inline char* strnstr(const char* buffer, const char* target, size_t bufferLength)
- {
---- src/3rdparty/javascriptcore/JavaScriptCore/wtf/StringExtras.h
-+++ src/3rdparty/javascriptcore/JavaScriptCore/wtf/StringExtras.h
-@@ -85,7 +85,7 @@
-
- #endif
-
--#if PLATFORM(WIN_OS) || PLATFORM(LINUX)
-+#if PLATFORM(WIN_OS) || PLATFORM(LINUX) || PLATFORM(SOLARIS)
-
- inline char* strnstr(const char* buffer, const char* target, size_t bufferLength)
- {
diff --git a/x11-libs/qt-webkit/files/qt-webkit-4.6.3-flash-plugin-segfault.patch b/x11-libs/qt-webkit/files/qt-webkit-4.6.3-flash-plugin-segfault.patch
deleted file mode 100644
index 6fc87ca314a7..000000000000
--- a/x11-libs/qt-webkit/files/qt-webkit-4.6.3-flash-plugin-segfault.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-This patch fixes WebKit Bug 40567: [Qt] QtWebKit crashes while initializing
-flash plugin 10.1.53.64...
-https://bugs.webkit.org/show_bug.cgi?id=40567
-
---- src/3rdparty/webkit/WebCore/plugins/qt/PluginPackageQt.cpp
-+++ src/3rdparty/webkit/WebCore/plugins/qt/PluginPackageQt.cpp
-@@ -35,4 +35,6 @@
-
- namespace WebCore {
-+
-+typedef void gtkInitFunc(int *argc, char ***argv);
-
- bool PluginPackage::fetchInfo()
-@@ -110,4 +112,5 @@
- NP_InitializeFuncPtr NP_Initialize;
- NPError npErr;
-+ gtkInitFunc* gtkInit;
-
- NP_Initialize = (NP_InitializeFuncPtr)m_module->resolve("NP_Initialize");
-@@ -126,4 +129,24 @@
- // It does so in NP_Initialize with a null instance, therefore it is done this way:
- m_browserFuncs.getvalue = staticPluginQuirkRequiresGtkToolKit_NPN_GetValue;
-+ }
-+
-+ // WORKAROUND: Prevent gtk based plugin crashes such as BR# 40567 by
-+ // explicitly forcing the initializing of Gtk, i.e. calling gtk_init,
-+ // whenver the symbol is present in the plugin library loaded above.
-+ // Note that this workaround is based on code from the NSPluginClass ctor
-+ // in KDE's kdebase/apps/nsplugins/viewer/nsplugin.cpp file.
-+ gtkInit = (gtkInitFunc*)m_module->resolve("gtk_init");
-+ if (gtkInit) {
-+ // Prevent gtk_init() from replacing the X error handlers, since the Gtk
-+ // handlers abort when they receive an X error, thus killing the viewer.
-+#ifdef Q_WS_X11
-+ int (*old_error_handler)(Display*, XErrorEvent*) = XSetErrorHandler(0);
-+ int (*old_io_error_handler)(Display*) = XSetIOErrorHandler(0);
-+#endif
-+ gtkInit(0, 0);
-+#ifdef Q_WS_X11
-+ XSetErrorHandler(old_error_handler);
-+ XSetIOErrorHandler(old_io_error_handler);
-+#endif
- }