summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/quanta/quanta-2.0-r1.ebuild27
-rw-r--r--app-office/abiword/abiword-0.7.11.ebuild52
-rw-r--r--app-office/abiword/files/digest-abiword-0.7.115
-rw-r--r--app-office/gnumeric/gnumeric-0.64.ebuild51
-rw-r--r--gnome-office/abiword/abiword-0.7.11.ebuild52
-rw-r--r--gnome-office/abiword/files/digest-abiword-0.7.115
-rw-r--r--gnome-office/gnumeric/gnumeric-0.64.ebuild51
-rw-r--r--kde-apps/quanta/quanta-2.0-r1.ebuild27
8 files changed, 54 insertions, 216 deletions
diff --git a/app-editors/quanta/quanta-2.0-r1.ebuild b/app-editors/quanta/quanta-2.0-r1.ebuild
new file mode 100644
index 000000000000..b3471d7ea649
--- /dev/null
+++ b/app-editors/quanta/quanta-2.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Philippe Namias <pnamias@gentoo.org>
+
+A=${P}-pr1.tar.bz2
+S=${WORKDIR}/quanta
+DESCRIPTION="HTML editor for KDE2"
+SRC_URI="http://ftp1.sourceforge.net/quanta/${A}"
+HOMEPAGE="http://quanta.sourceforge.net"
+
+DEPEND=">=kde-base/kdelibs-2.1.1"
+
+RDEPEND=$DEPEND
+
+src_compile() {
+
+ try ./configure --prefix=${KDEDIR} --host=${CHOST}
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
+
diff --git a/app-office/abiword/abiword-0.7.11.ebuild b/app-office/abiword/abiword-0.7.11.ebuild
deleted file mode 100644
index 1af664af89ca..000000000000
--- a/app-office/abiword/abiword-0.7.11.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-0.7.11.ebuild,v 1.2 2000/11/02 08:31:51 achim Exp $
-
-A="abi-${PV}.tar.gz abidistfiles-${PV}.tar.gz expat-${PV}.tar.gz
- unixfonts-${PV}.tar.gz wv-${PV}.tar.gz"
-S=${WORKDIR}/abi-0.7.11
-DESCRIPTION="Framework for creating database applications"
-SRC_URI="http://download.abisource.com/releases/${PV}/src/lf/abi-${PV}.tar.gz
- http://download.abisource.com/releases/${PV}/src/lf/abidistfiles-${PV}.tar.gz
- http://download.abisource.com/releases/${PV}/src/lf/expat-${PV}.tar.gz
- http://download.abisource.com/releases/${PV}/src/lf/unixfonts-${PV}.tar.gz
- http://download.abisource.com/releases/${PV}/src/lf/wv-${PV}.tar.gz"
-
-
-HOMEPAGE="http://www.gnome.org/gnome-office/abiword.shtml/"
-
-DEPEND=">=sys-libs/glibc-2.1.3
- >=sys-devel/gcc-2.95.2
- >=media-libs/freetype-1.3.1
- >=media-libs/libpng-1.0.7
- >=dev-libs/glib-1.2.8
- >=x11-libs/gtk+-1.2.8
- >=x11-base/xfree-4.0.1"
-
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-}
-
-src_compile() {
- cd ${S}
- try make prefix=/opt/gnome/ UNIX_CAN_BUILD_STATIC=0
-}
-
-src_install() {
- cd ${S}
- try make prefix=${D}/opt/gnome UNIX_CAN_BUILD_STATIC=0 install
- cp ${D}/opt/gnome/AbiSuite/bin/AbiWord AbiWord.orig
- sed -e "s:${D}::" AbiWord.orig > ${D}/opt/gnome/AbiSuite/bin/AbiWord
- cd ${D}/opt/gnome/bin
- rm -f abiword
- rm -f AbiWord
- ln -s ../AbiSuite/bin/AbiWord AbiWord
- ln -s ../AbiSuite/bin/AbiWord abiword
-}
-
-
-
-
diff --git a/app-office/abiword/files/digest-abiword-0.7.11 b/app-office/abiword/files/digest-abiword-0.7.11
deleted file mode 100644
index 9e7e53233d94..000000000000
--- a/app-office/abiword/files/digest-abiword-0.7.11
+++ /dev/null
@@ -1,5 +0,0 @@
-MD5 e10574250dfc0f3bfee94ceef9298b33 abi-0.7.11.tar.gz
-MD5 7599e6675c0a1b29f1f85f6726308dc4 abidistfiles-0.7.11.tar.gz
-MD5 b7bd0c00b94b7dc15975eb0422fedba0 expat-0.7.11.tar.gz
-MD5 f221a2baaadae45513e2c9bc4b859bba unixfonts-0.7.11.tar.gz
-MD5 6b31cb676cffb4f3f7c4bc46c29e64d4 wv-0.7.11.tar.gz
diff --git a/app-office/gnumeric/gnumeric-0.64.ebuild b/app-office/gnumeric/gnumeric-0.64.ebuild
deleted file mode 100644
index d8f9a82097bc..000000000000
--- a/app-office/gnumeric/gnumeric-0.64.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-0.64.ebuild,v 1.1 2001/04/29 17:03:43 achim Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="gnumeric"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnumeric/"${A}
-HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
-
-DEPEND=">=sys-devel/perl-5
- >=dev-lang/python-2.0
- >=gnome-base/gal-0.3.0
- >=gnome-libs/gb-0.0.17
- >=gnome-libs/libole2-0.1.7
- bonobo? ( >=gnome-base/bonobo-0.28
- >=gnome-libs/libgda-0.2.0 ) "
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- cp configure configure.orig
- sed -e 's:"%d,:"%d",:' configure.orig > configure
-}
-
-src_compile() {
- cd ${S}
- local myconf
- if [ "`use bonobo`" ]
- then
- myconf="--with-bonobo"
- fi
- LDFLAGS="-L/opt/gnome/lib -lunicode" try ./configure --host=${CHOST} --prefix=/opt/gnome \
- ${myconf} --with-gb
- cd ${S}
- try make
-}
-
-src_install() {
- cd ${S}
- try make prefix=${D}/opt/gnome PREFIX=${D}/usr install
- dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
-
-}
-
-
-
-
-
-
diff --git a/gnome-office/abiword/abiword-0.7.11.ebuild b/gnome-office/abiword/abiword-0.7.11.ebuild
deleted file mode 100644
index bcffb9638e4b..000000000000
--- a/gnome-office/abiword/abiword-0.7.11.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-office/abiword/abiword-0.7.11.ebuild,v 1.2 2000/11/02 08:31:51 achim Exp $
-
-A="abi-${PV}.tar.gz abidistfiles-${PV}.tar.gz expat-${PV}.tar.gz
- unixfonts-${PV}.tar.gz wv-${PV}.tar.gz"
-S=${WORKDIR}/abi-0.7.11
-DESCRIPTION="Framework for creating database applications"
-SRC_URI="http://download.abisource.com/releases/${PV}/src/lf/abi-${PV}.tar.gz
- http://download.abisource.com/releases/${PV}/src/lf/abidistfiles-${PV}.tar.gz
- http://download.abisource.com/releases/${PV}/src/lf/expat-${PV}.tar.gz
- http://download.abisource.com/releases/${PV}/src/lf/unixfonts-${PV}.tar.gz
- http://download.abisource.com/releases/${PV}/src/lf/wv-${PV}.tar.gz"
-
-
-HOMEPAGE="http://www.gnome.org/gnome-office/abiword.shtml/"
-
-DEPEND=">=sys-libs/glibc-2.1.3
- >=sys-devel/gcc-2.95.2
- >=media-libs/freetype-1.3.1
- >=media-libs/libpng-1.0.7
- >=dev-libs/glib-1.2.8
- >=x11-libs/gtk+-1.2.8
- >=x11-base/xfree-4.0.1"
-
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-}
-
-src_compile() {
- cd ${S}
- try make prefix=/opt/gnome/ UNIX_CAN_BUILD_STATIC=0
-}
-
-src_install() {
- cd ${S}
- try make prefix=${D}/opt/gnome UNIX_CAN_BUILD_STATIC=0 install
- cp ${D}/opt/gnome/AbiSuite/bin/AbiWord AbiWord.orig
- sed -e "s:${D}::" AbiWord.orig > ${D}/opt/gnome/AbiSuite/bin/AbiWord
- cd ${D}/opt/gnome/bin
- rm -f abiword
- rm -f AbiWord
- ln -s ../AbiSuite/bin/AbiWord AbiWord
- ln -s ../AbiSuite/bin/AbiWord abiword
-}
-
-
-
-
diff --git a/gnome-office/abiword/files/digest-abiword-0.7.11 b/gnome-office/abiword/files/digest-abiword-0.7.11
deleted file mode 100644
index 9e7e53233d94..000000000000
--- a/gnome-office/abiword/files/digest-abiword-0.7.11
+++ /dev/null
@@ -1,5 +0,0 @@
-MD5 e10574250dfc0f3bfee94ceef9298b33 abi-0.7.11.tar.gz
-MD5 7599e6675c0a1b29f1f85f6726308dc4 abidistfiles-0.7.11.tar.gz
-MD5 b7bd0c00b94b7dc15975eb0422fedba0 expat-0.7.11.tar.gz
-MD5 f221a2baaadae45513e2c9bc4b859bba unixfonts-0.7.11.tar.gz
-MD5 6b31cb676cffb4f3f7c4bc46c29e64d4 wv-0.7.11.tar.gz
diff --git a/gnome-office/gnumeric/gnumeric-0.64.ebuild b/gnome-office/gnumeric/gnumeric-0.64.ebuild
deleted file mode 100644
index 30901019e71e..000000000000
--- a/gnome-office/gnumeric/gnumeric-0.64.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-office/gnumeric/gnumeric-0.64.ebuild,v 1.1 2001/04/29 17:03:43 achim Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="gnumeric"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnumeric/"${A}
-HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
-
-DEPEND=">=sys-devel/perl-5
- >=dev-lang/python-2.0
- >=gnome-base/gal-0.3.0
- >=gnome-libs/gb-0.0.17
- >=gnome-libs/libole2-0.1.7
- bonobo? ( >=gnome-base/bonobo-0.28
- >=gnome-libs/libgda-0.2.0 ) "
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- cp configure configure.orig
- sed -e 's:"%d,:"%d",:' configure.orig > configure
-}
-
-src_compile() {
- cd ${S}
- local myconf
- if [ "`use bonobo`" ]
- then
- myconf="--with-bonobo"
- fi
- LDFLAGS="-L/opt/gnome/lib -lunicode" try ./configure --host=${CHOST} --prefix=/opt/gnome \
- ${myconf} --with-gb
- cd ${S}
- try make
-}
-
-src_install() {
- cd ${S}
- try make prefix=${D}/opt/gnome PREFIX=${D}/usr install
- dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
-
-}
-
-
-
-
-
-
diff --git a/kde-apps/quanta/quanta-2.0-r1.ebuild b/kde-apps/quanta/quanta-2.0-r1.ebuild
new file mode 100644
index 000000000000..b3471d7ea649
--- /dev/null
+++ b/kde-apps/quanta/quanta-2.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Philippe Namias <pnamias@gentoo.org>
+
+A=${P}-pr1.tar.bz2
+S=${WORKDIR}/quanta
+DESCRIPTION="HTML editor for KDE2"
+SRC_URI="http://ftp1.sourceforge.net/quanta/${A}"
+HOMEPAGE="http://quanta.sourceforge.net"
+
+DEPEND=">=kde-base/kdelibs-2.1.1"
+
+RDEPEND=$DEPEND
+
+src_compile() {
+
+ try ./configure --prefix=${KDEDIR} --host=${CHOST}
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
+