summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-zope/zope/ChangeLog7
-rw-r--r--net-zope/zope/Manifest2
-rw-r--r--net-zope/zope/files/digest-zope-3.2.01
-rw-r--r--net-zope/zope/zope-3.2.0.ebuild126
4 files changed, 135 insertions, 1 deletions
diff --git a/net-zope/zope/ChangeLog b/net-zope/zope/ChangeLog
index 2f9d61af492c..7ea7ec31c984 100644
--- a/net-zope/zope/ChangeLog
+++ b/net-zope/zope/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-zope/zope
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.95 2006/01/07 20:17:12 radek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.96 2006/01/08 13:40:39 radek Exp $
+
+*zope-3.2.0 (08 Jan 2006)
+
+ 08 Jan 2006; Radoslaw Stachowiak <radek@gentoo.org> +zope-3.2.0.ebuild:
+ version bump, also closes #117217
*zope-2.9.0 (07 Jan 2006)
diff --git a/net-zope/zope/Manifest b/net-zope/zope/Manifest
index dcdf4b444bff..18b751f93433 100644
--- a/net-zope/zope/Manifest
+++ b/net-zope/zope/Manifest
@@ -10,6 +10,7 @@ MD5 f26477bbd15c975a265ea05f285e728e files/digest-zope-2.8.3 66
MD5 d1db47dc244cba7522bfb1babe93f3f0 files/digest-zope-2.8.4 66
MD5 6a7b4cbd9d48c293b592dc78f879993c files/digest-zope-2.9.0 60
MD5 af9f7a9e66ce59bf1a8a901402f6ed5e files/digest-zope-3.1.0 60
+MD5 394e802ac25cc95135996a8d8344b5ec files/digest-zope-3.2.0 60
MD5 037cf91a5b4d60efe166f90210c837ed files/i18n-1.0.0.patch 8080
MD5 610f19a06033d3b55b76c7fd2d1d464d files/zope.initd 1317
MD5 7890d88c5c6d189fbe6b187a3ebb6532 metadata.xml 161
@@ -20,3 +21,4 @@ MD5 0ce3afe5cd3f944a3fa984afa74a43af zope-2.8.3.ebuild 3512
MD5 766f6734ba9201fceb214d0dd90ac286 zope-2.8.4.ebuild 3510
MD5 dbb92d40aea88035b7f99abff0024651 zope-2.9.0.ebuild 2301
MD5 294c0f19cff69103751c1a8eadb92019 zope-3.1.0.ebuild 3239
+MD5 6efc69343913a743696fa109712c275b zope-3.2.0.ebuild 3638
diff --git a/net-zope/zope/files/digest-zope-3.2.0 b/net-zope/zope/files/digest-zope-3.2.0
new file mode 100644
index 000000000000..da8e102129d5
--- /dev/null
+++ b/net-zope/zope/files/digest-zope-3.2.0
@@ -0,0 +1 @@
+MD5 dbbb708281ebcf7186aa7aa3ee46844c Zope-3.2.0.tgz 6566282
diff --git a/net-zope/zope/zope-3.2.0.ebuild b/net-zope/zope/zope-3.2.0.ebuild
new file mode 100644
index 000000000000..f86e14729914
--- /dev/null
+++ b/net-zope/zope/zope-3.2.0.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-3.2.0.ebuild,v 1.1 2006/01/08 13:40:40 radek Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites."
+HOMEPAGE="http://www.zope.org"
+SRC_URI="http://www.zope.org/Products/Zope3/${PV}final/Zope-${PV}.tgz"
+
+LICENSE="ZPL"
+SLOT="${PV}"
+IUSE=""
+
+KEYWORDS="~x86"
+
+RDEPEND="=dev-lang/python-2.4*"
+
+DEPEND="${RDEPEND}
+ >=app-shells/bash-2.0
+ >=sys-apps/sed-4.0.5"
+
+S="${WORKDIR}/Zope-${PV}"
+
+ZUNAME=zope
+ZGNAME=zope
+
+ZS_DIR=${ROOT%/}/usr/$(get_libdir)
+ZSERVDIR=${ZS_DIR}/${P}
+ZSKELDIR=${ZSERVDIR}/zopeskel
+ZINSTDIR=/var/lib/zope/${P}
+
+src_compile() {
+
+ cd ${S}
+
+ ./configure --prefix=${D}${ZSERVDIR} --with-python=/usr/bin/python2.4 || die "Failed to configure."
+ emake || die "Failed to compile."
+}
+
+src_install() {
+
+ cd ${S}
+
+ dodoc README.txt
+ dodoc Zope/doc/*.txt
+ for DIR in schema security skins style zcml zsync
+ do
+ docinto ${DIR}
+ dodoc Zope/doc/${DIR}/*
+ done
+
+ make install prefix=${D}${ZSERVDIR}
+
+ dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
+
+ # copy the init script skeleton to zopeskel directory of our installation
+ cp ${FILESDIR}/zope.initd ${D}${ZSKELDIR}/zope.initd
+}
+
+pkg_postinst() {
+ # create the zope user and group for backward compatibility
+ enewgroup ${ZGNAME} 261
+ usermod -g ${ZGNAME} -c "Zope Admin User" -d /var/lib/zope -s /bin/bash ${ZUNAME} 2>&1 >/dev/null || \
+ enewuser ${ZUNAME} 261 /bin/bash /var/lib/zope ${ZGNAME} -c "Zope Admin User"
+
+ einfo "This release can create a default instance using the command: "
+ einfo " emerge --config =${PF}"
+ einfo "Instance (${P}) will be created in ${ZINSTDIR} as its home."
+ einfo "System uid/gid for instance will be: ${ZUNAME}:${ZGNAME}"
+}
+
+pkg_prerm() {
+
+ find ${ZSERVDIR}/lib/python -name \*.py[co] -exec rm -f {} \;
+}
+
+pkg_postrm() {
+
+ rmdir /usr/$(get_libdir)/${ZSERVDIR} 2>/dev/null
+ ewarn "Instances created for this package are NOT automaticaly deleted!"
+ ewarn "Inspect these locations and manually remove them (if needed):"
+ ewarn " /etc/init.d/${P}"
+ ewarn " ${ZINSTDIR}"
+}
+
+pkg_config() {
+
+ if [ -f /etc/init.d/${P} -o -d ${ZINSTDIR} ]
+ then
+ ewarn "Default instance already exists, aborting.."
+ ewarn "Please delete first /etc/init.d/${P} and ${ZINSTDIR}"
+ die "Failed to create default instance."
+ fi
+
+ mkdir -p ${ZINSTDIR}
+ einfo "Instance ${P} creation, calling mkzopeinstance.."
+ ${ZSERVDIR}/bin/mkzopeinstance --non-interactive -d ${ZINSTDIR} -u admin:admin
+
+ # bug in zope
+ einfo "Patching ${ZINSTDIR}/etc/zdaemon.conf"
+ sed -i -e 's|daemon on|daemon on\n\n # socket has to be defined inside of instance\n socket-name $INSTANCE/var/zdsock|' ${ZINSTDIR}/etc/zdaemon.conf
+
+ # remove unnecessary zope.initd
+ rm -f ${ZINSTDIR}/zope.initd
+
+ # log symlink
+ rm -rf ${ZINSTDIR}/log
+ mkdir -p /var/log/zope/${PN}
+ ln -s /var/log/zope/${PN} ${ZINSTDIR}/log
+
+ # permissions changes
+ chmod go-rwx -R ${ZINSTDIR}
+ chown ${ZUNAME}:${ZGNAME} -R ${ZINSTDIR} /var/log/zope/${PN}
+
+ cp ${ZSKELDIR}/zope.initd /etc/init.d/${P}
+ chmod 755 /etc/init.d/${P}
+ sed -i -e "s|INSTANCE_HOME|${ZINSTDIR}|" /etc/init.d/${P}
+ sed -i -e "s|zopectl|zopectl -u ${ZUNAME}|" /etc/init.d/${P}
+
+ einfo "Default instance created at ${ZINSTDIR}"
+ einfo "Created default zope user 'admin' with password 'admin'."
+ einfo "System uid/gid for instance is: ${ZUNAME}:${ZGNAME}."
+ einfo "To start instance (default ports 8080,8021) use: /etc/init.d/${P} start"
+ einfo "To start instance on every restart use: rc-update -a ${P} default"
+}