summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/pykde4/ChangeLog8
-rw-r--r--kde-base/pykde4/files/pykde4-installation-fix.patch10
-rw-r--r--kde-base/pykde4/pykde4-4.3.0.ebuild80
3 files changed, 97 insertions, 1 deletions
diff --git a/kde-base/pykde4/ChangeLog b/kde-base/pykde4/ChangeLog
index 8f4e5b631862..49b23d6fcac8 100644
--- a/kde-base/pykde4/ChangeLog
+++ b/kde-base/pykde4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/pykde4
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.24 2009/06/16 15:27:57 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.25 2009/08/04 01:33:28 wired Exp $
+
+*pykde4-4.3.0 (04 Aug 2009)
+
+ 04 Aug 2009; Alex Alexander <wired@gentoo.org>
+ +files/pykde4-installation-fix.patch, +pykde4-4.3.0.ebuild:
+ Version bump
*pykde4-4.2.4-r2 (16 Jun 2009)
diff --git a/kde-base/pykde4/files/pykde4-installation-fix.patch b/kde-base/pykde4/files/pykde4-installation-fix.patch
new file mode 100644
index 000000000000..a0a3e642d495
--- /dev/null
+++ b/kde-base/pykde4/files/pykde4-installation-fix.patch
@@ -0,0 +1,10 @@
+Index: python/pykde4/tools/pykdeuic4/CMakeLists.txt
+===================================================================
+--- python/pykde4/tools/pykdeuic4/CMakeLists.txt (revision 1001414)
++++ python/pykde4/tools/pykdeuic4/CMakeLists.txt (working copy)
+@@ -1,2 +1,4 @@
+ PYTHON_INSTALL(kde4.py ${PYTHON_SITE_PACKAGES_DIR}/PyQt4/uic/widget-plugins/)
+-PYTHON_INSTALL(pykdeuic4.py ${BIN_INSTALL_DIR}/pykdeuic4)
++PYTHON_INSTALL(pykdeuic4.py ${PYTHON_SITE_PACKAGES_DIR}/PyQt4/uic/)
++find_path(cmake_module_dir create_exe_symlink.cmake ${CMAKE_MODULE_PATH})
++INSTALL(CODE "EXECUTE_PROCESS(COMMAND ${CMAKE_COMMAND} -DTARGET=${PYTHON_SITE_PACKAGES_DIR}/PyQt4/uic/pykdeuic4.py -DLINK_NAME=${BIN_INSTALL_DIR}/pykdeuic4 -P ${cmake_module_dir}/create_exe_symlink.cmake)" )
diff --git a/kde-base/pykde4/pykde4-4.3.0.ebuild b/kde-base/pykde4/pykde4-4.3.0.ebuild
new file mode 100644
index 000000000000..7507baa1d260
--- /dev/null
+++ b/kde-base/pykde4/pykde4-4.3.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/pykde4-4.3.0.ebuild,v 1.1 2009/08/04 01:33:28 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdebindings"
+KMMODULE="python/${PN}"
+OPENGL_REQUIRED="always"
+inherit python kde4-meta
+
+DESCRIPTION="Python bindings for KDE4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="akonadi debug examples policykit semantic-desktop"
+
+COMMON_DEPEND="
+ >=dev-python/PyQt4-4.5[dbus,sql,svg,webkit,X]
+ >=kde-base/kdelibs-${PV}:${SLOT}[kdeprefix=,opengl,semantic-desktop?]
+ akonadi? ( >=kde-base/kdepimlibs-${PV}:${SLOT}[kdeprefix=] )
+ policykit? ( >=sys-auth/policykit-qt-0.9.2 )
+"
+DEPEND="${COMMON_DEPEND}"
+# blocker added due to compatibility issues and error during compile time
+RDEPEND="${COMMON_DEPEND}
+ !dev-python/pykde
+"
+
+#PATCHES=(
+# "${FILESDIR}/${PN}-installation-fix.patch"
+#)
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ if ! use examples; then
+ sed -e '/^ADD_SUBDIRECTORY(examples)/s/^/# DISABLED /' -i python/${PN}/CMakeLists.txt \
+ || die "Failed to disable examples"
+ fi
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DWITH_QScintilla=OFF
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with policykit PolkitQt)
+ "
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ python_version
+ rm -f \
+ "${D}/usr/$(get_libdir)/python${PYVER}"/site-packages/PyKDE4/*.py[co] \
+ "${D}${PREFIX}"/share/apps/"${PN}"/*.py[co]
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ python_mod_optimize ${ROOT}"usr/$(get_libdir)/python${PYVER}"/site-packages/PyKDE4
+
+ if use examples; then
+ echo
+ elog "PyKDE4 examples have been installed to"
+ elog "${PREFIX}/share/apps/${PN}/examples"
+ echo
+ fi
+}
+
+pkg_postrm() {
+ kde4-meta_pkg_postrm
+
+ python_mod_cleanup ${ROOT}"usr/$(get_libdir)/python${PYVER}"/site-packages/PyKDE4
+}