summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/chardet/ChangeLog8
-rw-r--r--dev-python/chardet/chardet-1.0.1.ebuild23
2 files changed, 25 insertions, 6 deletions
diff --git a/dev-python/chardet/ChangeLog b/dev-python/chardet/ChangeLog
index 87a78e85e374..390d7e4a5802 100644
--- a/dev-python/chardet/ChangeLog
+++ b/dev-python/chardet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/chardet
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chardet/ChangeLog,v 1.5 2008/07/17 19:02:06 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chardet/ChangeLog,v 1.6 2009/09/13 02:55:26 arfrever Exp $
+
+ 13 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ chardet-1.0.1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
17 Jul 2008; Alexis Ballier <aballier@gentoo.org> chardet-1.0.1.ebuild:
keyword ~x86-fbsd
diff --git a/dev-python/chardet/chardet-1.0.1.ebuild b/dev-python/chardet/chardet-1.0.1.ebuild
index dbcb35f4c563..eff7d08a93ac 100644
--- a/dev-python/chardet/chardet-1.0.1.ebuild
+++ b/dev-python/chardet/chardet-1.0.1.ebuild
@@ -1,12 +1,17 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chardet/chardet-1.0.1.ebuild,v 1.2 2008/07/17 19:02:06 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chardet/chardet-1.0.1.ebuild,v 1.3 2009/09/13 02:55:26 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
inherit distutils
DESCRIPTION="Character encoding auto-detection in Python."
HOMEPAGE="http://chardet.feedparser.org/"
-SRC_URI="http://chardet.feedparser.org/download/${P}.tgz"
+SRC_URI="http://chardet.feedparser.org/download/python2-${P}.tgz
+ http://chardet.feedparser.org/download/python3-${P}.tgz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-fbsd"
@@ -15,7 +20,17 @@ IUSE=""
DEPEND=""
RDEPEND=""
+src_unpack() {
+ default
+ cp -pr "python3-${P}" "${P}"
+
+ unpacking() {
+ cp -pr "python${PYTHON_ABI:0:1}-${P}" "${S}-${PYTHON_ABI}"
+ }
+ python_execute_function -q unpacking
+}
+
src_install() {
distutils_src_install
- dohtml -r "${S}/docs/*"
+ dohtml -r "${S}/docs/"*
}