summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-servers/apache/ChangeLog8
-rw-r--r--www-servers/apache/apache-2.0.58-r2.ebuild6
-rw-r--r--www-servers/apache/apache-2.0.59-r2.ebuild6
-rw-r--r--www-servers/apache/apache-2.2.4-r10.ebuild12
-rw-r--r--www-servers/apache/apache-2.2.4-r6.ebuild12
-rw-r--r--www-servers/apache/apache-2.2.4-r7.ebuild14
-rw-r--r--www-servers/apache/apache-2.2.4-r8.ebuild14
-rw-r--r--www-servers/apache/apache-2.2.4-r9.ebuild14
8 files changed, 46 insertions, 40 deletions
diff --git a/www-servers/apache/ChangeLog b/www-servers/apache/ChangeLog
index 20594d567e2a..9eeeb466a9c8 100644
--- a/www-servers/apache/ChangeLog
+++ b/www-servers/apache/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/apache
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.1 2007/07/29 16:32:00 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.2 2007/07/29 17:23:43 phreak Exp $
+
+ 29 Jul 2007; Christian Heim <phreak@gentoo.org> apache-2.0.58-r2.ebuild,
+ apache-2.0.59-r2.ebuild, apache-2.2.4-r6.ebuild, apache-2.2.4-r7.ebuild,
+ apache-2.2.4-r8.ebuild, apache-2.2.4-r9.ebuild, apache-2.2.4-r10.ebuild:
+ Fixing the DEPEND/RDEPEND for the move of net-www/apache to
+ www-servers/apache (#78622).
*apache-2.2.4-r6 (29 Jul 2007)
diff --git a/www-servers/apache/apache-2.0.58-r2.ebuild b/www-servers/apache/apache-2.0.58-r2.ebuild
index 6e0872f3581f..264c4cd77c32 100644
--- a/www-servers/apache/apache-2.0.58-r2.ebuild
+++ b/www-servers/apache/apache-2.0.58-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.0.58-r2.ebuild,v 1.1 2007/07/29 16:32:00 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.0.58-r2.ebuild,v 1.2 2007/07/29 17:23:43 phreak Exp $
inherit eutils flag-o-matic gnuconfig multilib
@@ -344,7 +344,7 @@ pkg_postinst() {
fi
# Check for dual/upgrade install
- if has_version '=net-www/apache-1*' || ! use apache2 ; then
+ if has_version '=www-servers/apache-1*' || ! use apache2 ; then
ewarn
ewarn "Please add the 'apache2' flag to your USE variable and (re)install"
ewarn "any additional DSO modules you may wish to use with Apache-2.x."
@@ -360,7 +360,7 @@ pkg_postinst() {
done
[ -n "${list}" ] && einfo "You should delete these old symlinks: ${list}"
- if has_version '<net-www/apache-2.0.54-r30' && has_version '>=net-www/apache-2.0.0' ; then
+ if has_version '<www-servers/apache-2.0.54-r30' && has_version '>=www-servers/apache-2.0.0' ; then
einfo "Configuration locations have changed, you will need to migrate"
einfo "your configuration from /etc/apache2/conf/apache2.conf and"
einfo "/etc/apache2/conf/commonapache2.conf to /etc/apache2/httpd.conf."
diff --git a/www-servers/apache/apache-2.0.59-r2.ebuild b/www-servers/apache/apache-2.0.59-r2.ebuild
index dffabf82e3a8..897a5698cdd9 100644
--- a/www-servers/apache/apache-2.0.59-r2.ebuild
+++ b/www-servers/apache/apache-2.0.59-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.0.59-r2.ebuild,v 1.1 2007/07/29 16:32:00 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.0.59-r2.ebuild,v 1.2 2007/07/29 17:23:43 phreak Exp $
inherit eutils flag-o-matic gnuconfig multilib
@@ -351,7 +351,7 @@ pkg_postinst() {
fi
# Check for dual/upgrade install
- if has_version '=net-www/apache-1*' || ! use apache2 ; then
+ if has_version '=www-servers/apache-1*' || ! use apache2 ; then
ewarn
ewarn "Please add the 'apache2' flag to your USE variable and (re)install"
ewarn "any additional DSO modules you may wish to use with Apache-2.x."
@@ -367,7 +367,7 @@ pkg_postinst() {
done
[ -n "${list}" ] && einfo "You should delete these old symlinks: ${list}"
- if has_version '<net-www/apache-2.0.54-r30' && has_version '>=net-www/apache-2.0.0' ; then
+ if has_version '<www-servers/apache-2.0.54-r30' && has_version '>=www-servers/apache-2.0.0' ; then
einfo "Configuration locations have changed, you will need to migrate"
einfo "your configuration from /etc/apache2/conf/apache2.conf and"
einfo "/etc/apache2/conf/commonapache2.conf to /etc/apache2/httpd.conf."
diff --git a/www-servers/apache/apache-2.2.4-r10.ebuild b/www-servers/apache/apache-2.2.4-r10.ebuild
index 08050e31dae4..f1c16cb49c2d 100644
--- a/www-servers/apache/apache-2.2.4-r10.ebuild
+++ b/www-servers/apache/apache-2.2.4-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.4-r10.ebuild,v 1.1 2007/07/29 16:32:00 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.4-r10.ebuild,v 1.2 2007/07/29 17:23:43 phreak Exp $
inherit eutils flag-o-matic gnuconfig multilib autotools
@@ -30,7 +30,7 @@ DEPEND="dev-lang/perl
ldap? ( =net-nds/openldap-2* )
selinux? ( sec-policy/selinux-apache )
ssl? ( dev-libs/openssl )
- !=net-www/apache-1*
+ !=www-servers/apache-1*
!=app-admin/apache-tools-2.2.4-r2"
RDEPEND="${DEPEND}
@@ -344,7 +344,7 @@ pkg_postinst() {
# Previous installations of apache-2.2 installed the upstream configuration
# files, which shouldn't even have been installed!
- if has_version '>=net-www/apache-2.2.4' ; then
+ if has_version '>=www-servers/apache-2.2.4' ; then
[ -f "${ROOT}"/etc/apache2/apache2.conf ] && \
rm -f "${ROOT}"/etc/apache2/apache2.conf >/dev/null 2>&1
@@ -355,7 +355,7 @@ pkg_postinst() {
fi
# Note the changes regarding DEFAULT_VHOST and SSL_DEFAULT_VHOST
- if has_version '<net-www/apache-2.2.4-r7' ; then
+ if has_version '<www-servers/apache-2.2.4-r7' ; then
elog
elog "Listen directives have been moved into the default virtual host"
elog "configuation. At least DEFAULT_VHOST has been enabled for you"
@@ -367,7 +367,7 @@ pkg_postinst() {
fi
# Note the user of the config changes
- if has_version '<net-www/apache-2.2.4-r5' ; then
+ if has_version '<www-servers/apache-2.2.4-r5' ; then
elog
elog "Please make sure that you update your /etc directory."
elog "Between the versions, we had to changes some config files"
@@ -380,7 +380,7 @@ pkg_postinst() {
fi
# Check for dual/upgrade install
- if has_version '<net-www/apache-2.2.0' ; then
+ if has_version '<www-servers/apache-2.2.0' ; then
elog
elog "When upgrading from versions below 2.2.0 to this version, you"
elog "need to rebuild all your modules. Please do so for your modules"
diff --git a/www-servers/apache/apache-2.2.4-r6.ebuild b/www-servers/apache/apache-2.2.4-r6.ebuild
index 180308154b8d..1f1b726196bf 100644
--- a/www-servers/apache/apache-2.2.4-r6.ebuild
+++ b/www-servers/apache/apache-2.2.4-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.4-r6.ebuild,v 1.1 2007/07/29 16:32:00 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.4-r6.ebuild,v 1.2 2007/07/29 17:23:43 phreak Exp $
inherit eutils flag-o-matic gnuconfig multilib autotools
@@ -31,7 +31,7 @@ DEPEND="dev-lang/perl
ldap? ( =net-nds/openldap-2* )
selinux? ( sec-policy/selinux-apache )
ssl? ( dev-libs/openssl )
- !=net-www/apache-1*
+ !=www-servers/apache-1*
!=app-admin/apache-tools-2.2.4-r2"
RDEPEND="${DEPEND}
@@ -344,7 +344,7 @@ pkg_postinst() {
# Previous installations of apache-2.2 installed the upstream configuration
# files, which shouldn't even have been installed!
- if has_version '>=net-www/apache-2.2.4' ; then
+ if has_version '>=www-servers/apache-2.2.4' ; then
[ -f "${ROOT}"/etc/apache2/apache2.conf ] && \
rm -f "${ROOT}"/etc/apache2/apache2.conf >/dev/null 2>&1
@@ -355,7 +355,7 @@ pkg_postinst() {
fi
# Note the user of the config changes
- if has_version '<net-www/apache-2.2.4-r5' ; then
+ if has_version '<www-servers/apache-2.2.4-r5' ; then
elog
elog "Please make sure that you update your /etc directory."
elog "Between the versions, we had to changes some config files"
@@ -368,7 +368,7 @@ pkg_postinst() {
fi
# Check for dual/upgrade install
- if has_version '<net-www/apache-2.2.0' ; then
+ if has_version '<www-servers/apache-2.2.0' ; then
elog
elog "When upgrading from versions below 2.2.0 to this version, you"
elog "need to rebuild all your modules. Please do so for your modules"
@@ -392,7 +392,7 @@ pkg_postinst() {
elog "To keep from accidentally downgrading to Apache 2.0, you should"
elog "add the following to ${ROOT}/etc/portage/package.mask:"
elog
- elog " <net-www/apache-2.2.0"
+ elog " <www-servers/apache-2.2.0"
elog
fi
}
diff --git a/www-servers/apache/apache-2.2.4-r7.ebuild b/www-servers/apache/apache-2.2.4-r7.ebuild
index 77fd2aec629f..64ac711e0679 100644
--- a/www-servers/apache/apache-2.2.4-r7.ebuild
+++ b/www-servers/apache/apache-2.2.4-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.4-r7.ebuild,v 1.1 2007/07/29 16:32:00 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.4-r7.ebuild,v 1.2 2007/07/29 17:23:43 phreak Exp $
inherit eutils flag-o-matic gnuconfig multilib autotools
@@ -31,7 +31,7 @@ DEPEND="dev-lang/perl
ldap? ( =net-nds/openldap-2* )
selinux? ( sec-policy/selinux-apache )
ssl? ( dev-libs/openssl )
- !=net-www/apache-1*
+ !=www-servers/apache-1*
!=app-admin/apache-tools-2.2.4-r2"
RDEPEND="${DEPEND}
@@ -344,7 +344,7 @@ pkg_postinst() {
# Previous installations of apache-2.2 installed the upstream configuration
# files, which shouldn't even have been installed!
- if has_version '>=net-www/apache-2.2.4' ; then
+ if has_version '>=www-servers/apache-2.2.4' ; then
[ -f "${ROOT}"/etc/apache2/apache2.conf ] && \
rm -f "${ROOT}"/etc/apache2/apache2.conf >/dev/null 2>&1
@@ -355,7 +355,7 @@ pkg_postinst() {
fi
# Note for new location of Listen
- if has_version '<net-www/apache-2.2.4-r7' ; then
+ if has_version '<www-servers/apache-2.2.4-r7' ; then
elog
elog "Listen directives have been moved into the default virtual host"
elog "configuation. Therefore you have to enabled at least one of"
@@ -365,7 +365,7 @@ pkg_postinst() {
fi
# Note the user of the config changes
- if has_version '<net-www/apache-2.2.4-r5' ; then
+ if has_version '<www-servers/apache-2.2.4-r5' ; then
elog
elog "Please make sure that you update your /etc directory."
elog "Between the versions, we had to changes some config files"
@@ -378,7 +378,7 @@ pkg_postinst() {
fi
# Check for dual/upgrade install
- if has_version '<net-www/apache-2.2.0' ; then
+ if has_version '<www-servers/apache-2.2.0' ; then
elog
elog "When upgrading from versions below 2.2.0 to this version, you"
elog "need to rebuild all your modules. Please do so for your modules"
@@ -402,7 +402,7 @@ pkg_postinst() {
elog "To keep from accidentally downgrading to Apache 2.0, you should"
elog "add the following to ${ROOT}/etc/portage/package.mask:"
elog
- elog " <net-www/apache-2.2.0"
+ elog " <www-servers/apache-2.2.0"
elog
fi
}
diff --git a/www-servers/apache/apache-2.2.4-r8.ebuild b/www-servers/apache/apache-2.2.4-r8.ebuild
index d7e318aa2b2e..3a0619268a18 100644
--- a/www-servers/apache/apache-2.2.4-r8.ebuild
+++ b/www-servers/apache/apache-2.2.4-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.4-r8.ebuild,v 1.1 2007/07/29 16:32:00 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.4-r8.ebuild,v 1.2 2007/07/29 17:23:43 phreak Exp $
inherit eutils flag-o-matic gnuconfig multilib autotools
@@ -31,7 +31,7 @@ DEPEND="dev-lang/perl
ldap? ( =net-nds/openldap-2* )
selinux? ( sec-policy/selinux-apache )
ssl? ( dev-libs/openssl )
- !=net-www/apache-1*
+ !=www-servers/apache-1*
!=app-admin/apache-tools-2.2.4-r2"
RDEPEND="${DEPEND}
@@ -345,7 +345,7 @@ pkg_postinst() {
# Previous installations of apache-2.2 installed the upstream configuration
# files, which shouldn't even have been installed!
- if has_version '>=net-www/apache-2.2.4' ; then
+ if has_version '>=www-servers/apache-2.2.4' ; then
[ -f "${ROOT}"/etc/apache2/apache2.conf ] && \
rm -f "${ROOT}"/etc/apache2/apache2.conf >/dev/null 2>&1
@@ -356,7 +356,7 @@ pkg_postinst() {
fi
# Note for new location of Listen
- if has_version '<net-www/apache-2.2.4-r7' ; then
+ if has_version '<www-servers/apache-2.2.4-r7' ; then
elog
elog "Listen directives have been moved into the default virtual host"
elog "configuation. Therefore you have to enabled at least one of"
@@ -366,7 +366,7 @@ pkg_postinst() {
fi
# Note the user of the config changes
- if has_version '<net-www/apache-2.2.4-r5' ; then
+ if has_version '<www-servers/apache-2.2.4-r5' ; then
elog
elog "Please make sure that you update your /etc directory."
elog "Between the versions, we had to changes some config files"
@@ -379,7 +379,7 @@ pkg_postinst() {
fi
# Check for dual/upgrade install
- if has_version '<net-www/apache-2.2.0' ; then
+ if has_version '<www-servers/apache-2.2.0' ; then
elog
elog "When upgrading from versions below 2.2.0 to this version, you"
elog "need to rebuild all your modules. Please do so for your modules"
@@ -403,7 +403,7 @@ pkg_postinst() {
elog "To keep from accidentally downgrading to Apache 2.0, you should"
elog "add the following to ${ROOT}/etc/portage/package.mask:"
elog
- elog " <net-www/apache-2.2.0"
+ elog " <www-servers/apache-2.2.0"
elog
fi
}
diff --git a/www-servers/apache/apache-2.2.4-r9.ebuild b/www-servers/apache/apache-2.2.4-r9.ebuild
index 00a7581d259e..63b1b42e3d95 100644
--- a/www-servers/apache/apache-2.2.4-r9.ebuild
+++ b/www-servers/apache/apache-2.2.4-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.4-r9.ebuild,v 1.1 2007/07/29 16:32:00 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.4-r9.ebuild,v 1.2 2007/07/29 17:23:43 phreak Exp $
inherit eutils flag-o-matic gnuconfig multilib autotools
@@ -31,7 +31,7 @@ DEPEND="dev-lang/perl
ldap? ( =net-nds/openldap-2* )
selinux? ( sec-policy/selinux-apache )
ssl? ( dev-libs/openssl )
- !=net-www/apache-1*
+ !=www-servers/apache-1*
!=app-admin/apache-tools-2.2.4-r2"
RDEPEND="${DEPEND}
@@ -345,7 +345,7 @@ pkg_postinst() {
# Previous installations of apache-2.2 installed the upstream configuration
# files, which shouldn't even have been installed!
- if has_version '>=net-www/apache-2.2.4' ; then
+ if has_version '>=www-servers/apache-2.2.4' ; then
[ -f "${ROOT}"/etc/apache2/apache2.conf ] && \
rm -f "${ROOT}"/etc/apache2/apache2.conf >/dev/null 2>&1
@@ -356,7 +356,7 @@ pkg_postinst() {
fi
# Note for new location of Listen
- if has_version '<net-www/apache-2.2.4-r7' ; then
+ if has_version '<www-servers/apache-2.2.4-r7' ; then
elog
elog "Listen directives have been moved into the default virtual host"
elog "configuation. Therefore you have to enabled at least one of"
@@ -366,7 +366,7 @@ pkg_postinst() {
fi
# Note the user of the config changes
- if has_version '<net-www/apache-2.2.4-r5' ; then
+ if has_version '<www-servers/apache-2.2.4-r5' ; then
elog
elog "Please make sure that you update your /etc directory."
elog "Between the versions, we had to changes some config files"
@@ -379,7 +379,7 @@ pkg_postinst() {
fi
# Check for dual/upgrade install
- if has_version '<net-www/apache-2.2.0' ; then
+ if has_version '<www-servers/apache-2.2.0' ; then
elog
elog "When upgrading from versions below 2.2.0 to this version, you"
elog "need to rebuild all your modules. Please do so for your modules"
@@ -403,7 +403,7 @@ pkg_postinst() {
elog "To keep from accidentally downgrading to Apache 2.0, you should"
elog "add the following to ${ROOT}/etc/portage/package.mask:"
elog
- elog " <net-www/apache-2.2.0"
+ elog " <www-servers/apache-2.2.0"
elog
fi