summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/curl/ChangeLog10
-rw-r--r--net-misc/curl/curl-7.17.0-r1.ebuild115
-rw-r--r--net-misc/curl/curl-7.17.1_pre20071013.ebuild (renamed from net-misc/curl/curl-7.17.0_pre20070828.ebuild)5
-rw-r--r--net-misc/curl/files/digest-curl-7.17.0-r13
-rw-r--r--net-misc/curl/files/digest-curl-7.17.0_pre200708283
-rw-r--r--net-misc/curl/files/digest-curl-7.17.1_pre200710133
6 files changed, 16 insertions, 123 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index 4ab63bfcbe38..508b82cb24ea 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/curl
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.106 2007/10/01 15:09:51 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.107 2007/10/14 06:40:18 dragonheart Exp $
+
+*curl-7.17.1_pre20071013 (13 Oct 2007)
+
+ 13 Oct 2007; Daniel Black <dragonheart@gentoo.org>
+ -curl-7.17.0_pre20070828.ebuild, -curl-7.17.0-r1.ebuild,
+ +curl-7.17.1_pre20071013.ebuild:
+ revision snapshot to fix bug #195706. thanks Christoph Mende and Daniel
+ Stenberg. removed older versions
01 Oct 2007; Roy Marples <uberlord@gentoo.org> curl-7.17.0.ebuild,
curl-7.17.0-r1.ebuild:
diff --git a/net-misc/curl/curl-7.17.0-r1.ebuild b/net-misc/curl/curl-7.17.0-r1.ebuild
deleted file mode 100644
index 965906711d05..000000000000
--- a/net-misc/curl/curl-7.17.0-r1.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.17.0-r1.ebuild,v 1.2 2007/10/01 15:09:51 uberlord Exp $
-
-# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
-
-inherit libtool eutils
-
-#MY_P=${P/_pre/-}
-DESCRIPTION="A Client that groks URLs"
-HOMEPAGE="http://curl.haxx.se/ http://curl.planetmirror.com"
-#SRC_URI="http://cool.haxx.se/curl-daily/${MY_P}.tar.bz2"
-SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
-#SRC_URI="http://curl.planetmirror.com/download/${P}.tar.bz2"
-
-LICENSE="MIT X11"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="ssl libssh2 ipv6 ldap ares gnutls nss idn kerberos test"
-
-RDEPEND="gnutls? ( net-libs/gnutls )
- nss? ( !gnutls? ( dev-libs/nss ) )
- ssl? ( !gnutls? ( !nss? ( dev-libs/openssl ) ) )
- ldap? ( net-nds/openldap )
- idn? ( net-dns/libidn )
- ares? ( >=net-dns/c-ares-1.4.0 )
- kerberos? ( virtual/krb5 )
- app-misc/ca-certificates
- libssh2? ( >=net-libs/libssh2-0.16 )"
-
-# net-libs/libssh2 (masked) --with-libssh2
-# fbopenssl (not in gentoo) --with-spnego
-# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
-
-DEPEND="${RDEPEND}
- test? (
- sys-apps/diffutils
- dev-lang/perl
- )"
-# used - but can do without in self test: net-misc/stunnel
-#S="${WORKDIR}"/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-strip-ldflags.patch
-# epatch "${FILESDIR}"/curl-7.16.2-strip-ldflags.patch
- elibtoolize
-}
-
-src_compile() {
-
- myconf="$(use_enable ldap)
- $(use_enable ldap ldaps)
- $(use_with idn libidn)
- $(use_enable kerberos gssapi)
- $(use_enable ipv6)
- $(use_with libssh2)
- --enable-http
- --enable-ftp
- --enable-gopher
- --enable-file
- --enable-dict
- --enable-manual
- --enable-telnet
- --enable-nonblocking
- --enable-largefile
- --enable-maintainer-mode
- --disable-sspi
- --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt
- --without-krb4
- --without-spnego"
-# --with-libssh2
-
- if use ipv6 && use ares; then
- elog "c-ares support disabled because it is incompatible with ipv6."
- myconf="${myconf} --disable-ares"
- else
- myconf="${myconf} $(use_enable ares)"
- fi
-
- if use gnutls; then
- myconf="${myconf} --without-ssl --with-gnutls --without-nss"
- elif use nss; then
- myconf="${myconf} --without-ssl --without-gnutls --with-nss"
- elif use ssl; then
- myconf="${myconf} --without-gnutls --without-nss --with-ssl"
- else
- myconf="${myconf} --without-gnutls --without-nss --without-ssl"
- fi
-
- econf ${myconf} || die 'configure failed'
- emake || die "install failed for current version"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "installed failed for current version"
- rm -rf "${D}"/etc/
-
- # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
- insinto /usr/share/aclocal
- doins docs/libcurl/libcurl.m4
-
- dodoc CHANGES README
- dodoc docs/FEATURES docs/INTERNALS
- dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
-}
-
-pkg_postinst() {
- if [[ -e "${ROOT}"/usr/$(get_libdir)/libcurl.so.3 ]] ; then
- elog "You must re-compile all packages that are linked against"
- elog "curl-7.15.* by using revdep-rebuild from gentoolkit:"
- elog "# revdep-rebuild --library libcurl.so.3"
- fi
-}
diff --git a/net-misc/curl/curl-7.17.0_pre20070828.ebuild b/net-misc/curl/curl-7.17.1_pre20071013.ebuild
index 14c42df28a22..6b595a4e2922 100644
--- a/net-misc/curl/curl-7.17.0_pre20070828.ebuild
+++ b/net-misc/curl/curl-7.17.1_pre20071013.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.17.0_pre20070828.ebuild,v 1.2 2007/08/29 07:11:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.17.1_pre20071013.ebuild,v 1.1 2007/10/14 06:40:18 dragonheart Exp $
# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
@@ -16,6 +16,7 @@ LICENSE="MIT X11"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="ssl ipv6 ldap ares gnutls nss idn kerberos test"
+#IUSE="ssl ipv6 ldap ares gnutls libssh2 nss idn kerberos test"
RDEPEND="gnutls? ( net-libs/gnutls )
nss? ( !gnutls? ( dev-libs/nss ) )
@@ -25,6 +26,7 @@ RDEPEND="gnutls? ( net-libs/gnutls )
ares? ( >=net-dns/c-ares-1.4.0 )
kerberos? ( virtual/krb5 )
app-misc/ca-certificates"
+# libssh2? ( >=net-libs/libssh2-0.16 )"
# net-libs/libssh2 (masked) --with-libssh2
# fbopenssl (not in gentoo) --with-spnego
@@ -67,6 +69,7 @@ src_compile() {
--without-krb4
--without-libssh2
--without-spnego"
+# $(use_with libssh2)
if use ipv6 && use ares; then
elog "c-ares support disabled because it is incompatible with ipv6."
diff --git a/net-misc/curl/files/digest-curl-7.17.0-r1 b/net-misc/curl/files/digest-curl-7.17.0-r1
deleted file mode 100644
index 76941a41a12e..000000000000
--- a/net-misc/curl/files/digest-curl-7.17.0-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 b529a8d2778c8ad09c33d9bbddee7e44 curl-7.17.0.tar.bz2 1698728
-RMD160 12141ad0f5de32e9d496f3d499bf6fda80a4308e curl-7.17.0.tar.bz2 1698728
-SHA256 3aabf85ef56afeddd66c7180971fbd6412133d85311a76b7a274f80982301cc3 curl-7.17.0.tar.bz2 1698728
diff --git a/net-misc/curl/files/digest-curl-7.17.0_pre20070828 b/net-misc/curl/files/digest-curl-7.17.0_pre20070828
deleted file mode 100644
index 072caa393c2d..000000000000
--- a/net-misc/curl/files/digest-curl-7.17.0_pre20070828
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 7b48931e065997bd47e757ab82f5b822 curl-7.17.0-20070828.tar.bz2 1761100
-RMD160 6f1ae3eef10a3674957a9bce8f3ea59d493b4baa curl-7.17.0-20070828.tar.bz2 1761100
-SHA256 9ed64d8d0f06b5ff2695168924ac2f8f342092f0af290da7dacfe29e4190276e curl-7.17.0-20070828.tar.bz2 1761100
diff --git a/net-misc/curl/files/digest-curl-7.17.1_pre20071013 b/net-misc/curl/files/digest-curl-7.17.1_pre20071013
new file mode 100644
index 000000000000..3376479f3a5a
--- /dev/null
+++ b/net-misc/curl/files/digest-curl-7.17.1_pre20071013
@@ -0,0 +1,3 @@
+MD5 fca3ae42fc530b8e98d377ca6d38edb9 curl-7.17.1-20071013.tar.bz2 1766588
+RMD160 1cf52a1ed6d187bdcaea7de0331b54a11260c38d curl-7.17.1-20071013.tar.bz2 1766588
+SHA256 5e702c0bc1e9c51f3b19e1e9f6e013310836f60f831bc50debc599192e792537 curl-7.17.1-20071013.tar.bz2 1766588