summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/alsa-utils/ChangeLog18
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.19.ebuild91
-rw-r--r--media-sound/alsa-utils/files/alsasound-1.0.19.confd36
-rw-r--r--media-sound/alsa-utils/files/alsasound-1.0.19.initd241
4 files changed, 384 insertions, 2 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 3e722ef5aff7..eb5286d3fc8f 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for media-sound/alsa-utils
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.254 2008/12/21 15:03:35 nixnut Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.255 2009/01/19 17:21:11 chainsaw Exp $
+
+*alsa-utils-1.0.19 (19 Jan 2009)
+
+ 19 Jan 2009; <chainsaw@gentoo.org> +files/alsasound-1.0.19.confd,
+ +files/alsasound-1.0.19.initd, +alsa-utils-1.0.19.ebuild:
+ Version bump, disabling the ill-advised automatic module unloading. Note
+ that our recommendations have changed, you are encouraged to build your
+ audio drivers into the kernels unless the device is hotpluggable or needs
+ special parameters (such as model= for HD-Audio). Unloading did not work
+ if the audio device prefix was not snd, as reported by chad heuschober
+ <chad_ryan1@hotmail.com> in bug #175740. As Dieter Ries <clip2@gmx.de>
+ reported in bug #253535 the modularisation of the HD-Audio driver meant
+ that the fragile code handling this broke further as ordering was not
+ taken into account.
21 Dec 2008; nixnut <nixnut@gentoo.org> alsa-utils-1.0.17.ebuild:
Stable on ppc wrt bug 245517
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.19.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.19.ebuild
new file mode 100644
index 000000000000..d4d6ad6a5268
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.19.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.19.ebuild,v 1.1 2009/01/19 17:21:11 chainsaw Exp $
+
+inherit eutils
+
+MY_P="${P/_rc/rc}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls midi minimal"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-${PV}
+ app-text/xmlto"
+RDEPEND="${DEPEND}
+ virtual/modutils
+ !minimal? ( sys-apps/pciutils )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use midi && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ eerror ""
+ eerror "To be able to build alsa-utils with midi support you need"
+ eerror "to have built media-libs/alsa-lib with midi USE flag."
+ die "Missing midi USE flag on media-libs/alsa-lib"
+ fi
+}
+
+src_compile() {
+ econf $(use_enable nls) \
+ $(use_enable midi sequencer) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+pkg_preinst() {
+ if [[ -a /etc/modules.d/alsa ]] && [[ ! -a /etc/modprobe.d/alsa ]]; then
+ elog "Moving old alsa configuration in modules.d to new"
+ elog "location in modprobe.d in /etc/"
+ mv "${ROOT}/etc/modules.d/alsa" "${ROOT}/etc/modprobe.d/alsa"
+ fi
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ emake DESTDIR="${D}" install || die "Installation Failed"
+
+ dodoc ${ALSA_UTILS_DOCS} || die
+ newdoc alsamixer/README README.alsamixer || die
+
+ newinitd "${FILESDIR}/alsasound-1.0.19.initd" alsasound
+ newconfd "${FILESDIR}/alsasound-1.0.19.confd" alsasound
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}/alsa-modules.conf-rc" alsa
+
+ keepdir /var/lib/alsa
+}
+
+pkg_postinst() {
+ echo
+ elog "To take advantage of the init script, and automate the process of"
+ elog "storing and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog " # rc-update add alsasound boot"
+ echo
+ elog "The script will load ALSA modules, if you choose to use a modular"
+ elog "configuration. The Gentoo ALSA developers recommend you to build"
+ elog "your audio drivers into the kernel unless the device is hotpluggable"
+ elog "or you need to supply specific options (such as model= to HD Audio)."
+ echo
+ ewarn "Automated unloading of ALSA modules is deprecated and unsupported."
+ ewarn "Should you choose to use it, bug reports will not be accepted."
+ echo
+ if use minimal; then
+ ewarn "The minimal use flag disables the dependency on pciutils that"
+ ewarn "is needed by alsaconf at runtime."
+ fi
+}
diff --git a/media-sound/alsa-utils/files/alsasound-1.0.19.confd b/media-sound/alsa-utils/files/alsasound-1.0.19.confd
new file mode 100644
index 000000000000..c54d14332261
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsasound-1.0.19.confd
@@ -0,0 +1,36 @@
+# ENABLE_OSS_EMUL:
+# Do you want to enable in-kernel oss emulation?
+# no - Do not load oss emul drivers
+# yes - Load oss emul drivers if they're found
+
+ENABLE_OSS_EMUL="yes"
+
+# RESTORE_ON_START:
+# Do you want to restore your mixer settings? If not, your cards will be
+# muted.
+# no - Do not restore state
+# yes - Restore state
+
+RESTORE_ON_START="yes"
+
+# SAVE_ON_STOP:
+# Do you want to save changes made to your mixer volumes when alsasound
+# stops?
+# no - Do not save state
+# yes - Save state
+
+SAVE_ON_STOP="yes"
+
+# LOAD_ON_START:
+# Do you want to load sound modules when alsasound starts?
+# Note: The Gentoo ALSA developers encourage you to build your sound
+# drivers into the kernel unless the device is hotpluggable or
+# you need to supply specific options (such as model= to HD-Audio).
+# no - Do not load modules
+# yes - Load modules
+LOAD_ON_START="yes"
+
+# Deprecated options:
+# Upstream feels, and we wholehartedly agree, that this was a silly idea
+UNLOAD_ON_STOP="no"
+KILLPROC_ON_STOP="no"
diff --git a/media-sound/alsa-utils/files/alsasound-1.0.19.initd b/media-sound/alsa-utils/files/alsasound-1.0.19.initd
new file mode 100644
index 000000000000..90bd11f0dfc9
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsasound-1.0.19.initd
@@ -0,0 +1,241 @@
+#!/sbin/runscript
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/files/alsasound-1.0.19.initd,v 1.1 2009/01/19 17:21:11 chainsaw Exp $
+# Copyright 2007,2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+alsastatedir=/var/lib/alsa
+alsascrdir=/etc/alsa.d
+
+opts="save restore"
+
+depend() {
+ need localmount
+ after bootmisc modules isapnp coldplug hotplug
+}
+
+load_modules() {
+ # List of drivers for each card.
+ local DRIVERS="$(modprobe -c | sed -n -e 's/^alias \(snd-card-[[:digit:]]\+\) .*/\1/p')"
+
+ # Fall back on the automated aliases if we don't have ALSA configured properly...
+ if [ -z "${DRIVERS}" ] && \
+ ( [ ! -r /proc/asound/cards ] || grep -q ' no soundcards ' /proc/asound/cards 2>/dev/null ) ; then
+ ewarn "Could not detect custom ALSA settings. Loading all detected alsa drivers."
+ DRIVERS="$(modprobe -c | sed -n -e '/^alias pci:.* snd.*/ s/^alias pci:[^ ]* \(.*\)/\1/p' | sort | uniq)"
+ if [ -z "${DRIVERS}" ] ; then
+ eerror "Unable to find any ALSA drivers. Have you configured your kernel correctly?"
+ fi
+ fi
+
+ if [ "${ENABLE_OSS_EMUL}" = "yes" ] ; then
+ DRIVERS="${DRIVERS} $(modprobe -l | sed -n -e '/snd.*oss/ s:\/.*\/\(.*\).ko:\1:p')"
+ fi
+
+ # We want to ensure snd-seq is loaded as it is needed for things like
+ # timidity even if we don't use a real sequencer.
+ DRIVERS="${DRIVERS} $(modprobe -l | sed -n -e '/snd.seq\./ s:\/.*\/\(.*\).ko:\1:p')"
+
+ # We want to ensure snd-ioctl32 is loaded as it is needed for 32bit
+ # compatibility
+ DRIVERS="${DRIVERS} $(modprobe -l | sed -n -e '/snd.ioctl32\./ s:\/.*\/\(.*\).ko:\1:p')"
+
+ local DRIVER= DMOD=
+ for DRIVER in ${DRIVERS} ; do
+ [ "${DRIVER}" = "off" ] && continue
+ DMOD="$(echo "${DRIVER}" | sed -e 's/-/_/g')"
+ if ! grep -q "^${DMOD} " /proc/modules ; then
+ ebegin "Loading: ${DRIVER}"
+ modprobe ${DRIVER}
+ eend $?
+ fi
+ done
+
+ if [ -f /proc/asound/seq/drivers ] ; then
+ local SEQUENCERS="$(sed -n -e 's/\([^,]*\),empty,.*/\1/p' /proc/asound/seq/drivers)"
+ local SEQUENCER
+ for SEQUENCER in ${SEQUENCERS} ; do
+ DMOD="$(echo "${SEQUENCER}" | sed -e 's/-/_/g')"
+ if ! grep -q "^${DMOD} " /proc/modules ; then
+ ebegin "Loading: ${SEQUENCER}"
+ modprobe ${SEQUENCER}
+ eend $?
+ fi
+ done
+ fi
+
+ for DRIVER in ${DRIVERS}
+ do
+ local TMP=${DRIVER##snd-}
+ TMP=${TMP##snd_}
+ if [ -x "${alsascrdir}/${TMP}" ] ; then
+ ebegin "Running: ${alsascrdir}/${TMP}"
+ "${alsascrdir}/${TMP}"
+ eend $?
+ fi
+ done
+
+ if [ ! -d /proc/asound ] || grep -q ' no soundcards ' /proc/asound/cards ; then
+ eerror "ERROR: Failed to load necessary drivers"
+ return 1
+ fi
+}
+
+unload_modules_24() {
+ local LOADED_MODULES="$(lsmod | sed -n -e 's/^\(snd[^ ]*\) .*/\1/p')"
+ local MODULE
+ for MODULE in ${LOADED_MODULES} ; do
+ rmmod "${MODULE}"
+ done
+ rmmod soundcore 2>/dev/null
+ rmmod gameport 2>/dev/null
+
+ lsmod | grep -vq '^snd'
+}
+
+unload_modules_recursive() {
+ local revdeps="$(lsmod | sed -n -e "s/,/ /g" -e "s/^$1 *[0-9]* *[0-9]* \(.*\)/\1/p")"
+
+ for module in ${revdeps} ; do
+ unload_modules_recursive "${module}"
+ done
+
+ vebegin "Unloading: $1"
+ rmmod --wait "$1"
+ veend $?
+}
+
+unload_modules_26() {
+ # First of all, remove the snd module and all the modules depending
+ # on it, this should remove already most of ALSA modules.
+ lsmod | grep -q "^snd[[:space:]]" && unload_modules_recursive snd
+
+ # Then find the remaining ones, and handle them too.
+ for module in $(lsmod | sed -n -e 's/^\(snd[^ ]*\) .*/\1/p'); do
+ unload_modules_recursive "${module}"
+ done
+
+ lsmod | grep -vq "^snd"
+}
+
+terminate() {
+ #
+ # Kill processes holding open sound devices
+ #
+ # DEVS=`find /dev/ -follow -type c -maxdepth 1 -print 2>/dev/null | xargs ls -dils | grep "1*1[46]," | cut -d: -f2 | cut -d" " -f2; echo /proc/asound/dev/*`
+ local ossdevs="/dev/admmidi* /dev/adsp* /dev/amidi* /dev/audio* /dev/dmfm* \
+ /dev/dmmidi* /dev/dsp* /dev/dspW* /dev/midi0* /dev/mixer* /dev/music \
+ /dev/patmgr* /dev/sequencer* /dev/sndstat"
+ local alsadevs="/proc/asound/dev/* /dev/sound/* /dev/snd/*"
+ fuser -k ${ossdevs} ${alsadevs} >/dev/null 2>/dev/null
+
+ # remove all sequencer connections if any
+ [ -f /proc/asound/seq/clients ] && type aconnect >/dev/null 2>/dev/null && aconnect --removeall
+}
+
+restore() {
+ ebegin "Restoring Mixer Levels"
+
+ if [ ! -r "${alsastatedir}/asound.state" ] ; then
+ ewarn "No mixer config in ${alsastatedir}/asound.state, you have to unmute your card!"
+ eend 0
+ return 0
+ fi
+
+ local cards="$(sed -n -e 's/ *\([[:digit:]]*\) .*/\1/p' /proc/asound/cards)"
+ local CARDNUM
+ for cardnum in ${cards}; do
+ [ -e /dev/snd/controlC${cardnum} ] || sleep 2
+ [ -e /dev/snd/controlC${cardnum} ] || sleep 2
+ [ -e /dev/snd/controlC${cardnum} ] || sleep 2
+ [ -e /dev/snd/controlC${cardnum} ] || sleep 2
+ alsactl -f "${alsastatedir}/asound.state" restore ${cardnum} \
+ || ewarn "Errors while restoring defaults, ignoring"
+ done
+
+ for ossfile in "${alsastatedir}"/oss/card*_pcm* ; do
+ [ -e "${ossfile}" ] || continue
+ # We use cat because I'm not sure if cp works properly on /proc
+ local procfile=${ossfile##${alsastatedir}/oss}
+ procfile="$(echo "${procfile}" | sed -e 's,_,/,g')"
+ if [ -e /proc/asound/"${procfile}"/oss ] ; then
+ cat "${ossfile}" > /proc/asound/"${procfile}"/oss
+ fi
+ done
+
+ eend 0
+}
+
+save() {
+ ebegin "Storing ALSA Mixer Levels"
+
+ mkdir -p "${alsastatedir}"
+ if ! alsactl -f "${alsastatedir}/asound.state" store; then
+ eerror "Error saving levels."
+ eend 1
+ return 1
+ fi
+
+ for ossfile in /proc/asound/card*/pcm*/oss; do
+ [ -e "${ossfile}" ] || continue
+ local device=${ossfile##/proc/asound/} ; device=${device%%/oss}
+ device="$(echo "${device}" | sed -e 's,/,_,g')"
+ mkdir -p "${alsastatedir}/oss/"
+ cp "${ossfile}" "${alsastatedir}/oss/${device}"
+ done
+
+ eend 0
+}
+
+start() {
+ if [ -f /proc/modules ] && [ "${LOAD_ON_START}" = "yes" ]; then
+ ebegin "Loading ALSA modules"
+ eindent
+ load_modules
+ eoutdent
+ eend $? || return 1
+ fi
+
+ if [ ! -d /proc/asound ]; then
+ eerror "ALSA failed to load."
+ eend 1
+ return 1
+ elif [ "${RESTORE_ON_START}" = "yes" ]; then
+ restore
+ fi
+
+ return 0
+}
+
+stop() {
+ if [ ! -d /proc/asound ] ; then
+ eerror "ALSA is not loaded"
+ return 0
+ fi
+
+ [ "${SAVE_ON_STOP}" = "yes" ] && save
+
+ if [ "${KILLPROC_ON_STOP}" = "yes" ] ; then
+ ewarn "You are using the unsupported KILLPROC_ON_STOP option."
+ ewarn "Consider unsetting it. Do not file bugs until you have done so."
+ ebegin "Killing processes using ALSA"
+ terminate
+ eend 0
+ fi
+
+ if [ -f /proc/modules ] && [ "${UNLOAD_ON_STOP}" = "yes" ]; then
+ ewarn "You are using the unsupported UNLOAD_ON_STOP option."
+ ewarn "Consider unsetting it. Do not file bugs until you have done so."
+ local ver="26"
+ case "$(uname -r)" in
+ 2.[01234].*) ver="24";;
+ *) ver="26";;
+ esac
+ ebegin "Unloading ALSA modules"
+ eindent
+ unload_modules_${ver}
+ eend $?
+ eoutdent
+ fi
+
+ return 0
+}