summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/logcheck/ChangeLog8
-rw-r--r--app-admin/logcheck/files/logcheck.cron11
-rw-r--r--app-admin/logcheck/logcheck-1.3.15-r1.ebuild46
3 files changed, 61 insertions, 4 deletions
diff --git a/app-admin/logcheck/ChangeLog b/app-admin/logcheck/ChangeLog
index 493c0c615db6..08e8190a1fb3 100644
--- a/app-admin/logcheck/ChangeLog
+++ b/app-admin/logcheck/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/logcheck
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/logcheck/ChangeLog,v 1.26 2012/07/31 15:53:27 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logcheck/ChangeLog,v 1.27 2012/12/30 18:53:17 phajdan.jr Exp $
+
+*logcheck-1.3.15-r1 (30 Dec 2012)
+
+ 30 Dec 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ +logcheck-1.3.15-r1.ebuild, files/logcheck.cron:
+ Make sure lock directory exists, bug #440880 by Ivan.
*logcheck-1.3.15 (31 Jul 2012)
diff --git a/app-admin/logcheck/files/logcheck.cron b/app-admin/logcheck/files/logcheck.cron
index 992eb7178920..3b3f4fcf62bd 100644
--- a/app-admin/logcheck/files/logcheck.cron
+++ b/app-admin/logcheck/files/logcheck.cron
@@ -1,5 +1,10 @@
#!/bin/bash
-#
-# Please uncomment the following if you want logcheck to run hourly.
-#su -s /bin/bash -c /usr/sbin/logcheck logcheck
+set -e
+
+if [ ! -d /var/lock/logcheck ]; then
+ mkdir -p /var/lock/logcheck
+fi
+chown -R logcheck:logcheck /var/lock/logcheck
+
+su -s /bin/bash -c /usr/sbin/logcheck logcheck
diff --git a/app-admin/logcheck/logcheck-1.3.15-r1.ebuild b/app-admin/logcheck/logcheck-1.3.15-r1.ebuild
new file mode 100644
index 000000000000..dd90f5528570
--- /dev/null
+++ b/app-admin/logcheck/logcheck-1.3.15-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logcheck/logcheck-1.3.15-r1.ebuild,v 1.1 2012/12/30 18:53:17 phajdan.jr Exp $
+
+EAPI="4"
+
+inherit user
+
+DESCRIPTION="Mails anomalies in the system logfiles to the administrator."
+HOMEPAGE="http://packages.debian.org/sid/logcheck"
+SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!app-admin/logsentry
+ app-misc/lockfile-progs
+ dev-lang/perl
+ dev-perl/mime-construct
+ virtual/mailx
+ ${DEPEND}"
+
+pkg_setup() {
+ enewgroup logcheck
+ enewuser logcheck -1 -1 -1 logcheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ keepdir /var/lib/logcheck
+ dodoc AUTHORS CHANGES CREDITS TODO docs/README.*
+ doman docs/logtail.8 docs/logtail2.8
+
+ exeinto /etc/cron.hourly
+ doexe "${FILESDIR}/${PN}.cron"
+}
+
+pkg_postinst() {
+ chown -R logcheck:logcheck /etc/logcheck /var/lib/logcheck || die
+
+ elog "Please read the guide ad http://www.gentoo.org/doc/en/logcheck.xml"
+ elog "for installation instructions."
+}