summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-servers/gatling/ChangeLog9
-rw-r--r--www-servers/gatling/files/gatling-0.13-compile.patch11
-rw-r--r--www-servers/gatling/gatling-0.13.ebuild61
3 files changed, 79 insertions, 2 deletions
diff --git a/www-servers/gatling/ChangeLog b/www-servers/gatling/ChangeLog
index 5554aac28081..df6a19b96292 100644
--- a/www-servers/gatling/ChangeLog
+++ b/www-servers/gatling/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/gatling
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/gatling/ChangeLog,v 1.11 2012/04/10 02:58:04 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gatling/ChangeLog,v 1.12 2012/11/05 07:01:34 patrick Exp $
+
+*gatling-0.13 (05 Nov 2012)
+
+ 05 Nov 2012; Patrick Lauer <patrick@gentoo.org>
+ +files/gatling-0.13-compile.patch, +gatling-0.13.ebuild:
+ Bump
10 Apr 2012; Sebastian Pipping <sping@gentoo.org> gatling-0.12-r2.ebuild,
+files/gatling-0.12-compile.patch:
@@ -59,4 +65,3 @@
12 May 2008; Maximilian Gaß <mxey@cloudconnected.org +gatling-0.9.ebuild,
+files/gentoo-vars.patch, +metadata.xml:
New Ebuild for bug 221841
-
diff --git a/www-servers/gatling/files/gatling-0.13-compile.patch b/www-servers/gatling/files/gatling-0.13-compile.patch
new file mode 100644
index 000000000000..7b4d44af9c09
--- /dev/null
+++ b/www-servers/gatling/files/gatling-0.13-compile.patch
@@ -0,0 +1,11 @@
+--- GNUmakefile 2012-04-10 04:31:14.505474482 +0200
++++ GNUmakefile 2012-04-10 04:31:53.821982958 +0200
+@@ -64,7 +64,7 @@
+ acc: acc.c
+ $(CC) -o $@ $< $(CFLAGS) $(LDFLAGS) -lowfat
+
+-CC:=$(DIET) $(CC)
++override CC:=$(DIET) $(CC)
+
+ pthreadbench: pthreadbench.o
+ $(CC) $< -o $@ -I. $(CFLAGS) $(LDFLAGS) $(LDLIBS) -lpthread
diff --git a/www-servers/gatling/gatling-0.13.ebuild b/www-servers/gatling/gatling-0.13.ebuild
new file mode 100644
index 000000000000..3d45b597d7a2
--- /dev/null
+++ b/www-servers/gatling/gatling-0.13.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gatling/gatling-0.13.ebuild,v 1.1 2012/11/05 07:01:34 patrick Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="High performance web server"
+HOMEPAGE="http://www.fefe.de/gatling/"
+SRC_URI="http://dl.fefe.de/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="ssl diet"
+REQUIRED_USE="ssl? ( !diet )"
+
+DEPEND=">=dev-libs/libowfat-0.25[diet=]
+ diet? ( dev-libs/dietlibc )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ rm Makefile # leaves us with GNUmakefile
+ epatch "${FILESDIR}/${P}-compile.patch"
+}
+
+src_compile() {
+ local DIET=
+ use diet && DIET='/usr/bin/diet'
+
+ local targets='gatling'
+ use ssl && targets+=' tlsgatling'
+
+ emake DIET="${DIET}" CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -I/usr/include/libowfat" \
+ LDFLAGS="${LDFLAGS}" prefix=/usr ${targets} \
+ || die "emake ${targets} failed"
+}
+
+src_install() {
+ doman gatling.1 || die "installing manpage failed"
+
+ newconfd "${FILESDIR}/gatling.confd" gatling || die
+ newinitd "${FILESDIR}/gatling.initd-2" gatling || die
+ dodoc README.{ftp,http} || die "installing docs failed"
+
+ dobin gatling || die "installing gatling binary failed"
+ use ssl && {
+ dodoc README.tls || die "installing docs failed"
+ dobin tlsgatling || die "installing tlsgatling binary failed"
+ }
+}
+
+pkg_setup() {
+ ebegin "Creating gatling user and group"
+ enewgroup gatling
+ enewuser ${PN} -1 -1 /var/www/localhost ${PN}
+}