summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/scientificpython/ChangeLog9
-rw-r--r--dev-python/scientificpython/files/digest-scientificpython-2.63
-rw-r--r--dev-python/scientificpython/scientificpython-2.6.ebuild40
3 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/scientificpython/ChangeLog b/dev-python/scientificpython/ChangeLog
index 242a3f152deb..d00e28dbca38 100644
--- a/dev-python/scientificpython/ChangeLog
+++ b/dev-python/scientificpython/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/scientificpython
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scientificpython/ChangeLog,v 1.9 2006/06/26 16:01:57 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scientificpython/ChangeLog,v 1.10 2006/10/17 03:59:32 dberkholz Exp $
+
+*scientificpython-2.6 (17 Oct 2006)
+
+ 17 Oct 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ +scientificpython-2.6.ebuild:
+ (#117792) Bump, thanks to Jaroslaw Kalinowski and Sebastien Fabbro for the
+ initial ebuilds.
26 Jun 2006; Donnie Berkholz <spyderous@gentoo.org>; metadata.xml:
Add sci herd to metadata, as this is decidedly a scientific package.
diff --git a/dev-python/scientificpython/files/digest-scientificpython-2.6 b/dev-python/scientificpython/files/digest-scientificpython-2.6
new file mode 100644
index 000000000000..c2d96684c744
--- /dev/null
+++ b/dev-python/scientificpython/files/digest-scientificpython-2.6
@@ -0,0 +1,3 @@
+MD5 6ebd96fc8a4e015adab2c57826d52e9f ScientificPython-2.6.tar.gz 514044
+RMD160 5c9e8cba2373d722854cfe57e270803d7ed2bf2a ScientificPython-2.6.tar.gz 514044
+SHA256 cfa06b0e5bdadfdc79328bfd01843f9e7b0a08f7c19d1f32a7ecec498be72cc0 ScientificPython-2.6.tar.gz 514044
diff --git a/dev-python/scientificpython/scientificpython-2.6.ebuild b/dev-python/scientificpython/scientificpython-2.6.ebuild
new file mode 100644
index 000000000000..8a8926066a35
--- /dev/null
+++ b/dev-python/scientificpython/scientificpython-2.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scientificpython/scientificpython-2.6.ebuild,v 1.1 2006/10/17 03:59:32 dberkholz Exp $
+
+MY_P=${P/scientificpython/ScientificPython}
+S=${WORKDIR}/${MY_P}
+DV=1034 # hardcoded download version
+
+inherit distutils
+
+IUSE="mpi"
+DESCRIPTION="Scientific Module for Python"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${DV}/${MY_P}.tar.gz"
+HOMEPAGE="http://dirac.cnrs-orleans.fr/ScientificPython/"
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="virtual/python
+ >=dev-python/numeric-23.0
+ >=sci-libs/netcdf-3.0
+ mpi? ( virtual/mpi )"
+
+src_compile() {
+ distutils_src_compile
+ if use mpi; then
+ cd Src/MPI
+ ${python} compile.py
+ dobin mpipython || die "dobin failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc MANIFEST.in README* Doc/CHANGELOG Doc/*.pdf
+ dohtml Doc/Reference/*
+ docinto Examples; dodoc Examples/*
+ docinto Examples/BSP; dodoc Examples/BSP/*
+}