summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/DBD-Pg/ChangeLog9
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-2.11.8.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-perl/DBD-Pg/ChangeLog b/dev-perl/DBD-Pg/ChangeLog
index a87226232d95..7dab95672e13 100644
--- a/dev-perl/DBD-Pg/ChangeLog
+++ b/dev-perl/DBD-Pg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/DBD-Pg
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/ChangeLog,v 1.60 2008/09/15 18:00:08 tove Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/ChangeLog,v 1.61 2009/01/16 10:52:00 robbat2 Exp $
+
+*DBD-Pg-2.11.8 (16 Jan 2009)
+
+ 16 Jan 2009; Robin H. Johnson <robbat2@gentoo.org> +DBD-Pg-2.11.8.ebuild:
+ Version bump, passes on 8.3 split and 8.2 non-split for me.
15 Sep 2008; Torsten Veller <tove@gentoo.org> -DBD-Pg-1.42.ebuild,
-DBD-Pg-1.43.ebuild, -DBD-Pg-1.48.ebuild:
diff --git a/dev-perl/DBD-Pg/DBD-Pg-2.11.8.ebuild b/dev-perl/DBD-Pg/DBD-Pg-2.11.8.ebuild
new file mode 100644
index 000000000000..753369026f8f
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-2.11.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/DBD-Pg-2.11.8.ebuild,v 1.1 2009/01/16 10:52:00 robbat2 Exp $
+
+MODULE_AUTHOR=TURNSTEP
+inherit perl-module eutils
+
+DESCRIPTION="The Perl DBD::Pg Module"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="virtual/perl-Test-Simple
+ >=virtual/perl-Test-Harness-2.03
+ >=dev-perl/DBI-1.52
+ >=virtual/postgresql-base-7.3"
+
+mydoc="README"
+
+# testcases require a local database with an
+# open password for the postgres user.
+SRC_TEST="skip"
+
+src_compile() {
+ postgres_include="$(readlink -f /usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d ${postgres_lib}/${i} ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_compile
+}