summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/activesupport/ChangeLog9
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.8.ebuild38
-rw-r--r--dev-ruby/activesupport/files/activesupport-2.3.8-unvendorize.patch35
3 files changed, 81 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 6fef3c8ee361..c14822de0132 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.120 2010/05/23 10:36:02 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.121 2010/05/31 05:55:46 graaff Exp $
+
+*activesupport-2.3.8 (31 May 2010)
+
+ 31 May 2010; Hans de Graaff <graaff@gentoo.org>
+ +activesupport-2.3.8.ebuild, +files/activesupport-2.3.8-unvendorize.patch:
+ Bump for Rails 2.3.8. Drop hppa/ppc/ppc64/x86-fbsd keywords due to new
+ unkeyworded dependency.
23 May 2010; Alex Legler <a3li@gentoo.org> activesupport-2.3.5-r1.ebuild:
Add REE18 support
diff --git a/dev-ruby/activesupport/activesupport-2.3.8.ebuild b/dev-ruby/activesupport/activesupport-2.3.8.ebuild
new file mode 100644
index 000000000000..d6d917da09d9
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-2.3.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.8.ebuild,v 1.1 2010/05/31 05:55:46 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/builder-2.1.2 >=dev-ruby/tzinfo-0.3.16 >=dev-ruby/i18n-0.3.3:0.3"
+
+all_ruby_prepare() {
+ # Remove the bundled packages!
+ rm -r lib/active_support/vendor/{tzinfo,builder,i18n}-* \
+ || die "failed to remove vendor packages"
+
+ # This patch removes the fallback to local vendorized gems, as
+ # well as fixing the dependencies for i18n to use only the 0.1
+ # slot.
+ epatch "${FILESDIR}"/${P}-unvendorize.patch
+
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-2.3.5-mocha-0.9.5.patch
+}
diff --git a/dev-ruby/activesupport/files/activesupport-2.3.8-unvendorize.patch b/dev-ruby/activesupport/files/activesupport-2.3.8-unvendorize.patch
new file mode 100644
index 000000000000..866611857449
--- /dev/null
+++ b/dev-ruby/activesupport/files/activesupport-2.3.8-unvendorize.patch
@@ -0,0 +1,35 @@
+Index: activesupport-2.3.5/lib/active_support/vendor.rb
+===================================================================
+--- activesupport-2.3.5.orig/lib/active_support/vendor.rb
++++ activesupport-2.3.5/lib/active_support/vendor.rb
+@@ -1,11 +1,7 @@
+ # Prefer gems to the bundled libs.
+ require 'rubygems'
+
+-begin
+- gem 'builder', '~> 2.1.2'
+-rescue Gem::LoadError
+- $:.unshift "#{File.dirname(__FILE__)}/vendor/builder-2.1.2"
+-end
++gem 'builder', '~> 2.1.2'
+ require 'builder'
+
+ begin
+@@ -14,15 +10,7 @@ rescue Gem::LoadError
+ $:.unshift "#{File.dirname(__FILE__)}/vendor/memcache-client-1.7.4"
+ end
+
+-begin
+- gem 'tzinfo', '~> 0.3.12'
+-rescue Gem::LoadError
+- $:.unshift "#{File.dirname(__FILE__)}/vendor/tzinfo-0.3.12"
+-end
++gem 'tzinfo', '~> 0.3.12'
+
+-begin
+- gem 'i18n', '>= 0.3.3'
+-rescue Gem::LoadError
+- $:.unshift "#{File.dirname(__FILE__)}/vendor/i18n-0.3.7"
+-end
++gem 'i18n', '~> 0.3.3'
+ require 'i18n'