summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/bcwipe/ChangeLog8
-rw-r--r--app-crypt/bcwipe/bcwipe-1.5_p3.ebuild10
-rw-r--r--app-crypt/bcwipe/bcwipe-1.6_p1.ebuild45
-rw-r--r--app-crypt/bcwipe/files/digest-bcwipe-1.5_p34
-rw-r--r--app-crypt/bcwipe/files/digest-bcwipe-1.6_p16
5 files changed, 70 insertions, 3 deletions
diff --git a/app-crypt/bcwipe/ChangeLog b/app-crypt/bcwipe/ChangeLog
index 5b90c6f47e9c..3266a467b3ad 100644
--- a/app-crypt/bcwipe/ChangeLog
+++ b/app-crypt/bcwipe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/bcwipe
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/ChangeLog,v 1.16 2006/04/19 03:55:10 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/ChangeLog,v 1.17 2006/04/23 06:05:15 dragonheart Exp $
+
+*bcwipe-1.6_p1 (23 Apr 2006)
+
+ 23 Apr 2006; Daniel Black <dragonheart@gentoo.org> -bcwipe-1.3_p1.ebuild,
+ -bcwipe-1.5_p2.ebuild, bcwipe-1.5_p3.ebuild, +bcwipe-1.6_p1.ebuild:
+ version bump. fix typo in 1.5_p3. remove old versions
19 Apr 2006; Jason Wever <weeve@gentoo.org> bcwipe-1.5_p3.ebuild:
Stable on SPARC.
diff --git a/app-crypt/bcwipe/bcwipe-1.5_p3.ebuild b/app-crypt/bcwipe/bcwipe-1.5_p3.ebuild
index 6795ac90aa85..c8d9b568a28c 100644
--- a/app-crypt/bcwipe/bcwipe-1.5_p3.ebuild
+++ b/app-crypt/bcwipe/bcwipe-1.5_p3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/bcwipe-1.5_p3.ebuild,v 1.5 2006/04/19 03:55:10 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/bcwipe-1.5_p3.ebuild,v 1.6 2006/04/23 06:05:15 dragonheart Exp $
inherit toolchain-funcs
@@ -25,7 +25,7 @@ src_compile() {
src_test() {
echo "abc123" >> testfile
- ./bcwipe -f testfile || dir "bcwipe test failed"
+ ./bcwipe -f testfile || die "bcwipe test failed"
[ -f testfile ] && die "test file still exists. bcwipe should of deleted it"
}
@@ -37,3 +37,9 @@ src_install() {
dodir /usr/share/doc/${PF}
cp -r * ${D}/usr/share/doc/${PF}
}
+
+pkg_postinst() {
+ ewarn "The BestCrypt drivers are not free - Please purchace a license from "
+ ewarn "http://www.jetico.com/"
+ ewarn "full details /usr/share/doc/${PF}/wu_licen.htm"
+}
diff --git a/app-crypt/bcwipe/bcwipe-1.6_p1.ebuild b/app-crypt/bcwipe/bcwipe-1.6_p1.ebuild
new file mode 100644
index 000000000000..161a7357fb10
--- /dev/null
+++ b/app-crypt/bcwipe/bcwipe-1.6_p1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/bcwipe-1.6_p1.ebuild,v 1.1 2006/04/23 06:05:15 dragonheart Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="BCWipe secure file removal utility"
+HOMEPAGE="http://www.jetico.com/"
+SRC_URI="http://www.jetico.com/linux/BCWipe-${PV/_p/-}.tar.gz
+ http://www.jetico.com/linux/BCWipe.doc.tgz"
+
+LICENSE="bestcrypt"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="virtual/libc"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ emake CC=$(tc-getCC) DEFS="${CFLAGS}"|| die "Make failed"
+}
+
+src_test() {
+ echo "abc123" >> testfile
+ ./bcwipe -f testfile || die "bcwipe test failed"
+ [ -f testfile ] && die "test file still exists. bcwipe should of deleted it"
+}
+
+
+src_install() {
+ dobin bcwipe
+ doman bcwipe.1
+ cd ../bcwipe-help
+ dodir /usr/share/doc/${PF}
+ cp -r * ${D}/usr/share/doc/${PF}
+}
+
+pkg_postinst() {
+ ewarn "The BestCrypt drivers are not free - Please purchace a license from "
+ ewarn "http://www.jetico.com/"
+ ewarn "full details /usr/share/doc/${PF}/wu_licen.htm"
+}
diff --git a/app-crypt/bcwipe/files/digest-bcwipe-1.5_p3 b/app-crypt/bcwipe/files/digest-bcwipe-1.5_p3
index 0b6854923ea2..029258952a61 100644
--- a/app-crypt/bcwipe/files/digest-bcwipe-1.5_p3
+++ b/app-crypt/bcwipe/files/digest-bcwipe-1.5_p3
@@ -1,2 +1,6 @@
MD5 1b99a6d12c2b3259fdbd527f484f03c3 BCWipe-1.5-3.tar.gz 21093
+RMD160 d65a7601e6744356b207c590648d3e3cca43eca3 BCWipe-1.5-3.tar.gz 21093
+SHA256 3f6055dfe05955d1d8735be08bd891e974cfd87cb0a0dfebb4dc58566e4201d5 BCWipe-1.5-3.tar.gz 21093
MD5 f095c187949d08a3cc3b245862df9acd BCWipe.doc.tgz 21218
+RMD160 a38bb741c3aae7d849cc8035010644720434ac2b BCWipe.doc.tgz 21218
+SHA256 afa50bf8653bb6bee108f0ae8b3dc35d289dde3d5c513b7e9ae7fe373635df4f BCWipe.doc.tgz 21218
diff --git a/app-crypt/bcwipe/files/digest-bcwipe-1.6_p1 b/app-crypt/bcwipe/files/digest-bcwipe-1.6_p1
new file mode 100644
index 000000000000..c6ea01bb0b8c
--- /dev/null
+++ b/app-crypt/bcwipe/files/digest-bcwipe-1.6_p1
@@ -0,0 +1,6 @@
+MD5 3ee1f865acda62a2721c595e8905d8bb BCWipe-1.6-1.tar.gz 21674
+RMD160 e7105a44dfa3803bf78a902f9f0c114f47252f2b BCWipe-1.6-1.tar.gz 21674
+SHA256 7135e79a2394f03bfa0b17c11db02f1bb479a2a85e2aad5c95ba00318cc68500 BCWipe-1.6-1.tar.gz 21674
+MD5 f095c187949d08a3cc3b245862df9acd BCWipe.doc.tgz 21218
+RMD160 a38bb741c3aae7d849cc8035010644720434ac2b BCWipe.doc.tgz 21218
+SHA256 afa50bf8653bb6bee108f0ae8b3dc35d289dde3d5c513b7e9ae7fe373635df4f BCWipe.doc.tgz 21218