summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/sandbox/ChangeLog7
-rw-r--r--sys-apps/sandbox/Manifest4
-rw-r--r--sys-apps/sandbox/files/digest-sandbox-1.2.21
-rw-r--r--sys-apps/sandbox/sandbox-1.2.2.ebuild92
4 files changed, 102 insertions, 2 deletions
diff --git a/sys-apps/sandbox/ChangeLog b/sys-apps/sandbox/ChangeLog
index 559bc207e874..4f30488da196 100644
--- a/sys-apps/sandbox/ChangeLog
+++ b/sys-apps/sandbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sandbox
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.6 2005/04/24 18:22:00 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.7 2005/04/28 16:34:28 azarah Exp $
+
+*sandbox-1.2.2 (28 Apr 2005)
+
+ 28 Apr 2005; Martin Schlemmer <azarah@gentoo.org> +sandbox-1.2.2.ebuild:
+ Bug fixes for bug #90592.
*sandbox-1.2.1-r3 (24 Apr 2005)
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
index 9c968f972030..0dd81c28e6a2 100644
--- a/sys-apps/sandbox/Manifest
+++ b/sys-apps/sandbox/Manifest
@@ -1,12 +1,14 @@
MD5 034ac0d90bcd60acce9919a9f5dfe311 ChangeLog 939
MD5 968e2965b0b6f620634dae6d28d8b4c4 metadata.xml 455
-MD5 47438c0ad7e347064cdaf223d6a5f042 sandbox-1.2.1.ebuild 1747
MD5 fa4e917c828593f1c202fe11f019e2d3 sandbox-1.2.ebuild 1711
+MD5 47438c0ad7e347064cdaf223d6a5f042 sandbox-1.2.1.ebuild 1747
MD5 23e070ffbbc6123cc5082bab1b9de240 sandbox-1.2.1-r1.ebuild 2131
MD5 ff83893e146a467c718131e5f68ff52e sandbox-1.2.1-r2.ebuild 2110
MD5 6fcdfc54e50834549f956f92430059ff sandbox-1.2.1-r3.ebuild 2299
+MD5 e6511bfd21296afdd745e18fa58dfe6d sandbox-1.2.2.ebuild 2238
MD5 06ad9881ad2610487c66565ee5b39389 files/digest-sandbox-1.2 64
MD5 9b60e9e6d1e45533a0e719fdf023ec07 files/digest-sandbox-1.2.1 66
MD5 9b60e9e6d1e45533a0e719fdf023ec07 files/digest-sandbox-1.2.1-r1 66
MD5 9b60e9e6d1e45533a0e719fdf023ec07 files/digest-sandbox-1.2.1-r2 66
MD5 9b60e9e6d1e45533a0e719fdf023ec07 files/digest-sandbox-1.2.1-r3 66
+MD5 fb651b249c3214a6d0fa321e1d419e07 files/digest-sandbox-1.2.2 66
diff --git a/sys-apps/sandbox/files/digest-sandbox-1.2.2 b/sys-apps/sandbox/files/digest-sandbox-1.2.2
new file mode 100644
index 000000000000..f2f2cf3fea44
--- /dev/null
+++ b/sys-apps/sandbox/files/digest-sandbox-1.2.2
@@ -0,0 +1 @@
+MD5 f45d35a3a57f5864dad57e685ae062e7 sandbox-1.2.2.tar.bz2 222520
diff --git a/sys-apps/sandbox/sandbox-1.2.2.ebuild b/sys-apps/sandbox/sandbox-1.2.2.ebuild
new file mode 100644
index 000000000000..95effde059d2
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-1.2.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.2.ebuild,v 1.1 2005/04/28 16:34:28 azarah Exp $
+
+inherit eutils flag-o-matic eutils toolchain-funcs multilib
+#
+# don't monkey with this ebuild unless contacting portage devs.
+# period.
+#
+
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~azarah/sandbox/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+RESTRICT="multilib-pkg-force"
+
+#KEYWORDS=" alpha amd64 arm hppa ia64 mips ppc ppc-macos ppc64 s390 sh sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DEPEND="virtual/libc"
+
+check_multilib() {
+ has_m32
+ if [ "$?" == 0 ]; then
+ einfo "Found valid multilib environment."
+ einfo "Building with multilib support."
+ export MULTILIB="1"
+ else
+ ewarn "No valid multilib environment found!"
+ ewarn "Building without multilib support. If"
+ ewarn "you want to have multilib support,"
+ ewarn "emerge gcc with \"multilib\" in your"
+ ewarn "useflags."
+ fi
+}
+
+src_unpack() {
+ if has_multilib_profile; then
+ for TA in $(get_install_abis); do
+ unpack ${A} || die "unpack failed"
+ cd ${S}
+ epunt_cxx
+ cd ${WORKDIR}
+ mv ${S} ${S%/}-${TA} || die "failed mving \$S to $TA"
+ done
+ else
+ unpack ${A} || die "unpack failed"
+ cd ${S}
+ epunt_cxx
+ fi
+}
+
+src_compile() {
+ filter-lfs-flags #90228
+ if has_multilib_profile; then
+ OABI="${ABI}"
+ export CFLAGS="${CFLAGS} -DSB_HAVE_64BIT_ARCH"
+ for ABI in $(get_install_abis); do
+ export ABI
+ cd ${S}-${ABI}
+ econf --libdir="/usr/$(get_libdir)" || die "econf failed for $ABI"
+ emake || die "emake failed for $ABI"
+ done
+ ABI="${OABI}"
+ else
+ if useq amd64; then
+ check_multilib
+ export HAVE_64BIT_ARCH="${MULTILIB}"
+ fi
+ cd ${S}
+ econf || die "econf failed"
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ if has_multilib_profile; then
+ OABI="${ABI}"
+ for ABI in $(get_install_abis); do
+ export ABI
+ cd ${S}-${ABI}
+ make DESTDIR="${D}" install || die "make install failed for $ABI"
+ done
+ ABI="${OABI}"
+ else
+ cd ${S}
+ einstall || die "einstalled failed"
+ fi
+}