summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/cel/ChangeLog12
-rw-r--r--dev-libs/cel/Manifest4
-rw-r--r--dev-libs/cel/cel-20030413-r1.ebuild51
-rw-r--r--dev-libs/cel/files/digest-cel-20030413-r11
4 files changed, 63 insertions, 5 deletions
diff --git a/dev-libs/cel/ChangeLog b/dev-libs/cel/ChangeLog
index d7c1cb7501e9..603f83912ab3 100644
--- a/dev-libs/cel/ChangeLog
+++ b/dev-libs/cel/ChangeLog
@@ -1,12 +1,18 @@
# ChangeLog for dev-libs/cel
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cel/ChangeLog,v 1.4 2003/06/10 20:48:27 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cel/ChangeLog,v 1.5 2003/07/02 23:19:29 blauwers Exp $
- 10 Jun 2003; <msterret@gentoo.org> cel-20030413.ebuild:
- DEPEND on sed >= 4
+*cel-20030413-r1 (02 Jul 2003)
+
+ 02 Jul 2003; <blauwers@gentoo.org> cel-20030413-r1.ebuild, Changelog :
+ Added a new revision of the cel ebuild to fix numerous problems, the
+ includes will now install in the proper place, sed 4 no longer required,
+ environment var CEL added, and several ebuild tooling errors corrected.
*cel-20030413 (13 Apr 2003)
+ 10 Jun 2003; <msterret@gentoo.org> cel-20030413.ebuild:
+ DEPEND on sed >= 4
13 Apr 2003; Philip Walls <malverian@gentoo.org> cel-20030413.ebuild :
Cel snapshot that works with Planeshift
19 May 2003; Thomas Raschbacher <lordvan@gentoo.org> cel-20030413.ebuild:
diff --git a/dev-libs/cel/Manifest b/dev-libs/cel/Manifest
index a37bf3d62e78..2875f3ae8c10 100644
--- a/dev-libs/cel/Manifest
+++ b/dev-libs/cel/Manifest
@@ -1,5 +1,5 @@
-MD5 daba72cabb14f61eb2c9cdd8c3668006 ChangeLog 696
+MD5 e47c76555f03b342ebc6f122183eb0ad ChangeLog 1021
MD5 8f00227bc5bfbfbf419bad1b8b74862a cel-20030413.ebuild 977
-MD5 5b576f80018ccea816d45add68e886ff cel-20030413-r1.ebuild 1030
+MD5 a6e1302e6ab00befb61c33e2249750ea cel-20030413-r1.ebuild 1112
MD5 17683292d3b178749a2b7d93eb6218cb files/digest-cel-20030413 64
MD5 17683292d3b178749a2b7d93eb6218cb files/digest-cel-20030413-r1 64
diff --git a/dev-libs/cel/cel-20030413-r1.ebuild b/dev-libs/cel/cel-20030413-r1.ebuild
new file mode 100644
index 000000000000..14b82a840301
--- /dev/null
+++ b/dev-libs/cel/cel-20030413-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cel/cel-20030413-r1.ebuild,v 1.1 2003/07/02 23:19:29 blauwers Exp $
+
+inherit games
+
+HOMEPAGE="http://cel.sourceforge.net/"
+SRC_URI="mirror://gentoo/distfiles/${P}.tar.gz"
+DESCRIPTION="A game entity layer based on Crystal Space"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="dev-libs/crystalspace
+ dev-util/jam
+ !dev-libs/cel-cvs"
+
+S=${WORKDIR}/${PN}
+
+CEL_PREFIX=${GAMES_PREFIX_OPT}/crystal
+
+src_compile() {
+ ./autogen.sh || die
+ PATH="${CEL_PREFIX}/bin:${PATH}" ./configure --prefix=${CEL_PREFIX} || die
+ jam || die
+
+ # Put the correct path there
+ mv cel.cex cel.cex.DIST
+ sed -e "s:/usr/local/cel:${CEL_PREFIX}:g" cel.cex.DIST > cel.cex
+ # Make an environment config file
+ echo "CEL=${CEL_PREFIX}" > 99cel-env
+}
+
+src_install() {
+ into ${CEL_PREFIX}
+ dolib.so *.so
+
+ dobin cel.cex
+ dobin celtst
+
+ for inc in bl pf pl; do
+ insinto ${CEL_PREFIX}/include/${inc}
+ doins include/${inc}/*
+ done
+
+ insinto /etc/env.d
+ doins 99cel-env
+
+ prepgamesdirs
+}
diff --git a/dev-libs/cel/files/digest-cel-20030413-r1 b/dev-libs/cel/files/digest-cel-20030413-r1
new file mode 100644
index 000000000000..4aaec9630308
--- /dev/null
+++ b/dev-libs/cel/files/digest-cel-20030413-r1
@@ -0,0 +1 @@
+MD5 1ae2fe6e7d51e9ff0e287167265854f3 cel-20030413.tar.gz 207382