summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/jflex/ChangeLog8
-rw-r--r--dev-java/jflex/jflex-1.4.3-r1.ebuild72
-rw-r--r--dev-java/jflex/jflex-1.4.3.ebuild8
3 files changed, 83 insertions, 5 deletions
diff --git a/dev-java/jflex/ChangeLog b/dev-java/jflex/ChangeLog
index e8e583b31cab..613942dfe42e 100644
--- a/dev-java/jflex/ChangeLog
+++ b/dev-java/jflex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/jflex
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jflex/ChangeLog,v 1.19 2015/02/22 18:55:39 monsieurp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jflex/ChangeLog,v 1.20 2015/02/23 10:37:47 monsieurp Exp $
+
+*jflex-1.4.3-r1 (23 Feb 2015)
+
+ 23 Feb 2015; Patrice Clement <monsieurp@gentoo.org> +jflex-1.4.3-r1.ebuild,
+ jflex-1.4.3.ebuild:
+ Revert previous change (EAPI + SLOT) and revbump the package instead.
22 Feb 2015; Patrice Clement <monsieurp@gentoo.org> jflex-1.4.3.ebuild,
jflex-1.5.0.ebuild, jflex-1.5.1.ebuild, jflex-1.6.0.ebuild:
diff --git a/dev-java/jflex/jflex-1.4.3-r1.ebuild b/dev-java/jflex/jflex-1.4.3-r1.ebuild
new file mode 100644
index 000000000000..3534ee01cedf
--- /dev/null
+++ b/dev-java/jflex/jflex-1.4.3-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jflex/jflex-1.4.3-r1.ebuild,v 1.1 2015/02/23 10:37:47 monsieurp Exp $
+
+# Currently, this package uses an included JFlex.jar file to bootstrap.
+# Upstream was contacted and this bootstrap is really needed. The only way to avoid it would be to use a supplied pre-compiled .scanner file.
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="JFlex is a lexical analyzer generator for Java"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.jflex.de/"
+LICENSE="GPL-2"
+SLOT="1.4"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+RDEPEND=">=virtual/jre-1.4
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+ >=dev-java/ant-core-1.7.0
+ >=dev-java/javacup-0.11a_beta20060608:0"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/junit:0
+ >=dev-java/javacup-0.11a_beta20060608:0"
+
+IUSE="doc source vim-syntax"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ cd "${S}/src"
+
+ mkdir "${S}/tools"
+ cp "${S}/lib/JFlex.jar" "${S}/tools/JFlex.jar"
+ rm -rf java_cup "${S}/lib/JFlex.jar"
+
+ java-ant_rewrite-classpath
+}
+
+src_compile() {
+ ANT_TASKS="javacup"
+ jflex_cp="$(java-pkg_getjars --build-only junit):$(java-pkg_getjars ant-core,javacup)"
+ cd "${S}/src"
+ eant realclean
+ eant -Dgentoo.classpath="${jflex_cp}" jar
+
+ rm "${S}/tools/JFlex.jar"
+ cp "${S}/lib/JFlex.jar" "${S}/tools/"
+ rm "${S}/lib/JFlex.jar"
+
+ eant realclean
+ einfo "Recompiling using the newly generated JFlex library"
+ eant -Dgentoo.classpath="${jflex_cp}" jar
+}
+
+src_install() {
+ java-pkg_dojar lib/JFlex.jar
+ java-pkg_dolauncher "${PF}" --main JFlex.Main
+ java-pkg_register-ant-task
+
+ dodoc doc/manual.pdf doc/manual.ps.gz src/changelog
+ dohtml -r doc/*
+
+ use source && java-pkg_dosrc src/JFlex
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins "${S}/lib/jflex.vim"
+ fi
+}
diff --git a/dev-java/jflex/jflex-1.4.3.ebuild b/dev-java/jflex/jflex-1.4.3.ebuild
index 70c82a7def87..7bc475504a38 100644
--- a/dev-java/jflex/jflex-1.4.3.ebuild
+++ b/dev-java/jflex/jflex-1.4.3.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jflex/jflex-1.4.3.ebuild,v 1.9 2015/02/22 18:55:39 monsieurp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jflex/jflex-1.4.3.ebuild,v 1.10 2015/02/23 10:37:47 monsieurp Exp $
# Currently, this package uses an included JFlex.jar file to bootstrap.
# Upstream was contacted and this bootstrap is really needed. The only way to avoid it would be to use a supplied pre-compiled .scanner file.
-EAPI="5"
+EAPI="3"
JAVA_PKG_IUSE="source"
@@ -15,7 +15,7 @@ DESCRIPTION="JFlex is a lexical analyzer generator for Java"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.jflex.de/"
LICENSE="GPL-2"
-SLOT="1.4"
+SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86 ~amd64-fbsd ~ppc-macos ~x64-macos ~x86-macos"
RDEPEND=">=virtual/jre-1.4
vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
@@ -57,7 +57,7 @@ src_compile() {
src_install() {
java-pkg_dojar lib/JFlex.jar
- java-pkg_dolauncher "${PN}-${SLOT}" --main JFlex.Main
+ java-pkg_dolauncher "${P}" --main JFlex.Main
java-pkg_register-ant-task
dodoc doc/manual.pdf doc/manual.ps.gz src/changelog