summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/system-config-printer-common/ChangeLog11
-rw-r--r--app-admin/system-config-printer-common/system-config-printer-common-1.3.3.ebuild93
-rw-r--r--app-admin/system-config-printer-common/system-config-printer-common-1.3.7.ebuild6
3 files changed, 12 insertions, 98 deletions
diff --git a/app-admin/system-config-printer-common/ChangeLog b/app-admin/system-config-printer-common/ChangeLog
index f809d3319f18..8252bce4e583 100644
--- a/app-admin/system-config-printer-common/ChangeLog
+++ b/app-admin/system-config-printer-common/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/system-config-printer-common
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-printer-common/ChangeLog,v 1.55 2011/12/29 17:12:18 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-printer-common/ChangeLog,v 1.56 2012/01/11 18:57:07 pacho Exp $
+
+ 11 Jan 2012; Pacho Ramos <pacho@gentoo.org>
+ -system-config-printer-common-1.3.3.ebuild,
+ system-config-printer-common-1.3.7.ebuild:
+ We need newer udev for udev_enumerate_add_match_tag usage, DEPENDing on 164-r2
+ as it's the older version I have tested it works (bug #398499 by Peter
+ Gantner). Remove old.
29 Dec 2011; Pacho Ramos <pacho@gentoo.org>
system-config-printer-common-1.3.7.ebuild:
diff --git a/app-admin/system-config-printer-common/system-config-printer-common-1.3.3.ebuild b/app-admin/system-config-printer-common/system-config-printer-common-1.3.3.ebuild
deleted file mode 100644
index 1dee718185fa..000000000000
--- a/app-admin/system-config-printer-common/system-config-printer-common-1.3.3.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-printer-common/system-config-printer-common-1.3.3.ebuild,v 1.11 2011/10/23 21:37:20 tetromino Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="2"
-WANT_AUTOMAKE="1.11"
-inherit python autotools
-
-MY_P="${PN%-common}-${PV}"
-
-DESCRIPTION="Common modules of Red Hat's printer administration tool"
-HOMEPAGE="http://cyberelk.net/tim/software/system-config-printer/"
-SRC_URI="http://cyberelk.net/tim/data/system-config-printer/1.3/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 arm ~hppa ia64 ppc ppc64 ~sh sparc x86"
-SLOT="0"
-IUSE="doc policykit"
-
-# Needs cups running, bug 284005
-RESTRICT="test"
-
-# system-config-printer split since 1.1.3
-COMMON_DEPEND="
- dev-libs/glib:2
- dev-libs/libxml2[python]
- dev-python/dbus-python
- >=dev-python/pycups-1.9.53
- >=dev-python/pygobject-2.21.5:2
- >=net-print/cups-1.4.6[dbus]
- sys-fs/udev
- virtual/libusb:0
-"
-DEPEND="${COMMON_DEPEND}
- dev-util/intltool
- dev-util/pkgconfig
- doc? ( dev-python/epydoc )
-"
-RDEPEND="${COMMON_DEPEND}
- !app-admin/system-config-printer:0
- !<app-admin/system-config-printer-gnome-${PV}
- policykit? ( sys-auth/polkit )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- python_set_active_version 2
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-1.3.3-split.patch"
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-nls \
- --with-udev-rules
-}
-
-src_compile() {
- emake || die "emake failed"
- if use doc; then
- emake html || die "emake html failed"
- fi
-}
-
-src_install() {
- dodoc AUTHORS ChangeLog README || die "dodoc failed"
-
- if use doc; then
- dohtml -r html/ || die "installing html docs failed"
- fi
-
- emake DESTDIR="${ED}" install \
- udevrulesdir=/lib/udev/rules.d \
- udevhelperdir=/lib/udev \
- || die "emake install failed"
-
- python_convert_shebangs -q -r $(python_get_version) "${ED}"
-}
-
-pkg_postinst() {
- python_mod_optimize cupshelpers
-}
-
-pkg_postrm() {
- python_mod_cleanup cupshelpers /usr/share/system-config-printer
-}
diff --git a/app-admin/system-config-printer-common/system-config-printer-common-1.3.7.ebuild b/app-admin/system-config-printer-common/system-config-printer-common-1.3.7.ebuild
index 4c9fe4539e26..5252b894ce4f 100644
--- a/app-admin/system-config-printer-common/system-config-printer-common-1.3.7.ebuild
+++ b/app-admin/system-config-printer-common/system-config-printer-common-1.3.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-printer-common/system-config-printer-common-1.3.7.ebuild,v 1.4 2011/12/29 17:12:18 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-printer-common/system-config-printer-common-1.3.7.ebuild,v 1.5 2012/01/11 18:57:07 pacho Exp $
EAPI="3"
@@ -30,7 +30,7 @@ COMMON_DEPEND="
>=dev-python/pycups-1.9.53
>=dev-python/pygobject-2.21.5:2
>=net-print/cups-1.4.6[dbus]
- sys-fs/udev
+ >=sys-fs/udev-164-r2
virtual/libusb:0
"
DEPEND="${COMMON_DEPEND}