summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/Net-RawIP/ChangeLog5
-rw-r--r--dev-perl/Net-RawIP/Manifest3
-rw-r--r--dev-perl/Net-RawIP/Net-RawIP-0.09d.ebuild26
3 files changed, 33 insertions, 1 deletions
diff --git a/dev-perl/Net-RawIP/ChangeLog b/dev-perl/Net-RawIP/ChangeLog
index 0b101bb169a3..0d8768475759 100644
--- a/dev-perl/Net-RawIP/ChangeLog
+++ b/dev-perl/Net-RawIP/ChangeLog
@@ -1,8 +1,11 @@
# ChangeLog for dev-perl/Net-RawIP
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-RawIP/ChangeLog,v 1.2 2003/02/12 06:22:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-RawIP/ChangeLog,v 1.3 2003/05/08 16:53:46 rac Exp $
*Net-RawIP-0.09d (30 Jan 2003)
+ 08 May 2003; <rac@gentoo.org> Net-RawIP-0.09d.ebuild:
+ Add header to ebuild, address bug 16388
+
30 Jan 2003; Jared Hudson <jhhudso@gentoo.org> : Initial import. Credit goes
to Andrea Barisani <lcars@infis.univ.trieste.it>.
diff --git a/dev-perl/Net-RawIP/Manifest b/dev-perl/Net-RawIP/Manifest
new file mode 100644
index 000000000000..2bf47e4671f9
--- /dev/null
+++ b/dev-perl/Net-RawIP/Manifest
@@ -0,0 +1,3 @@
+MD5 64e068559512df6522f9cf5e549f8e25 Net-RawIP-0.09d.ebuild 1490
+MD5 3a20d3f03157592a67dfd74741b46d7e ChangeLog 477
+MD5 e04c3fa53d9d22a11b1deb98b8fca6f1 files/digest-Net-RawIP-0.09d 66
diff --git a/dev-perl/Net-RawIP/Net-RawIP-0.09d.ebuild b/dev-perl/Net-RawIP/Net-RawIP-0.09d.ebuild
index 67cb836911ee..aabe0a8016e9 100644
--- a/dev-perl/Net-RawIP/Net-RawIP-0.09d.ebuild
+++ b/dev-perl/Net-RawIP/Net-RawIP-0.09d.ebuild
@@ -1,3 +1,7 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-RawIP/Net-RawIP-0.09d.ebuild,v 1.3 2003/05/08 16:53:46 rac Exp $
+
inherit perl-module
S=${WORKDIR}/${P}
@@ -10,3 +14,25 @@ DEPEND="net-libs/libpcap"
SLOT="0"
LICENSE="Artistic"
KEYWORDS="~x86"
+
+src_unpack() {
+ unpack ${A}
+
+ # This patch makes sure CFLAGS are applied properly instead of
+ # being runon additions to the previously defined symbol.
+ # Attempts to address the problem in bug 16388 without completely
+ # losing CFLAGS. The patch submitted to that bug chose to remove
+ # the $ENV{'CFLAGS'}. With the current state of MakeMaker, this
+ # would be a perfectly acceptable choice, because the approach
+ # taken here ends up with two sets of CFLAGS in the compile line.
+ # However, I believe that it may be more prudent in the long run
+ # to try to accommodate what I think the original intention of the
+ # Makefile was. Perhaps on some system with some (maybe future)
+ # version of MakeMaker, this would be the only way to convey
+ # CFLAGS. Since duplication of CFLAGS is harmless, I'm going to
+ # go with adding the space instead of taking out the $ENV{CFLAGS}.
+
+ # Robert Coie <rac@gentoo.org> 2003.05.08
+
+ sed -i -e "s/D_IFLIST_'\./D_IFLIST_ '\./" ${S}/Makefile.PL
+} \ No newline at end of file