summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-firmware/sgabios/ChangeLog9
-rw-r--r--sys-firmware/sgabios/sgabios-0.1_pre8.ebuild16
2 files changed, 19 insertions, 6 deletions
diff --git a/sys-firmware/sgabios/ChangeLog b/sys-firmware/sgabios/ChangeLog
index 6179676e516f..61f206e87fd6 100644
--- a/sys-firmware/sgabios/ChangeLog
+++ b/sys-firmware/sgabios/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-firmware/sgabios
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/sgabios/ChangeLog,v 1.3 2012/11/21 21:02:28 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/sgabios/ChangeLog,v 1.4 2013/06/30 02:36:19 cardoe Exp $
+
+ 30 Jun 2013; Doug Goldstein <cardoe@gentoo.org> sgabios-0.1_pre8.ebuild:
+ For users using the gold linker, make the build process a little more friendly
+ by automatically selecting the bfd linker and pointing them to the bug
+ explaining why gold won't work. bug #438056
21 Nov 2012; Agostino Sarubbo <ago@gentoo.org> sgabios-0.1_pre8.ebuild:
Stable for x86, wrt to bug #440092
diff --git a/sys-firmware/sgabios/sgabios-0.1_pre8.ebuild b/sys-firmware/sgabios/sgabios-0.1_pre8.ebuild
index b6462e6be3a9..9a3a8d5e7b39 100644
--- a/sys-firmware/sgabios/sgabios-0.1_pre8.ebuild
+++ b/sys-firmware/sgabios/sgabios-0.1_pre8.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/sgabios/sgabios-0.1_pre8.ebuild,v 1.3 2012/11/21 21:02:28 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/sgabios/sgabios-0.1_pre8.ebuild,v 1.4 2013/06/30 02:36:19 cardoe Exp $
EAPI=4
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="serial graphics adapter bios option rom for x86"
HOMEPAGE="http://code.google.com/p/sgabios/"
@@ -20,13 +20,21 @@ IUSE=""
DEPEND=""
RDEPEND="${DEPEND}"
+pkg_setup() {
+ local myld=$(tc-getLD)
+
+ ${myld} -v | grep -q "GNU gold" && \
+ ewarn "gold linker unable to handle 16-bit code using ld.bfd. bug #438058"
+}
+
src_prepare() {
epatch "${FILESDIR}"/${P}-makefile.patch
}
src_compile() {
if use amd64 || use x86 ; then
- emake
+ emake CC=$(tc-getCC) LD="$(tc-getLD).bfd" AR=$(tc-getAR) \
+ OBJCOPY=$(tc-getOBJCOPY)
fi
}