summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/libpq/ChangeLog8
-rw-r--r--dev-db/libpq/files/digest-libpq-8.0.153
-rw-r--r--dev-db/libpq/files/libpq-8.0.15-gentoo.patch47
-rw-r--r--dev-db/libpq/libpq-8.0.15.ebuild115
4 files changed, 172 insertions, 1 deletions
diff --git a/dev-db/libpq/ChangeLog b/dev-db/libpq/ChangeLog
index bfbabf0d7ac6..87d0bb757096 100644
--- a/dev-db/libpq/ChangeLog
+++ b/dev-db/libpq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/libpq
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/ChangeLog,v 1.124 2008/01/13 01:38:02 mjolnir Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/ChangeLog,v 1.125 2008/01/13 19:30:03 mjolnir Exp $
+
+*libpq-8.0.15 (13 Jan 2008)
+
+ 13 Jan 2008; Martin Jackson <mjolnir@gentoo.org>
+ +files/libpq-8.0.15-gentoo.patch, +libpq-8.0.15.ebuild:
+ Bump to 8.0.15 for #204760
*libpq-8.2.6 (13 Jan 2008)
diff --git a/dev-db/libpq/files/digest-libpq-8.0.15 b/dev-db/libpq/files/digest-libpq-8.0.15
new file mode 100644
index 000000000000..e7881b8bd13e
--- /dev/null
+++ b/dev-db/libpq/files/digest-libpq-8.0.15
@@ -0,0 +1,3 @@
+MD5 3ee548b3643e0a0a4b76493e81b336f3 postgresql-8.0.15.tar.bz2 11253897
+RMD160 6aff5c63dce73eea609f0b6e013cd043ae8b7a37 postgresql-8.0.15.tar.bz2 11253897
+SHA256 59408a00db1c73e638a11af10438a827507b7a72b53916d58f2d44c477718714 postgresql-8.0.15.tar.bz2 11253897
diff --git a/dev-db/libpq/files/libpq-8.0.15-gentoo.patch b/dev-db/libpq/files/libpq-8.0.15-gentoo.patch
new file mode 100644
index 000000000000..e6a37001ef99
--- /dev/null
+++ b/dev-db/libpq/files/libpq-8.0.15-gentoo.patch
@@ -0,0 +1,47 @@
+diff -Nru postgresql-8.0.9.orig/src/interfaces/libpq/Makefile postgresql-8.0.9/src/interfaces/libpq/Makefile
+--- postgresql-8.0.9.orig/src/interfaces/libpq/Makefile 2006-11-05 13:20:26.000000000 +0100
++++ postgresql-8.0.9/src/interfaces/libpq/Makefile 2006-11-05 13:24:34.000000000 +0100
+@@ -20,6 +20,8 @@
+ SO_MINOR_VERSION= 0
+ DLTYPE= library
+
++NAME_STATIC_LIB= $(NAME)-$(SO_MAJOR_VERSION)
++
+ override CPPFLAGS := -DFRONTEND -I$(srcdir) $(CPPFLAGS) -I$(top_builddir)/src/port
+ override CFLAGS += $(PTHREAD_CFLAGS)
+
+@@ -136,7 +138,7 @@
+ $(INSTALL_DATA) $(srcdir)/libpq-fe.h $(DESTDIR)$(includedir)
+ $(INSTALL_DATA) $(srcdir)/libpq-int.h $(DESTDIR)$(includedir_internal)
+ $(INSTALL_DATA) $(srcdir)/pqexpbuffer.h $(DESTDIR)$(includedir_internal)
+- $(INSTALL_DATA) $(srcdir)/pg_service.conf.sample $(DESTDIR)$(datadir)/pg_service.conf.sample
++ $(INSTALL_DATA) $(srcdir)/pg_service.conf.sample $(DESTDIR)$(datadir)/pg_service-$(SO_MAJOR_VERSION).conf.sample
+
+ installdirs:
+ $(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir) $(DESTDIR)$(includedir_internal)
+diff -Nru postgresql-8.0.9.orig/src/interfaces/libpq/nls.mk postgresql-8.0.9/src/interfaces/libpq/nls.mk
+--- postgresql-8.0.9.orig/src/interfaces/libpq/nls.mk 2006-11-05 13:20:26.000000000 +0100
++++ postgresql-8.0.9/src/interfaces/libpq/nls.mk 2006-11-05 13:24:34.000000000 +0100
+@@ -1,5 +1,5 @@
+ # $PostgreSQL: pgsql/src/interfaces/libpq/nls.mk,v 1.20 2005/01/14 08:57:06 petere Exp $
+-CATALOG_NAME := libpq
++CATALOG_NAME := libpq-4
+ AVAIL_LANGUAGES := af cs de es fr hr it ko nb pl pt_BR ru sk sl sv tr zh_CN zh_TW
+ GETTEXT_FILES := fe-auth.c fe-connect.c fe-exec.c fe-lobj.c fe-misc.c fe-protocol2.c fe-protocol3.c fe-secure.c
+ GETTEXT_TRIGGERS:= libpq_gettext pqInternalNotice:2
+diff -Nru postgresql-8.0.9.orig/src/Makefile.shlib postgresql-8.0.9/src/Makefile.shlib
+--- postgresql-8.0.9.orig/src/Makefile.shlib 2006-11-05 13:20:26.000000000 +0100
++++ postgresql-8.0.9/src/Makefile.shlib 2006-11-05 13:24:34.000000000 +0100
+@@ -360,10 +360,10 @@
+ install-lib: install-lib-static install-lib-shared
+
+ install-lib-static: lib$(NAME).a
+- $(INSTALL_STLIB) $< $(DESTDIR)$(libdir)/lib$(NAME).a
++ $(INSTALL_STLIB) $< $(DESTDIR)$(libdir)/lib$(NAME_STATIC_LIB).a
+ ifeq ($(PORTNAME), darwin)
+ cd $(DESTDIR)$(libdir) && \
+- ranlib lib$(NAME).a
++ ranlib lib$(NAME_STATIC_LIB).a
+ endif
+
+ ifeq ($(enable_shared), yes)
diff --git a/dev-db/libpq/libpq-8.0.15.ebuild b/dev-db/libpq/libpq-8.0.15.ebuild
new file mode 100644
index 000000000000..2a854be2ba27
--- /dev/null
+++ b/dev-db/libpq/libpq-8.0.15.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/libpq-8.0.15.ebuild,v 1.1 2008/01/13 19:30:03 mjolnir Exp $
+
+inherit eutils gnuconfig flag-o-matic toolchain-funcs
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="PostgreSQL libraries."
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+SLOT="4"
+IUSE="kerberos nls pam pg-intdatetime readline ssl threads zlib"
+
+RDEPEND="!<=dev-db/postgresql-8.0.8
+ kerberos? ( virtual/krb5 )
+ pam? ( virtual/pam )
+ readline? ( >=sys-libs/readline-4.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+ zlib? ( >=sys-libs/zlib-1.1.3 )"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf
+ >=sys-devel/bison-1.875
+ nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/postgresql-${PV}"
+
+pkg_preinst() {
+ # Removing wrong symlink created by previous ebuild
+ if [[ -L "${ROOT}/usr/include/libpq" ]] ; then
+ rm -f "${ROOT}/usr/include/libpq"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_compile() {
+ filter-flags -ffast-math -feliminate-dwarf2-dups
+
+ # Detect mips systems properly
+ gnuconfig_update
+
+ cd "${S}"
+
+ ./configure --prefix=/usr \
+ --includedir=/usr/include/postgresql/libpq-${SLOT} \
+ --sysconfdir=/etc/postgresql \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --with-docdir=/usr/share/doc/${PF} \
+ --libdir=/usr/$(get_libdir) \
+ --enable-depend \
+ $(use_with kerberos krb5) \
+ $(use_enable nls ) \
+ $(use_with pam) \
+ --without-perl \
+ $(use_enable pg-intdatetime integer-datetimes ) \
+ --without-python \
+ $(use_with readline) \
+ $(use_with ssl openssl) \
+ --without-tcl \
+ $(use_enable threads thread-safety ) \
+ $(use_with zlib) \
+ || die "configure failed"
+
+ cd "${S}/src/interfaces/libpq"
+ emake -j1 LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "emake libpq failed"
+
+ cd "${S}/src/bin/pg_config"
+ emake -j1 LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "emake pg_config failed"
+}
+
+src_install() {
+ cd "${S}/src/interfaces/libpq"
+ emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install || die "emake install libpq failed"
+
+ cd "${S}/src/include"
+ emake DESTDIR="${D}" install || die "emake install headers failed"
+
+ cd "${S}/src/bin/pg_config"
+ emake DESTDIR="${D}" install || die "emake install pg_config failed"
+
+ cd "${S}"
+ dodoc README HISTORY
+
+ dosym libpq-${SLOT}.a /usr/$(get_libdir)/libpq.a
+
+ for f in $(ls -1 "${D}"/usr/include/postgresql/libpq-${SLOT}/*.h) ; do
+ dosym postgresql/libpq-${SLOT}/$(basename ${f}) /usr/include/
+ done
+
+ dodir /usr/include/libpq
+ for f in $(ls -1 "${D}"/usr/include/postgresql/libpq-${SLOT}/libpq/*.h) ; do
+ dosym ../postgresql/libpq-${SLOT}/libpq/$(basename ${f}) /usr/include/libpq/
+ done
+
+ cd "${D}/usr/include/postgresql/libpq-${SLOT}"
+ for f in $(find * -name '*.h' -print) ; do
+ destdir=$(dirname ${f})
+ if [[ ! -d "${D}/usr/include/postgresql/${destdir}" ]] ; then
+ dodir "/usr/include/postgresql/${destdir}"
+ fi
+ dosym /usr/include/postgresql/libpq-${SLOT}/${f} "/usr/include/postgresql/${destdir}/"
+ done
+}
+
+src_test() {
+ einfo "No tests available for libpq."
+}