summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/glibc/glibc-2.2.5-r7.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/sys-libs/glibc/glibc-2.2.5-r7.ebuild b/sys-libs/glibc/glibc-2.2.5-r7.ebuild
index e950a8013e29..02beade2119c 100644
--- a/sys-libs/glibc/glibc-2.2.5-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.2.5-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r7.ebuild,v 1.10 2002/10/12 01:44:41 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r7.ebuild,v 1.11 2002/10/12 06:19:59 seemant Exp $
IUSE="nls pic build"
inherit flag-o-matic
@@ -100,11 +100,6 @@ src_unpack() {
# (Azarah, 14 Jul 2002)
cd ${S}; patch -p1 < ${FILESDIR}/glibc-2.2.5-gcc311.patch || die
- # Avoid "Error: illegal instruction" when compiling on sparc with gcc 3.1.1
- if [ "${ARCH}" = "sparc" -o "${ARCH}" = "sparc64" ]; then
- cd ${S}; patch -p1 < ${FILESDIR}/glibc-2.2.5-gcc311-sparc.patch || die
- fi
-
# Some patches to fixup build on alpha
if [ "${ARCH}" = "alpha" ]; then
cd ${S}
@@ -114,12 +109,14 @@ src_unpack() {
# A patch for miscellaenous sparc fixes
if [ "${ARCH}" = "sparc" -o "${ARCH} = "sparc64" ] ; then
+ einfo "applying sparc miscellaneous fixes patch"
cd ${S}
patch -p1 < ${FILESDIR}/${P}-sparc-misc.diff || die
fi
# A patch for the notorious sparc64 issues
if [ "${ARCH} = "sparc64" ] ; then
+ einfo "applying sparc64 fixups patch"
cd ${S}
patch -p1 < ${FILESDIR}/${P}-sparc64-fixups.diff || die
fi