summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/llvm/ChangeLog5
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild29
2 files changed, 19 insertions, 15 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index e1e3906a7990..d8a43e23608f 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.249 2015/06/13 12:10:52 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.250 2015/06/13 20:51:45 mgorny Exp $
+
+ 13 Jun 2015; Michał Górny <mgorny@gentoo.org> llvm-9999.ebuild:
+ Clean multilib_src_install_all() up.
13 Jun 2015; Michał Górny <mgorny@gentoo.org> llvm-9999.ebuild:
Simplify doc CMake code
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index ef7446674c2b..b98537eda435 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.115 2015/06/13 12:10:52 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.116 2015/06/13 20:51:45 mgorny Exp $
EAPI=5
@@ -397,24 +397,25 @@ multilib_src_install() {
}
multilib_src_install_all() {
- pushd utils/vim >/dev/null || die
- for dir in */; do
- insinto /usr/share/vim/vimfiles/${dir}
- doins ${dir}/*.vim
- done
- popd >/dev/null || die
+ insinto /usr/share/vim/vimfiles
+ doins -r utils/vim/*/
+ # some users may find it useful
+ dodoc utils/vim/vimrc
if use clang; then
pushd tools/clang >/dev/null || die
if use static-analyzer ; then
- dobin tools/scan-build/ccc-analyzer
+ pushd tools/scan-build >/dev/null || die
+
+ dobin ccc-analyzer scan-build
dosym ccc-analyzer /usr/bin/c++-analyzer
- dobin tools/scan-build/scan-build
+ doman scan-build.1
+
+ insinto /usr/share/llvm
+ doins scanview.css sorttable.js
- insinto /usr/share/${PN}
- doins tools/scan-build/scanview.css
- doins tools/scan-build/sorttable.js
+ popd >/dev/null || die
fi
python_inst() {
@@ -425,7 +426,7 @@ multilib_src_install_all() {
touch __init__.py || die
python_moduleinto clang
- python_domodule __init__.py Reporter.py Resources ScanView.py startfile.py
+ python_domodule *.py Resources
popd >/dev/null || die
fi
@@ -434,7 +435,7 @@ multilib_src_install_all() {
pushd bindings/python/clang >/dev/null || die
python_moduleinto clang
- python_domodule __init__.py cindex.py enumerations.py
+ python_domodule *.py
popd >/dev/null || die
fi