summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/logcheck/ChangeLog8
-rw-r--r--app-admin/logcheck/logcheck-1.3.6.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/app-admin/logcheck/ChangeLog b/app-admin/logcheck/ChangeLog
index 15cd09c5da25..2fb05bc30965 100644
--- a/app-admin/logcheck/ChangeLog
+++ b/app-admin/logcheck/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/logcheck
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/logcheck/ChangeLog,v 1.3 2010/01/02 14:39:05 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logcheck/ChangeLog,v 1.4 2010/01/27 16:50:05 phajdan.jr Exp $
+
+*logcheck-1.3.6 (27 Jan 2010)
+
+ 27 Jan 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ +logcheck-1.3.6.ebuild:
+ Version bump.
*logcheck-1.3.5 (02 Jan 2010)
diff --git a/app-admin/logcheck/logcheck-1.3.6.ebuild b/app-admin/logcheck/logcheck-1.3.6.ebuild
new file mode 100644
index 000000000000..0d993aef1088
--- /dev/null
+++ b/app-admin/logcheck/logcheck-1.3.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logcheck/logcheck-1.3.6.ebuild,v 1.1 2010/01/27 16:50:05 phajdan.jr Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Mails anomalies in the system logfiles to the administrator."
+HOMEPAGE="http://packages.debian.org/sid/logcheck"
+SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!app-admin/logsentry
+ app-misc/lockfile-progs
+ dev-lang/perl
+ virtual/mailx
+ ${DEPEND}"
+
+pkg_setup() {
+ enewgroup logcheck
+ enewuser logcheck -1 -1 -1 logcheck
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-makefile.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ keepdir /var/{lib,lock}/logcheck
+ dodoc AUTHORS CHANGES CREDITS TODO docs/README.* || die "dodoc failed"
+ doman docs/logtail.8 docs/logtail2.8 || die "doman failed"
+
+ exeinto /etc/cron.hourly
+ doexe "${FILESDIR}/${PN}.cron" || die "doexe failed"
+}
+
+pkg_postinst() {
+ chown -R logcheck:logcheck /etc/logcheck /var/{lib,lock}/logcheck \
+ || die "chown failed"
+
+ elog "The configuration files are located in /etc/logcheck. The most"
+ elog "important files are /etc/logcheck/logcheck.conf"
+ elog "and /etc/logcheck/logcheck.logfiles. Also, make sure that"
+ elog "the logcheck user has access to your log files."
+ elog "Finally, uncomment the logcheck line"
+ elog "/etc/cron.hourly/logcheck.cron to enable periodic log checks."
+}