summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/modutils/ChangeLog10
-rw-r--r--sys-apps/modutils/files/digest-modutils-2.4.221
-rw-r--r--sys-apps/modutils/modutils-2.4.22.ebuild36
3 files changed, 46 insertions, 1 deletions
diff --git a/sys-apps/modutils/ChangeLog b/sys-apps/modutils/ChangeLog
index dc43f95b1626..c7d8eb7ea674 100644
--- a/sys-apps/modutils/ChangeLog
+++ b/sys-apps/modutils/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/modutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/ChangeLog,v 1.8 2002/11/02 10:26:40 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/ChangeLog,v 1.9 2002/11/25 18:21:50 lostlogic Exp $
+
+*modutils-2.4.22 (25 Nov 2002)
+
+ 25 Nov 2002; Brandon Low <lostlogic@gentoo.org> modutils-2.4.22.ebuild
+ files/digest-modutils-2.4.22 :
+
+ Version bump still unstable for the moment, lets try to stabilize
+ this quickly.
*modutils-2.4.20 (02 Nov 2002)
diff --git a/sys-apps/modutils/files/digest-modutils-2.4.22 b/sys-apps/modutils/files/digest-modutils-2.4.22
new file mode 100644
index 000000000000..e63ad0bbb764
--- /dev/null
+++ b/sys-apps/modutils/files/digest-modutils-2.4.22
@@ -0,0 +1 @@
+MD5 6c5d2a62ae98708f3ad0c57900d63919 modutils-2.4.22.tar.bz2 219457
diff --git a/sys-apps/modutils/modutils-2.4.22.ebuild b/sys-apps/modutils/modutils-2.4.22.ebuild
new file mode 100644
index 000000000000..cb8ce858cee0
--- /dev/null
+++ b/sys-apps/modutils/modutils-2.4.22.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/modutils-2.4.22.ebuild,v 1.1 2002/11/25 18:21:50 lostlogic Exp $
+
+S=${WORKDIR}/${P}
+SLOT="0"
+DESCRIPTION="Standard kernel module utilities"
+SRC_URI="http://www.kernel.org/pub/linux/utils/kernel/${PN}/v2.4/${P}.tar.bz2"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/modutils/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+LICENSE="GPL-2"
+DEPEND="virtual/glibc"
+
+src_compile() {
+ myconf=""
+ # see bug #3897 ... we need insmod static, as libz.so is in /usr/lib
+ #
+ # Final resolution ... dont make it link against zlib, as the static
+ # version do not want to autoload modules :(
+ myconf="${myconf} --disable-zlib"
+
+ econf \
+ --prefix=/ \
+ --disable-strip \
+ --enable-insmod-static \
+ ${myconf} || die "./configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall prefix="${D}" || die "make install failed"
+
+ dodoc COPYING CREDITS ChangeLog NEWS README TODO
+}