summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/util-linux/ChangeLog10
-rw-r--r--sys-apps/util-linux/files/digest-util-linux-2.13-r36
-rw-r--r--sys-apps/util-linux/files/util-linux-2.13-hwclock-rtc.patch74
-rw-r--r--sys-apps/util-linux/files/util-linux-2.13-losetup-P.patch15
-rw-r--r--sys-apps/util-linux/util-linux-2.13-r3.ebuild89
5 files changed, 193 insertions, 1 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index 5424cc10757d..ec0905e5aed8 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.211 2007/11/19 07:20:20 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.212 2007/12/14 03:18:57 vapier Exp $
+
+*util-linux-2.13-r3 (14 Dec 2007)
+
+ 14 Dec 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/util-linux-2.13-hwclock-rtc.patch,
+ +files/util-linux-2.13-losetup-P.patch, +util-linux-2.13-r3.ebuild:
+ Fix from upstream for rtc/hwclock handling #179780 and fix for losetup -P
+ with loop-aes #201981.
19 Nov 2007; Joshua Kinard <kumba@gentoo.org> util-linux-2.12r-r8.ebuild:
Stable on mips, per #195390.
diff --git a/sys-apps/util-linux/files/digest-util-linux-2.13-r3 b/sys-apps/util-linux/files/digest-util-linux-2.13-r3
new file mode 100644
index 000000000000..35f8c626232c
--- /dev/null
+++ b/sys-apps/util-linux/files/digest-util-linux-2.13-r3
@@ -0,0 +1,6 @@
+MD5 601caadc3248fcd6b5911fc6339451e9 util-linux-ng-2.13-1.diff.bz2 40468
+RMD160 defb0fa7abb39963d1d168c4fbf8352ceb2a916c util-linux-ng-2.13-1.diff.bz2 40468
+SHA256 6606666808f510cc8aeead408e14d3226b06219b0752ca3badea7acd154929cd util-linux-ng-2.13-1.diff.bz2 40468
+MD5 2175a6e64ba0cf8ff05402eaee33e4b0 util-linux-ng-2.13.tar.bz2 2702618
+RMD160 499b1c5c2060b23d8bf504122a22122af99eb7fa util-linux-ng-2.13.tar.bz2 2702618
+SHA256 002412e93d8e85b1796fdbe65bbb0a4d193d0317a7155fda4270667e08bdfbfc util-linux-ng-2.13.tar.bz2 2702618
diff --git a/sys-apps/util-linux/files/util-linux-2.13-hwclock-rtc.patch b/sys-apps/util-linux/files/util-linux-2.13-hwclock-rtc.patch
new file mode 100644
index 000000000000..b62433ca1913
--- /dev/null
+++ b/sys-apps/util-linux/files/util-linux-2.13-hwclock-rtc.patch
@@ -0,0 +1,74 @@
+http://bugs.gentoo.org/179780
+
+From: Matthias Koenig <mkoenig@suse.de>
+Date: Thu, 20 Sep 2007 09:11:18 +0000 (+0200)
+Subject: hwclock: fix --rtc option
+X-Git-Url: http://git.kernel.org/?p=utils%2Futil-linux-ng%2Futil-linux-ng.git;a=commitdiff_plain;h=5d1f6bae3b298809ecd63b3e55f6ab30caaa4dbf
+
+hwclock: fix --rtc option
+
+The --rtc option does not set the name of the device correctly.
+It still uses /dev/rtc even if the --rtc option is given.
+
+Testcase:
+$ mv /dev/rtc /dev/foo
+$ hwclock --show --debug --rtc=/dev/foo
+hwclock from util-linux-2.13-rc2
+Using /dev interface to clock.
+Last drift adjustment done at 1190198135 seconds after 1969
+Last calibration done at 1190198135 seconds after 1969
+Hardware clock is on local time
+Assuming hardware clock is kept in local time.
+Waiting for clock tick...
+hwclock: open() of /dev/rtc failed, errno=2: No such file or directory.
+...got clock tick
+
+Co-Author: Karel Zak <kzak@redhat.com>
+Signed-off-by: Matthias Koenig <mkoenig@suse.de>
+Signed-off-by: Karel Zak <kzak@redhat.com>
+---
+
+diff --git a/hwclock/rtc.c b/hwclock/rtc.c
+index f8e626e..724daf9 100644
+--- a/hwclock/rtc.c
++++ b/hwclock/rtc.c
+@@ -104,24 +104,21 @@ open_rtc(void) {
+ "/dev/misc/rtc",
+ NULL
+ };
+- char **p = fls;
+- char *fname = rtc_dev_name ? : *p;
+-
+- do {
+- int fd = open(fname, O_RDONLY);
+-
+- if (fd < 0 && errno == ENOENT) {
+- if (fname == rtc_dev_name)
+- break;
+- fname = *++p;
+- } else {
+- rtc_dev_name = *p;
+- return fd;
+- }
+- } while(fname);
+-
+- if (!rtc_dev_name)
+- rtc_dev_name = *fls;
++ char **p;
++
++ /* --rtc option has been given */
++ if (rtc_dev_name)
++ return open(rtc_dev_name, O_RDONLY);
++
++ for (p=fls; *p; ++p) {
++ int fd = open(*p, O_RDONLY);
++
++ if (fd < 0 && errno == ENOENT)
++ continue;
++ rtc_dev_name = *p;
++ return fd;
++ }
++ rtc_dev_name = *fls; /* default */
+ return -1;
+ }
+
diff --git a/sys-apps/util-linux/files/util-linux-2.13-losetup-P.patch b/sys-apps/util-linux/files/util-linux-2.13-losetup-P.patch
new file mode 100644
index 000000000000..65ac03084fb6
--- /dev/null
+++ b/sys-apps/util-linux/files/util-linux-2.13-losetup-P.patch
@@ -0,0 +1,15 @@
+loop-aes patch forgets to include -P in getopt call
+
+http://bugs.gentoo.org/201981
+
+--- mount/lomount.c
++++ mount/lomount.c
+@@ -1249,7 +1249,7 @@
+
+ delete = 0;
+ progname = argv[0];
+- while ((c = getopt(argc,argv,"aC:de:FG:H:I:K:o:p:rRs:S:Tv")) != -1) {
++ while ((c = getopt(argc,argv,"aC:de:FG:H:I:K:o:p:rRs:S:TvP:")) != -1) {
+ switch (c) {
+ case 'a': /* show status of all loops */
+ option_a = 1;
diff --git a/sys-apps/util-linux/util-linux-2.13-r3.ebuild b/sys-apps/util-linux/util-linux-2.13-r3.ebuild
new file mode 100644
index 000000000000..ae458c69ed0a
--- /dev/null
+++ b/sys-apps/util-linux/util-linux-2.13-r3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.13-r3.ebuild,v 1.1 2007/12/14 03:18:57 vapier Exp $
+
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
+inherit eutils
+[[ ${PV} == "9999" ]] && inherit git
+
+MY_PV=${PV/_/-}
+MY_P=${PN}-ng-${MY_PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Various useful Linux utilities"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux-ng/"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+else
+ SRC_URI="http://www.kernel.org/pub/linux/utils/util-linux-ng/v${PV:0:4}/${MY_P}.tar.bz2
+ crypt? ( http://loop-aes.sourceforge.net/updates/${MY_P}-1.diff.bz2 )"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="crypt nls old-linux selinux"
+
+RDEPEND="!sys-process/schedutils
+ !sys-apps/setarch
+ >=sys-libs/ncurses-5.2-r2
+ >=sys-fs/e2fsprogs-1.34
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/os-headers"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git_src_unpack
+ cd "${S}"
+ ./autogen.sh || die
+ else
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-locale.patch #191111
+ epatch "${FILESDIR}"/${P}-ioprio-syscalls.patch #190613
+ epatch "${FILESDIR}"/${P}-setuid-checks.patch
+ epatch "${FILESDIR}"/${P}-script-SIGWINCH.patch #191452
+ epatch "${FILESDIR}"/${P}-hwclock-rtc.patch #179780
+ use crypt && epatch "${WORKDIR}"/${MY_P}-1.diff "${FILESDIR}"/${P}-losetup-P.patch #201981
+ sed -i '/#include <asm\/page.h>/d' mount/swapon.c || die
+ fi
+}
+
+src_compile() {
+ export localedir="/usr/share/locale" #190895
+ econf \
+ --with-fsprobe=blkid \
+ $(use_enable nls) \
+ --enable-agetty \
+ --enable-cramfs \
+ $(use_enable old-linux elvtune) \
+ --disable-init \
+ --disable-kill \
+ --disable-last \
+ --disable-mesg \
+ --enable-partx \
+ --enable-raw \
+ --enable-rdev \
+ --enable-rename \
+ --disable-reset \
+ --disable-login-utils \
+ --enable-schedutils \
+ --disable-wall \
+ --enable-write \
+ --without-pam \
+ $(use_with selinux) \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS NEWS README* TODO docs/*
+
+ if use crypt ; then
+ newinitd "${FILESDIR}"/crypto-loop.initd crypto-loop || die
+ newconfd "${FILESDIR}"/crypto-loop.confd crypto-loop || die
+ fi
+}