summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/cppcheck/ChangeLog6
-rw-r--r--dev-util/cppcheck/cppcheck-1.46.1.ebuild16
2 files changed, 17 insertions, 5 deletions
diff --git a/dev-util/cppcheck/ChangeLog b/dev-util/cppcheck/ChangeLog
index 3450609cd509..62be7a56e015 100644
--- a/dev-util/cppcheck/ChangeLog
+++ b/dev-util/cppcheck/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/cppcheck
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.21 2011/01/08 20:15:26 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.22 2011/01/08 20:18:03 arfrever Exp $
+
+ 08 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ cppcheck-1.46.1.ebuild:
+ Fix deprecation warning.
08 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-cppcheck-1.41-r1.ebuild, -cppcheck-1.43.ebuild, -cppcheck-1.44.ebuild,
diff --git a/dev-util/cppcheck/cppcheck-1.46.1.ebuild b/dev-util/cppcheck/cppcheck-1.46.1.ebuild
index f12e4ebaf70a..2ba5e723b2a0 100644
--- a/dev-util/cppcheck/cppcheck-1.46.1.ebuild
+++ b/dev-util/cppcheck/cppcheck-1.46.1.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.46.1.ebuild,v 1.1 2011/01/01 15:12:42 xmw Exp $
-
-EAPI=2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.46.1.ebuild,v 1.2 2011/01/08 20:18:03 arfrever Exp $
+EAPI="3"
PYTHON_DEPEND="htmlreport? 2"
-inherit distutils eutils python toolchain-funcs qt4-r2
+inherit distutils eutils qt4-r2 toolchain-funcs
DESCRIPTION="static analyzer of C/C++ code"
HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
@@ -20,6 +19,7 @@ IUSE="htmlreport qt4"
DEPEND="htmlreport? ( dev-python/pygments )
qt4? ( x11-libs/qt-gui:4
x11-libs/qt-assistant:4 )"
+RDEPEND="${DEPEND}"
pkg_setup() {
if use htmlreport ; then
@@ -73,3 +73,11 @@ src_install() {
popd
fi
}
+
+pkg_postinst() {
+ use htmlreport && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use htmlreport && distutils_pkg_postrm
+}