summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/alsa-utils/ChangeLog12
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.27-r1.ebuild77
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.27-alsactl.patch27
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.27-arecord.patch24
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.27-service.patch12
5 files changed, 151 insertions, 1 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 97543133d939..b7c671465c46 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.345 2013/05/01 12:16:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.346 2013/05/01 16:18:18 ssuominen Exp $
+
+*alsa-utils-1.0.27-r1 (01 May 2013)
+
+ 01 May 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +alsa-utils-1.0.27-r1.ebuild, +files/alsa-utils-1.0.27-alsactl.patch,
+ +files/alsa-utils-1.0.27-arecord.patch,
+ +files/alsa-utils-1.0.27-service.patch:
+ Fix typing error in alsa-restore.service systemd file. Fix missing break to
+ the capture loop in arecord. Fix buffer overflow in alsactl wrt #468160 by
+ "John"
01 May 2013; Samuli Suominen <ssuominen@gentoo.org>
-alsa-utils-1.0.24.2-r1.ebuild, -alsa-utils-1.0.25-r1.ebuild,
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.27-r1.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.27-r1.ebuild
new file mode 100644
index 000000000000..64722dcfa8da
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.27-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.27-r1.ebuild,v 1.1 2013/05/01 16:18:18 ssuominen Exp $
+
+EAPI=5
+inherit eutils systemd udev
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${P}.tar.bz2
+ mirror://alsaproject/driver/alsa-driver-1.0.25.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc +libsamplerate +ncurses nls selinux"
+
+RDEPEND=">=media-libs/alsa-lib-${PV}
+ libsamplerate? ( media-libs/libsamplerate )
+ ncurses? ( >=sys-libs/ncurses-5.7-r7 )
+ selinux? ( sec-policy/selinux-alsa )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.0.25-separate-usr-var-fs.patch \
+ "${FILESDIR}"/${P}-service.patch \
+ "${FILESDIR}"/${P}-arecord.patch \
+ "${FILESDIR}"/${P}-alsactl.patch
+}
+
+src_configure() {
+ local myconf
+ use doc || myconf='--disable-xmlto'
+
+ # --disable-alsaconf because it doesn't work with sys-apps/kmod wrt #456214
+ econf \
+ $(use_enable libsamplerate alsaloop) \
+ $(use_enable nls) \
+ $(use_enable ncurses alsamixer) \
+ --disable-alsaconf \
+ "$(systemd_with_unitdir)" \
+ --with-udev-rules-dir="$(get_udevdir)"/rules.d \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog README TODO seq/*/README.*
+
+ newbin "${WORKDIR}"/alsa-driver-*/utils/alsa-info.sh alsa-info
+
+ newinitd "${FILESDIR}"/alsasound.initd-r5 alsasound
+ newconfd "${FILESDIR}"/alsasound.confd-r4 alsasound
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/alsa-modules.conf-rc alsa.conf
+
+ keepdir /var/lib/alsa
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog "# rc-update add alsasound boot"
+ ewarn
+ ewarn "The ALSA core should be built into the kernel or loaded through other"
+ ewarn "means. There is no longer any modular auto(un)loading in alsa-utils."
+ fi
+}
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.27-alsactl.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.27-alsactl.patch
new file mode 100644
index 000000000000..3b5a761db492
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.27-alsactl.patch
@@ -0,0 +1,27 @@
+http://bugs.gentoo.org/468160
+
+From: Jaroslav Kysela <perex@perex.cz>
+Date: Mon, 15 Apr 2013 12:44:13 +0000 (+0200)
+Subject: alsactl: Fix the string size for the lock file contents
+X-Git-Url: http://git.alsa-project.org/?p=alsa-utils.git;a=commitdiff_plain;h=95788fea25c1a59985828d4b91af0772d077600b
+
+alsactl: Fix the string size for the lock file contents
+
+The string length is 10 characters + LF + '\0' = 12 characters.
+
+Signed-off-by: Jaroslav Kysela <perex@perex.cz>
+---
+
+diff --git a/alsactl/lock.c b/alsactl/lock.c
+index d34d013..fce208b 100644
+--- a/alsactl/lock.c
++++ b/alsactl/lock.c
+@@ -35,7 +35,7 @@ static int state_lock_(const char *file, int lock, int timeout)
+ int fd = -1, err = 0;
+ struct flock lck;
+ struct stat st;
+- char lcktxt[11];
++ char lcktxt[12];
+ char *nfile;
+
+ if (!do_lock)
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.27-arecord.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.27-arecord.patch
new file mode 100644
index 000000000000..f9edb2d21363
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.27-arecord.patch
@@ -0,0 +1,24 @@
+From: Jaroslav Kysela <perex@perex.cz>
+Date: Wed, 17 Apr 2013 06:34:34 +0000 (+0200)
+Subject: arecord: add a missing break to the capture loop
+X-Git-Url: http://git.alsa-project.org/?p=alsa-utils.git;a=commitdiff_plain;h=b4f34ac26037c10ac51c4bb29203500165848977
+
+arecord: add a missing break to the capture loop
+
+Signed-off-by: Jaroslav Kysela <perex@perex.cz>
+---
+
+diff --git a/aplay/aplay.c b/aplay/aplay.c
+index 5bdc39c..000d25b 100644
+--- a/aplay/aplay.c
++++ b/aplay/aplay.c
+@@ -3021,6 +3021,9 @@ static void capture(char *orig_name)
+ fd = -1;
+ }
+
++ if (in_aborting)
++ break;
++
+ /* repeat the loop when format is raw without timelimit or
+ * requested counts of data are recorded
+ */
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.27-service.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.27-service.patch
new file mode 100644
index 000000000000..dfe83e011ddc
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.27-service.patch
@@ -0,0 +1,12 @@
+http://git.alsa-project.org/?p=alsa-utils.git;a=commitdiff;h=3616b1fe3ca603832b2f88abeb722cba2f0dde7e
+
+--- alsactl/alsa-restore.service.in
++++ alsactl/alsa-restore.service.in
+@@ -12,6 +12,6 @@
+ Conflicts=shutdown.target
+
+ [Service]
+-Type=oneshop
++Type=oneshot
+ ExecStart=-@sbindir@/alsactl restore
+ StandardOutput=syslog