summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/awesome/ChangeLog9
-rw-r--r--x11-wm/awesome/awesome-3.5.4.ebuild132
-rw-r--r--x11-wm/awesome/files/awesome-3.5.4-imagebox.patch28
3 files changed, 168 insertions, 1 deletions
diff --git a/x11-wm/awesome/ChangeLog b/x11-wm/awesome/ChangeLog
index 3c66a0cdc421..6be7f1195ccd 100644
--- a/x11-wm/awesome/ChangeLog
+++ b/x11-wm/awesome/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/awesome
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/awesome/ChangeLog,v 1.160 2014/03/31 17:14:12 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/awesome/ChangeLog,v 1.161 2014/04/03 19:16:52 maksbotan Exp $
+
+*awesome-3.5.4 (03 Apr 2014)
+
+ 03 Apr 2014; Maxim Koltsov <maksbotan@gentoo.org> +awesome-3.5.4.ebuild,
+ +files/awesome-3.5.4-imagebox.patch:
+ Bump to 3.5.4, add upstream patch for imagebox, bug #506586. Thanks to Bohdan
+ Trach <bv.trach@gmail.com>.
*awesome-3.5.3 (31 Mar 2014)
diff --git a/x11-wm/awesome/awesome-3.5.4.ebuild b/x11-wm/awesome/awesome-3.5.4.ebuild
new file mode 100644
index 000000000000..025c1163fa89
--- /dev/null
+++ b/x11-wm/awesome/awesome-3.5.4.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/awesome/awesome-3.5.4.ebuild,v 1.1 2014/04/03 19:16:52 maksbotan Exp $
+
+EAPI="5"
+CMAKE_MIN_VERSION="2.8"
+inherit cmake-utils eutils
+
+DESCRIPTION="A dynamic floating and tiling window manager"
+HOMEPAGE="http://awesome.naquadah.org/"
+SRC_URI="http://awesome.naquadah.org/download/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="dbus doc elibc_FreeBSD gnome"
+
+COMMON_DEPEND="
+ >=dev-lang/lua-5.1
+ dev-libs/glib:2
+ >=dev-libs/libxdg-basedir-1
+ >=dev-lua/lgi-0.7
+ x11-libs/cairo[xcb]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/libxcb-1.6
+ >=x11-libs/pango-1.19.3[introspection]
+ >=x11-libs/startup-notification-0.10_p20110426
+ >=x11-libs/xcb-util-0.3.8
+ x11-libs/xcb-util-cursor
+ x11-libs/libXcursor
+ || ( <x11-libs/libX11-1.3.99.901[xcb] >=x11-libs/libX11-1.3.99.901 )
+ dbus? ( >=sys-apps/dbus-1 )
+ elibc_FreeBSD? ( dev-libs/libexecinfo )"
+
+# graphicsmagick's 'convert -channel' has no Alpha support, bug #352282
+DEPEND="${COMMON_DEPEND}
+ >=app-text/asciidoc-8.4.5
+ app-text/xmlto
+ dev-util/gperf
+ virtual/pkgconfig
+ media-gfx/imagemagick[png]
+ >=x11-proto/xcb-proto-1.5
+ >=x11-proto/xproto-7.0.15
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DOCS="AUTHORS BUGS PATCHES README STYLE"
+
+src_prepare() {
+ # bug #408025
+ epatch "${FILESDIR}/${PN}-3.5_rc1-convert-path.patch"
+ epatch "${FILESDIR}/${PN}-xsession.patch"
+
+ # bug #506586
+ epatch "${FILESDIR}/${P}-imagebox.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DPREFIX="${EPREFIX}"/usr
+ -DSYSCONFDIR="${EPREFIX}"/etc
+ $(cmake-utils_use_with dbus DBUS)
+ $(cmake-utils_use doc GENERATE_DOC)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ local myargs="all"
+
+ if use doc ; then
+ myargs="${myargs} doc"
+ fi
+ cmake-utils_src_make ${myargs}
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use doc ; then
+ (
+ cd "${CMAKE_BUILD_DIR}"/doc
+ mv html doxygen
+ dohtml -r doxygen || die
+ )
+ fi
+ rm -rf "${ED}"/usr/share/doc/${PN} || die "Cleanup of dupe docs failed"
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session ${PN} || die
+
+ # GNOME-based awesome
+ if use gnome ; then
+ # GNOME session
+ insinto /usr/share/gnome-session/sessions
+ newins "${FILESDIR}/${PN}-gnome-3.session" "${PN}-gnome.session" || die
+ # Application launcher
+ domenu "${FILESDIR}/${PN}-gnome.desktop" || die
+ # X Session
+ insinto /usr/share/xsessions/
+ doins "${FILESDIR}/${PN}-gnome-xsession.desktop" || die
+ fi
+}
+
+pkg_postinst() {
+ # bug #447308
+ if use gnome; then
+ elog
+ elog "You have enabled the gnome USE flag."
+ elog "Please note that quitting awesome won't kill your gnome session."
+ elog "To really quit the session, you should bind your quit key"
+ elog "to the following command:"
+ elog " gnome-session-quit --logout"
+ elog "For more info visit"
+ elog " https://bugs.gentoo.org/show_bug.cgi?id=447308"
+ fi
+
+ # bug #440724
+ elog
+ elog "If you are having issues with Java application windows being"
+ elog "completely blank, try installing"
+ elog " x11-misc/wmname"
+ elog "and setting the WM name to LG3D."
+ elog "For more info visit"
+ elog " https://bugs.gentoo.org/show_bug.cgi?id=440724"
+ elog
+}
diff --git a/x11-wm/awesome/files/awesome-3.5.4-imagebox.patch b/x11-wm/awesome/files/awesome-3.5.4-imagebox.patch
new file mode 100644
index 000000000000..7d224f24302e
--- /dev/null
+++ b/x11-wm/awesome/files/awesome-3.5.4-imagebox.patch
@@ -0,0 +1,28 @@
+From: Uli Schlachter <psychon@znc.in>
+Date: Wed, 2 Apr 2014 20:48:06 +0000 (+0200)
+Subject: imagebox: Don't try to scale by infinite (FS#1248)
+X-Git-Url: http://git.naquadah.org/?p=awesome.git;a=commitdiff_plain;h=7967d05915c95c8eba7709a46093cc1b6de55572;hp=afa50904fb1c79a24ddda8fb242afe2dcc1de841
+
+imagebox: Don't try to scale by infinite (FS#1248)
+
+When an imagebox was drawn with width or height zero, it tried to calculate the
+needed scale factor for making the image fit. Sadly, this would be a division by
+zero aka infinite in this case.
+
+Fix this by just not drawing anything if there is no space available.
+
+Signed-off-by: Uli Schlachter <psychon@znc.in>
+---
+
+diff --git a/lib/wibox/widget/imagebox.lua.in b/lib/wibox/widget/imagebox.lua.in
+index da51634..5963d0e 100644
+--- a/lib/wibox/widget/imagebox.lua.in
++++ b/lib/wibox/widget/imagebox.lua.in
+@@ -18,6 +18,7 @@ local imagebox = { mt = {} }
+ --- Draw an imagebox with the given cairo context in the given geometry.
+ function imagebox:draw(wibox, cr, width, height)
+ if not self._image then return end
++ if width == 0 or height == 0 then return end
+
+ cr:save()
+