summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-antivirus/klamav/klamav-0.41.1.ebuild')
-rw-r--r--app-antivirus/klamav/klamav-0.41.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-antivirus/klamav/klamav-0.41.1.ebuild b/app-antivirus/klamav/klamav-0.41.1.ebuild
new file mode 100644
index 000000000000..a5719ccf2d58
--- /dev/null
+++ b/app-antivirus/klamav/klamav-0.41.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/klamav/klamav-0.41.1.ebuild,v 1.1 2007/12/30 12:50:17 mattepiu Exp $
+
+inherit kde
+
+MY_P="${P}-source"
+S="${WORKDIR}/${MY_P}/${P}"
+
+DESCRIPTION="KlamAV is a KDE frontend for the ClamAV antivirus."
+HOMEPAGE="http://klamav.sourceforge.net/"
+SRC_URI="mirror://sourceforge/klamav/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=app-antivirus/clamav-0.90"
+RDEPEND="${DEPEND}"
+
+need-kde 3.4
+
+PATCHES="${FILESDIR}/${P}-cl_loaddbdir.patch
+ ${FILESDIR}/klamav-gentempdesc.patch"
+
+src_unpack(){
+ kde_src_unpack
+ # Assure a future version won't try to build this.
+ rm -rf "${WORKDIR}/${MY_P}/dazuko"* || die "We missed to eradicate some files"
+}
+
+pkg_postinst(){
+ elog "The on-access scanning functionality is provided by"
+ elog "the Dazuko kernel module: emerge sys-fs/dazuko"
+}