summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/pure-sfv/pure-sfv-0.3.ebuild')
-rw-r--r--app-arch/pure-sfv/pure-sfv-0.3.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-arch/pure-sfv/pure-sfv-0.3.ebuild b/app-arch/pure-sfv/pure-sfv-0.3.ebuild
index 506fa1aceea6..0f01003968b6 100644
--- a/app-arch/pure-sfv/pure-sfv-0.3.ebuild
+++ b/app-arch/pure-sfv/pure-sfv-0.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pure-sfv/pure-sfv-0.3.ebuild,v 1.13 2006/01/29 07:36:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pure-sfv/pure-sfv-0.3.ebuild,v 1.14 2008/10/23 02:43:22 flameeyes Exp $
+
+inherit toolchain-funcs
DESCRIPTION="utility to test and create .sfv files and create .par files"
HOMEPAGE="http://pure-sfv.sourceforge.net/"
@@ -22,6 +24,10 @@ src_unpack() {
sed -i 's:-O2 -g::;s:-Werror::' Makefile
}
+src_compile() {
+ emake CC="$(tc_getCC)" || die "emake failed"
+}
+
src_install() {
dobin pure-sfv || die
dodoc ReadMe.txt