summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/gpgme/gpgme-1.2.0.ebuild')
-rw-r--r--app-crypt/gpgme/gpgme-1.2.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/app-crypt/gpgme/gpgme-1.2.0.ebuild b/app-crypt/gpgme/gpgme-1.2.0.ebuild
deleted file mode 100644
index 1107ac0ff717..000000000000
--- a/app-crypt/gpgme/gpgme-1.2.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-1.2.0.ebuild,v 1.11 2010/04/01 21:30:45 abcd Exp $
-
-EAPI="3"
-
-inherit libtool eutils
-
-DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
-HOMEPAGE="http://www.gnupg.org/related_software/gpgme"
-SRC_URI="mirror://gnupg/gpgme/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="1"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="common-lisp pth"
-
-DEPEND=">=dev-libs/libgpg-error-1.4
- app-crypt/gnupg
- pth? ( >=dev-libs/pth-1.2 )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-1.1.8-et_EE.patch"
- epatch "${FILESDIR}/${P}-fix_implicit_declaration.patch"
-
- # Call elibtoolize to get sane .so versioning on FreeBSD.
- elibtoolize
-}
-
-src_configure() {
- econf \
- --includedir="${EPREFIX}/usr/include/gpgme" \
- --with-gpg="${EPREFIX}/usr/bin/gpg" \
- --with-gpgsm="${EPREFIX}/usr/bin/gpgsm" \
- $(use_with pth)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO
-
- if ! use common-lisp; then
- rm -fr "${ED}usr/share/common-lisp"
- fi
-}