summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/qemacs/files/qemacs-0.3.2_pre20070226-Makefile-gentoo.patch')
-rw-r--r--app-editors/qemacs/files/qemacs-0.3.2_pre20070226-Makefile-gentoo.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-editors/qemacs/files/qemacs-0.3.2_pre20070226-Makefile-gentoo.patch b/app-editors/qemacs/files/qemacs-0.3.2_pre20070226-Makefile-gentoo.patch
new file mode 100644
index 000000000000..7cb542cdc36d
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.3.2_pre20070226-Makefile-gentoo.patch
@@ -0,0 +1,45 @@
+diff -u ../qemacs/Makefile ./Makefile
+--- ../qemacs/Makefile 2007-02-06 18:41:16.000000000 +0100
++++ ./Makefile 2007-02-26 14:03:24.000000000 +0100
+@@ -38,15 +38,6 @@
+ LDFLAGS+= -p
+ endif
+
+-ifdef TARGET_ARCH_X86
+-#CFLAGS+=-fomit-frame-pointer
+-ifeq ($(GCC_MAJOR),2)
+-CFLAGS+=-m386 -malign-functions=0
+-else
+-CFLAGS+=-march=i386 -falign-functions=0
+-endif
+-endif
+-
+ DEFINES=-DHAVE_QE_CONFIG_H
+
+ ########################################################
+@@ -211,15 +202,17 @@
+ rm -f config.h config.mak
+
+ install: $(TARGETS) qe.1 kmaps ligatures
+- install -m 755 qe$(EXE) $(prefix)/bin/qemacs
+- ln -sf qemacs $(prefix)/bin/qe$(EXE)
++ mkdir -p $(DESTDIR)$(prefix)/bin
++ install -m 755 qe $(DESTDIR)$(prefix)/bin/qemacs
++ install -m 755 libqhtml/csstoqe $(DESTDIR)$(prefix)/bin/csstoqe
+ ifdef CONFIG_FFMPEG
+- ln -sf qemacs $(prefix)/bin/ffplay
++ ln -sf qemacs $(DESTDIR)$(prefix)/bin/qemacs-ffplay
+ endif
+- mkdir -p $(prefix)/share/qe
+- install kmaps ligatures $(prefix)/share/qe
+- install qe.1 $(prefix)/man/man1
++ mkdir -p $(DESTDIR)$(prefix)/share/qemacs
++ install -m644 kmaps ligatures $(DESTDIR)$(prefix)/share/qe
++ mkdir -p $(DESTDIR)$(prefix)/share/man/man1
++ install -m644 qe.1 $(DESTDIR)$(prefix)/share/man/man1/qemacs.1
+ ifdef CONFIG_HTML
+- install -m 755 -s html2png$(EXE) $(prefix)/bin
++ install -m 755 -s html2png $(DESTDIR)$(prefix)/bin
+ endif
+
+ TAGS: force \ No newline at end of file