summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/org-mode/org-mode-5.21.ebuild')
-rw-r--r--app-emacs/org-mode/org-mode-5.21.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/org-mode/org-mode-5.21.ebuild b/app-emacs/org-mode/org-mode-5.21.ebuild
new file mode 100644
index 000000000000..db601031dd71
--- /dev/null
+++ b/app-emacs/org-mode/org-mode-5.21.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/org-mode-5.21.ebuild,v 1.1 2008/02/07 17:44:32 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="An Emacs mode for notes and project planning"
+HOMEPAGE="http://www.orgmode.org/"
+SRC_URI="http://orgmode.org/org-${PV}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+SITEFILE="51${PN}-gentoo.el"
+DOCS="README ChangeLog org.pdf orgcard.pdf"
+
+S="${WORKDIR}/org-${PV}"
+
+src_compile() {
+ elisp_src_compile
+ emake info || die "emake info failed"
+ mv org org.info || die "Infofile could not be renamed"
+}
+
+src_install() {
+ elisp_src_install
+ doinfo *.info
+}