summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/riece/riece-3.1.1.ebuild')
-rw-r--r--app-emacs/riece/riece-3.1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/riece/riece-3.1.1.ebuild b/app-emacs/riece/riece-3.1.1.ebuild
new file mode 100644
index 000000000000..e1c327a29424
--- /dev/null
+++ b/app-emacs/riece/riece-3.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/riece/riece-3.1.1.ebuild,v 1.1 2006/11/14 16:54:37 usata Exp $
+
+inherit elisp
+
+IUSE=""
+S="${WORKDIR}/${P/b/}"
+
+DESCRIPTION="Riece is a redesign of Liece IRC client"
+HOMEPAGE="http://www.nongnu.org/riece/"
+SRC_URI="http://savannah.nongnu.org/download/riece/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~ppc ~ppc64 ~amd64 ~ppc-macos"
+
+SITEFILE=50riece-gentoo.el
+
+src_compile() {
+
+ econf --with-lispdir=${SITELISP} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+
+ einstall lispdir=${D}/${SITELISP} || die "einstall failed"
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}